portal entry

select a category, or use search below
(searches all categories and all time range)
Title:

CF18 install for iis

| View in Portal
October 29, 2018 09:27:50 PM GMT
16 Comments
<p>Installing CF18 under Windows 10. Choosing the External Server option, the install package drops me off with “Installation Complete.” Then it tells me I “may now deploy Adobe Coldfusion 2018 to your application server.” I do not get the usual dialog box within the installation routine that allows me to configure my servers (IIS). So, where do I go? What do I further install to get up and running? The installation routine created the folder, ColdFusion2018, which has a text […]</p>
<p>The post <a rel="nofollow" href="https://coldfusion.adobe.com/2018/10/cf18-install-for-iis/">CF18 install for iis</a> appeared first on <a rel="nofollow" href="https://coldfusion.adobe.com">ColdFusion</a>.</p>
Labels: CF2018 Updates, ColdFusion 2018, Question, cf2018 updates, ColdFusion, coldfusion 2018, question

Comments:

Sounds like you mistakenly installed the Java JEE version of ColdFusion.  It's now waiting for you to deploy the CF WAR/EAR to your Java application server.  You need to uninstall and reinstall making sure to install the Stand-alone server version.
Comment by Paul Mascari
1322 | October 30, 2018 03:07:08 PM GMT
Adding to Paul's comment, I would wonder if in fact you may say  I only had one option", which would mean that the installer thought that cf (in the server form) was ALREADY installed. Have you checked that, Jack? Besides looking for a coldfusion2018 folder (which could have been deleted without uninstalling), look also for cf in the windows services panel. And there may be a registry key that the installer looks to in order to know if cf was already installed.
Comment by Charlie Arehart
1325 | October 31, 2018 01:16:56 PM GMT
Paul, this is exactly the fork I've been laboring over. The "standalone" option creates a server under the ColdFusion2018 directory structure, which is not what I want. The JEE options installs coldfusion and lets me configure my iis servers. I truly hope I'm not misremembering this process, but this is the path I think I've always taken. Only, in the past, the installer brought up the deploy/configure module. The JEE path dropped me off with this: "You have successfully completed the first step in installing Adobe ColdFusion 2018. You may now deploy Adobe ColdFusion2018 to your application server. Once you have deployed to your application server, you can continue by loggin in to the Configuration Wizard at (path to CF Administrator)." I don't have a copy of wsconfig.exe on my system. I don't know how to proceed. Thanks!
Comment by Jack_Allred2
1363 | November 05, 2018 10:29:22 PM GMT
Guys, my problem exists because I am attempting to install anew on a Windows 10, 64 bit laptop. I have a perfectly good, running CF server on my 32 bit, Windows 7 desktop. What I need is to install a 32 bit version of SQLServer there. It seems that no such animal exists for download anymore. THAT was why I'm trying to install ColdFusion2018 in the first place.
Comment by Jack_Allred2
1364 | November 05, 2018 10:34:15 PM GMT
Jack, where then ARE YOU wanting cf to be installed, if not to the cf2018 folder? (and you do realize you could tell it to install to any drive and folder,  right?) I'm wondering: are you focused more on where you want you cf code to go? That would NOT typically be the cf2018 folder.
Comment by Charlie Arehart
1367 | November 06, 2018 03:44:48 PM GMT
Did you really mean sql server or cf? If CF, that's true: it no longer supports 32bit.
Comment by Charlie Arehart
1366 | November 06, 2018 03:48:54 PM GMT
I see the same thing in my developer install. It only lets me select "Stand alone" or "JEE" but I am looking for a way to get it to install into an existing IIS. Our current production environment is CF 2016 running integrated with IIS. Hoping to mirror that with a new development CF 2018 environment and so far am not able to get the connectors to install even manually. Not sure how a stand-alone or JEE based install would affect our codebase if I can 't get the connectors to behave.
Comment by wubwub
1530 | January 09, 2019 05:11:24 PM GMT
There is no such thing as installing cf (itself) "into" iis. To be clear, you can integrate CF WITH IIS, either during the standalone install (if it detects iis running) or with the cf web server config tool. But look, if either of you just want your issue solved, rather than lots of back and forth here, I can help, in a screen share session, I'm sure (or you won't pay for my time). More at carehart.org/consulting.
Comment by Charlie Arehart
1531 | January 10, 2019 02:48:33 AM GMT
Hi all, Adobe removed the wsconfig options from CF2018's installer when choosing the standalone option. Here's a discussion (well, mostly w/ myself LOL ;)) regarding sensibly restoring the wsconfig options to installer UI when "Developer Edition" was selected: https://tracker.adobe.com/#/view/cf-4202894 Thanks!, -Aaron
Comment by Aaron Neff
1534 | January 12, 2019 04:15:57 AM GMT
Aaron, you must be experiencing some other problem. What you say is not true. The dev and standalone edition installers DO indeed present the web server config out of the box. The only reasons I can think were if it detected no web server, or if that web server lacked needed features (like isapi filters in iis), or perhaps in your case if all sites were already configured for a previous edition. And as for the bug report, and how no one from Adobe contended against your statements  I can't explain, other than it was back during the prerelease, so perhaps they presumed yours was a unique experience. Can you check again?
Comment by Charlie Arehart
1540 | January 15, 2019 03:32:32 AM GMT
Hi Charlie, Sorry for the delay. To re-confirm, I just now downloaded the CF2018 installer on a *brand new* Windows 2016 VM, then installed IIS (including ISAPI Extensions and Filters, CGI and ASP.Net). In IIS I also added a second site (in addition to the Default site). Then ran CF2018 installer and was never presented w/ the web server config screen. I've attached a PDF of the screens I saw to ticket <a href="https://tracker.adobe.com/#/view/cf-4202894" rel="nofollow">https://tracker.adobe.com/#/view/cf-4202894</a> as CF2018_InstallerScreens.pdf. If I run wsconfig.exe manually, and choose IIS, it lists both the Default site and the one I added. And the UI also displays this text: "Total WebSites: 2 Configurable WebSites: 2". Do you see additional screens that my PDF doesn't show? Thanks!, -Aaron
Comment by Aaron Neff
1634 | February 06, 2019 10:43:59 AM GMT
I edited my reply, by adding "test edit" beneath my signature. Then clicked Save. However.. it did not save.
Comment by Aaron Neff
1633 | February 06, 2019 10:45:21 AM GMT
<p>But Aaron, you present this as if anyone would experience it. Not only have I not experienced it (on multiple cf2018 installs, of my own and in my consulting), but I have also not seen anyone else report it, beyond this thread. Surely if this was a problem happening in all such configurations we would hear of it.</p><p>If you’ll reach out to me directly I’d like to check some things with you, if you’re interested</p>
Comment by Charlie Arehart
1635 | February 06, 2019 02:06:37 PM GMT
Hi Charlie, That's certainly interesting that we're seeing differently. Sure, I messaged you in Slack PM. I too would like to get to the bottom of this.<span> </span> And I wish Adobe would reply on that ticket as to what behavior we -should- be seeing. Thanks!, -Aaron
Comment by Aaron Neff
1651 | February 08, 2019 09:07:17 AM GMT
Hi Charlie, I asked Adobe, and this is their reply: "For CF2018, you should not be seeing the webserver config screen. That is how it is designed. I am not sure how is Charlie getting to the page. Can I ask if Charlie is using a new installer or if he is using a beta or Alpha build?" Thanks!, -Aaron
Comment by Aaron Neff
1652 | February 08, 2019 02:17:24 PM GMT
I'm trying to install CF 2018 on windows and I don't see option for external webserver. Please help.
Comment by ah_dc
1756 | February 13, 2019 07:26:25 PM GMT