portal entry

select a category, or use search below
(searches all categories and all time range)
Title:

CF 2018 ckeditor 4 erases or disallows styles

| View in Portal
October 30, 2018 06:54:16 PM GMT
7 Comments
<p>We recently transferred an application from a server with CF11 with FCKeditor 2.6.4 to CF 2018 with CKeditor 4. Everything seems to be perfect except for one thing. When we load content in CKeditor it erases certain styles such as table cell borders. And if I try to reenter the deleted styles in the source, as soon as a swith back to the wysiwyg view, styles are erased. Very annoying. Is there a filter activated somewhere that filters certain styles? […]</p>
<p>The post <a rel="nofollow" href="https://coldfusion.adobe.com/2018/10/cf-2018-ckeditor-4-erases-or-disallows-styles/">CF 2018 ckeditor 4 erases or disallows styles</a> appeared first on <a rel="nofollow" href="https://coldfusion.adobe.com">ColdFusion</a>.</p>
Labels: ColdFusion, Question, Troubleshooting, question, troubleshooting

Comments:

Have you viewed the page with your browser's developer tool enabled, watching its network tab, to see if some files used in the rendering of the page are failing?
Comment by Charlie Arehart
1326 | October 31, 2018 01:29:02 PM GMT
Thanks for your reply. All files required for the editor are transferred except one (tableCell.js) which could explain why table cell properties are not available. I have to investigate. As for the styles being deleted, it appears that the Advanced Content Filter introduced in 4.1 could be the source of my problem. Probably certain Disallowed Rules are implemented by default. I was able to solve my problem by adding in the config.js file the folowing line of code: config.allowedContent = true;
1331 | October 31, 2018 04:59:06 PM GMT
Cool. Thanks for the update and additional info.
Comment by Charlie Arehart
1333 | October 31, 2018 06:44:48 PM GMT
Ran into a similar issue with my CF 2018 fully patched (Update 7) server. (On my dev Mac & prod Windows server). Google Dev tools showed failure to load: /cf_scripts/scripts/ajax/ckeditor/skins/moono/editor.css?t=I63C The quick fix was to back up the 'moono' folder, duplicate and rename the 'moono-lisa' to 'moono'.  I'm surprised this wasn't picked up adobe yet, it's 2020.
3638 | February 04, 2020 04:10:12 AM GMT
Hi, Yaron (and very long time, no talk). About this, did it happen upon doing an update *OF* cf2018? From what update? Or was it a move *TO* CF2018, like Francois had reported? And either way, is it the same kind of specific action as he reported here, that leads to the error you see? Or is it a request for *any* page using cftextarea? Or is it perhaps your *own* use of ckeditor? If so, what version? I'm trying to help narrow down why  Adobe might not have" picked up on this" before now, as you said.
Comment by Charlie Arehart
3640 | February 04, 2020 05:21:27 AM GMT
Yaron?
Comment by Charlie Arehart
3641 | February 07, 2020 01:34:57 AM GMT
CF 2018 is shipping that way.  The original moono folder has only a single file in it.  His solution works perfectly, all the needed files are in the moono-lisa folder. Dave
Comment by dtb26
4707 | March 27, 2020 01:38:42 PM GMT