tracker issue : CF-3042922

select a category, or use search below
(searches all categories and all time range)

Bug 85280:I ran into a weird issue today - working in MG and had an event Iwanted to fire and set some file info

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/

Reporter/Name(from Bugbase): Jim Priest / Jim Priest (Jim Priest)

Created: 12/02/2010

Components: ORM Support

Versions: 9.0

Failure Type: Unspecified

Found In Build/Fixed In Build: 0000 /

Priority/Frequency: Normal / Unknown

Locale/System: English / Win All

Vote Count: 0


I ran into a weird issue today - working in MG and had an event Iwanted to fire and set some file info.<cffunction name="getUserFile" output="false" access="public"returntype="Any" hint="Get file information."><cfargument name="event" type="any" required="true" /><cfset local = {} /><cfset local.myQuery = ormexecutequery("select uf.userformid, f.formname, uf.formstatusid, uf.documenttype,f.newfilename, u.credtrakidfrom userform  ufjoin uf.form fjoin uf.user uwhere uf.userformid = :userformidand uf.formstatusid = :formstatusid", { userformid = arguments.event.getValue('f') }) /><!--- TODO - for debugging ---><cfdump var="#local.myQuery#" top=5 label="My Query Dump"abort="true"></cffunction>So when I ran this - my cfdump would never fire - I would immediatelybe directed along to my view.Then I found the issue - in my query - I'm looking for two variablesbut have only defined one.This didn't throw an error - but just returned out of the function andproceeded to the view.


ORMExecuteQuery will return out of function if error is thrown in query.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3042922

External Customer Info:
External Company:  
External Customer Name: Jim Priest
External Customer Email: 2E2763C8451D55CE992015C3
External Test Config: 12/02/2010