tracker issue : CF-3130239

select a category, or use search below
(searches all categories and all time range)

Updates not working anymore

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/NotABug

Reporter/Name(from Bugbase): Andrew Scott / Andrew Scott (Andrew Scott)

Created: 03/05/2012

Components: Administrator, HotFix Notification

Versions: 10.0

Failure Type:

Found In Build/Fixed In Build: Public Beta /

Priority/Frequency: Major / Most users will encounter

Locale/System: English / Win 2008 Server x64

Vote Count: 0

Problem Description: Well I have no idea why, but I have done this before and it has worked.

But after installing and uninstalling that many times, I think something has finally screwed up. I have attached a screen shot, to show that after I click on the icon with the number 2 as there are 2 updates, or I select the update from the navigation. 

I get nothing.

Steps to Reproduce:

Actual Result:

Expected Result:

Any Workarounds:

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3130239

External Customer Info:
External Company:  
External Customer Name: ascott67
External Customer Email:  
External Test Config: My Hardware and Environment details:


  1. March 05, 2012 00:00:00: 1_CaptureUpdateCf10.PNG


"Error","pool-2-thread-1","03/06/12","00:25:32",,"Unable to initialise WebSocket service: Failed to bind to:" Failed to bind to: at org.jboss.netty.bootstrap.ServerBootstrap.bind( at at at coldfusion.server.CFService.setupWebSocketService( at coldfusion.server.CFService.start( at coldfusion.server.j2ee.CFStartUpServlet.startCFService( at coldfusion.server.j2ee.CFStartUpServlet.init( at javax.servlet.GenericServlet.init( at coldfusion.bootstrap.ClassloaderHelper.initServletClass( at coldfusion.bootstrap.BootstrapServlet.init( at org.apache.catalina.core.StandardWrapper.initServlet( at org.apache.catalina.core.StandardWrapper.loadServlet( at org.apache.catalina.core.StandardWrapper.load( at org.apache.catalina.core.StandardContext.loadOnStartup( at org.apache.catalina.core.StandardContext.startInternal( at org.apache.catalina.util.LifecycleBase.start( at org.apache.catalina.core.ContainerBase$ at org.apache.catalina.core.ContainerBase$ at java.util.concurrent.FutureTask$Sync.innerRun( at at java.util.concurrent.ThreadPoolExecutor$Worker.runTask( at java.util.concurrent.ThreadPoolExecutor$ at Caused by: Address already in use: bind at Method) at at at at at at at at org.jboss.netty.bootstrap.ServerBootstrap$Binder.channelOpen( at at<init>( at at at org.jboss.netty.bootstrap.ServerBootstrap.bind( ... 22 more
Comment by External U.
20376 | March 05, 2012 07:56:53 AM GMT
Thought it might be a firewall issue, but as it is turned off and still get the error, something else is causing this.
Comment by External U.
20377 | March 05, 2012 07:59:40 AM GMT
In case you have standalone and J2EE installations running on the same machine, the web socket port will be the same and this might be the reason why you are getting the exception. Can you change the websocket port {cfroot}\lib\neo-webcoket.xml (for any one of the installations) and try again? (Comment added from ex-user id:vkonatal)
Comment by Adobe D.
20378 | March 21, 2012 08:38:40 AM GMT
This is related to another ticket, where I installed ColdFusion as 2 instances running as a standard instalaltion, and deploying another instance. I also had another instance installed on tomcat that was using the same port. In the other ticket, I made the suggestion that when installing ColdFusion or Deploying it to another container like Tomcat then it should check that the port is free to be used. Otherwise this issue will happen. The same can be said if I have two Tomcat installations and deploy the war to both instances, the same problem occurs. I could change what you asked me to do, and it would more than likely work. As stopping the Tomcat instance allows ColdFusion 19 standard to work again. Starting the omcat instance causes that to fail. Same as the two tomcat installs when one ist stopped the other will work, and viceversa. Hope that helps more. ColdFusion should not assume that this port is free, and should cycle to another port if it is not free. I have given many examples of how this can be the case, and all are typical Developer installations or even production to some degree.
Comment by External U.
20379 | March 21, 2012 08:46:41 AM GMT
Server should not cycle ports on start-up to another one if it is not free. This port needs to be exposed externally and if server changes it dynamically, it will become impossible to manage it by the administrator. This is similar to the HTTP port and any server should not cycle the HTTP port dynamically during startup. This is not a bug and does not need anything to be done.
Comment by Rupesh K.
20380 | April 02, 2012 02:37:25 AM GMT