tracker issue : CF-3131509

select a category, or use search below
(searches all categories and all time range)

CF 10 crashes in a non responsive way under tomcat

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Andrew Scott / Andrew Scott (Andrew Scott)

Created: 03/06/2012

Components: Installation/Config, JEE Deployment

Versions: 10.0

Failure Type: Crash

Found In Build/Fixed In Build: Public Beta /

Priority/Frequency: Critical / All users will encounter

Locale/System: English / Win 2008 Server x64

Vote Count: 0

Problem Description:

When stopping ColdFusion on a tomcat install, it will stop. But you can't start ColdFusion as it sits there trying in an endless loop for over an hour.

Steps to Reproduce:

Install tomcat, deploy CF from a war. Stop cfusion, and try to start cfusion and the manager will be stuck trying to start cfusion back up again.

Actual Result:

Expected Result:

Any Workarounds:

None, this happens each time I try to stop cfusion on tomcat

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3131509

External Customer Info:
External Company:  
External Customer Name: ascott67
External Customer Email:  
External Test Config: My Hardware and Environment details:


  1. March 15, 2012 00:00:00: 1_tomcat7-stderr.2012-03-13.log
  2. March 15, 2012 00:00:00: 2_catalina.2012-03-13.log


Deploying ColdFusion on Tomcat might work but there could be issues as we've done some customizations to Tomcat source code as well as Connector source code as a result of which things might not work as expected. If possible, we might list some of the known issues and possible workaround for a ColdfFusion deployment on Tomcat but no promises right now.
Comment by Vamseekrishna N.
20292 | March 06, 2012 11:28:02 PM GMT
So what your saying is that it is not supported running on tomcat, I think that is going to make a lot of people very upset. And especially since you have no real concept of multi - server installation, you are basically forcing people to install tomcat to get this feature. So although I can appreciate custom enhancements to tomcat, and to the connector. You will either need to make installing on Tomcat a reality, or you provide a way to have a multi-server installation the same way ColdFusion 9 has it now. I have raised many tickets because of the lack of support to multi-server installation being non existent, and you have now made it even harder for people like me to deploy ColdFusion 10, 9 and 8 as instances on top of a well known Application Server.
Comment by External U.
20293 | March 08, 2012 01:51:00 AM GMT
Could you please check if you have any .SER file in the location <CF_HOME>\runtime\conf\Catalina\localhost\tmp If yes, please delete that and try to restart the server. Let us know if that works. This is one of the issue that we found with Tomcat which we have changed in the custom Tomcat build that we ship.
Comment by Rupesh K.
20294 | March 12, 2012 07:27:23 AM GMT
I take it you mean <cf_home> as in the instance that is installed on tomcat? If not please let me know.
Comment by External U.
20295 | March 12, 2012 08:10:07 AM GMT
On tomcat that directory structure does not exist.
Comment by External U.
20296 | March 12, 2012 08:11:33 AM GMT
oh sorry.. since this is a standard Tomcat, it should be <Tomcat InstallDir>\conf\Catalina\localhost\tmp
Comment by Rupesh K.
20297 | March 12, 2012 08:15:11 AM GMT
If that directory does not exist, can you take a thread dump and attach?
Comment by Rupesh K.
20298 | March 12, 2012 08:16:13 AM GMT
Thread dump from where? And no that directory did not exist
Comment by External U.
20299 | March 12, 2012 08:26:38 AM GMT
I just tried to upload the catalina and tomcat-stderr as there are exceptions there, but they are bigger than 4000 so it wont allow me to add them here.
Comment by External U.
20300 | March 12, 2012 08:34:13 AM GMT
can you mail it to me at rukumar at adobe?
Comment by Rupesh K.
20301 | March 12, 2012 02:54:58 PM GMT
this was emailed
Comment by External U.
20302 | March 13, 2012 07:43:57 AM GMT
Hi Andrew, Can you please confirm these 2 steps - 1. Cryptoj.jar and CryptojFIPS.jar is put for the JRE that is being used for server? The reason i ask is, if there is a JRE set using JAVA_HOME, these jars should be copied to respective JRE/lib/ext directory. 2. If this does not fix the issue, Can you try this alternative fix - Add these jars in TOMCAT-HOME/server/lib. Let me know if this helps. (Comment added from ex-user id:shilpik)
Comment by Adobe D.
20303 | March 15, 2012 12:59:47 AM GMT
Ok I added the jars to that location and still have the same issue... One thing I can tell you is that I have no JAVA_HOME setup, but I also had a look and I have two Java installations. Maybe I copied the files to the wrong installation, I might try the other and see if that makes any difference. Is there an easy way to find out the path of the Java install being used if there is no JAVA_HOME
Comment by External U.
20304 | March 15, 2012 04:59:12 AM GMT
When I tried to move to another directory or Java install it told me it was loaded by Tomcat so I guess Tomcat is actually loading it.
Comment by External U.
20305 | March 15, 2012 05:01:39 AM GMT
Hi Andrew, Since the last release we have upgraded the CryptoJ library and with that it should be fixed. We are not able to see this issue on our latest builds. Can you please try it on the public beta intermediate build (released on 04/06/2012)? Thanks Kunal
Comment by Kunal S.
20306 | April 16, 2012 04:46:30 AM GMT
is that on
Comment by External U.
20307 | April 16, 2012 09:39:41 AM GMT
Actually this was fixed in a build post public beta
Comment by Vamseekrishna N.
20308 | April 16, 2012 09:51:52 AM GMT
So that means I will have no way to confirm if this is fixed, and will have to wait until it is released to confirm.
Comment by External U.
20309 | April 16, 2012 06:10:45 PM GMT