tracker issue : CF-3135653

select a category, or use search below
(searches all categories and all time range)

CFIMAP does not work with Exchange 2010 SP1

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/CannotReproduce

Reporter/Name(from Bugbase): Michael Cummins / Michael Cummins (M.Cummins)

Created: 03/12/2012

Components: Net Protocols, IMAP

Versions: 10.0

Failure Type: Non Functioning

Found In Build/Fixed In Build: Public Beta /

Priority/Frequency: Critical / All users will encounter

Locale/System: English / Win 2008 Server R2 64 bit

Vote Count: 0

Problem Description:CF 9.0+ cannot <cfimap action="GetAll"> to a Microsoft Exchange 2010 SP1 server.  You receive: javax.mail.MessagingException: Unable to load BODYSTRUCTURE

Steps to Reproduce:

Actual Result:

Expected Result:

Any Workarounds

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3135653

External Customer Info:
External Company:  
External Customer Name: M.Cummins
External Customer Email:  
External Test Config:



I heard they updated CFEXCHANGE for Exchange 2010 in the CF10 Beta, but it does not appear that CFIMAP was. I wrote a lot of CFIMAP helper bots that check mailboxes on Exchange servers to help me with automation, and this breaks all of them.
Comment by External U.
20114 | March 12, 2012 11:56:10 AM GMT
We are able to get data from Exchaneg 2010 server for <cfimap action="GetAll"> Are you using SSL/TLS for imap? Also another related issue that I found online is with digitally signed mails and imap in Exchange.Is this the case? (Comment added from ex-user id:evelinv)
Comment by Adobe D.
20115 | March 13, 2012 05:07:23 AM GMT
Everything worked well until the upgrade to 2010 SP1. Then it failed. I am not using SSL/TLS. My call is rather simple, it looks like this: <cfimap action="GetAll" folder="INBOX" connection="monitoringBackups" name="allMail" maxrows="5" /> It worked previously for Exchange 2010. It failed when Exchange was upgraded to SP1.
Comment by External U.
20116 | March 13, 2012 08:59:59 AM GMT
No, we're not using digitally signed e-mails. This particular implementation is a scheduled task that runs a page that checks e-mail for an account that receives notices from several dozen servers that copy the account on their backup notices. This "bot" then parses the messages, stores the results in a database, and moves the messages to a "read" folder, or to a "could not identify" folder. The mail is application-generated HTML of a simple variety. The IMAP port is unencrypted.
Comment by External U.
20117 | March 13, 2012 09:03:08 AM GMT
Ok We got Exchange 2010 setup with SP2. I checked simple imap getall and it is working fine. I know you are on SP1. Can you try configuring the same imap user to Microsoft Office and see if that is working? (Comment added from ex-user id:evelinv)
Comment by Adobe D.
20118 | March 26, 2012 05:43:01 AM GMT
Did you have a chance to look into this? It would be great if we could get some confirmation.
Comment by Vamseekrishna N.
20119 | April 16, 2012 03:44:32 AM GMT
Closing this issue as not reproducible.We tested with Exchange 2010 and SP2 and imap is working. (Comment added from ex-user id:evelinv)
Comment by Adobe D.
20120 | June 18, 2012 02:59:44 AM GMT