tracker issue : CF-3181617

select a category, or use search below
(searches all categories and all time range)

Critical ORM/2nd Level Caching Bug

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Rob Bilson / Rob Bilson (Rob Bilson)

Created: 05/03/2012

Components: ORM Support

Versions: 10.0

Failure Type: Crash

Found In Build/Fixed In Build: Public Beta / 282484

Priority/Frequency: Critical / All users will encounter

Locale/System: English / Platforms All

Vote Count: 5

Duplicate ID:	CF-3327626

Related Bugs:
CF-3327626 - Similar to

Problem Description:

Note that this affects the latest Intermediate Build:

Thanks to Ray Camden for bumping up against this bug. I’m just here to explain the issue and provide the use case.

The most recent ColdFusion intermediate build (ColdFusion 10,282335) has introduced a serious bug with Hibernate and 2nd level caching via ehcache.  I’m attaching a zip file with a reproducible case to illustrate what’s going on. It requires you to have the cfartgallery datasource installed on your machine.  

To run the test case, simply unzip the files into any directory under your web root.  Hit the index.cfm file and you’ll see some output.  Now wait a minute (literally 60 seconds) until the application times out, then reload the page.  You’ll get an error which is too large to post here, so I added it in the Zip file.

It’s important to note that this bug didn’t exist in previous builds of CF 10. It was introduced in the latest intermediate build.  The latest build contains ehcache 2.5.1 whereas the previous CF 10 build used 2.4.x (I believe).

What seems to be happening is when the CF application times out (the 1 minute timeout for app scope in the Application.cfc), ColdFusion loses its handle to the Hibernate 2nd level cache.  A subsequent hit to the application causes CF to attempt to get a new cache manager, only it tries to get one using the same name as the cache manager it created previously.  Since the original cache manager with the same name already exists, Ehcache/ColdFusion throws an error.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3181617

External Customer Info:
External Company:  
External Customer Name: Rob Brooks-Bilson
External Customer Email:


  1. May 04, 2012 00:00:00:


I just raised another issue (CF-3327626). The hotfix 10.0.1 didn't solve this issue.
Comment by External U.
19545 | September 09, 2012 07:47:24 AM GMT
This is still a bug. We are at version 10.0.4 now, but this problem has still not been solved.
Vote by External U.
19548 | November 12, 2012 06:38:11 AM GMT
I can confirm this bug. Secondary caching is still a problem.
Vote by External U.
19549 | November 12, 2012 07:20:19 AM GMT
It has indeed not been fixed yet.
Vote by External U.
19550 | November 12, 2012 07:20:52 AM GMT
Same here, secondary caching still cannot be used.
Vote by External U.
19551 | November 12, 2012 07:25:18 AM GMT
I'm running 10.0.5 and the issue still exists.
Comment by External U.
19546 | December 04, 2012 01:43:30 PM GMT
This is still a problem...
Vote by External U.
19552 | February 17, 2013 10:46:11 PM GMT
Still seeing the issue with 10,0,8,284032.
Comment by External U.
19547 | March 26, 2013 10:30:35 AM GMT