tracker issue : CF-3197321

select a category, or use search below
(searches all categories and all time range)

Connection String in MySQL Datasource sent to Database with trailing space

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/CannotReproduce

Reporter/Name(from Bugbase): Nathan Dintenfass / Nathan Dintenfass (screennameunavailable99)

Created: 05/23/2012

Components: Database

Versions: 10.0

Failure Type:

Found In Build/Fixed In Build: Final /

Priority/Frequency: Major / All users will encounter

Locale/System: English / Mac 10.6 for Intel

Vote Count: 5

Problem Description:
When attempting to add a Connection String to a MySQL 4/5 Datasource, if the value is "allowMultiQueries=yes"

The message returned is:

Connection verification failed for data source: kplapdashboard
java.sql.SQLException: The connection property 'allowMultiQueries' only accepts values of the form: 'true', 'false', 'yes' or 'no'. The value 'yes ' is not in this set.
The root cause was that: java.sql.SQLException: The connection property 'allowMultiQueries' only accepts values of the form: 'true', 'false', 'yes' or 'no'. The value 'yes ' is not in this set.

Also tried with a value of "true" -- ensured no trailing space in the form on the DSN configuration page in the CF Admin

Steps to Reproduce:

Add a MySQL 4/5 datasource, add a Connection String of "allowMultiQueries=yes", submit the datasource, view error message (or try to load a page that uses the datasource)

Actual Result: error message above

Expected Result: no error, connection string properly sent to the database server

Any Workarounds: None I know of

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3197321

External Customer Info:
External Company:  
External Customer Name: screennameunavailable99
External Customer Email:  
External Test Config: My Hardware and Environment details: MacBook Pro, OS X 10.6, CF10 production build



This also appears to impact zeroDateTimeBehavior=convertToNull with the same issue. I have reviewed the neo-datasource.xml file and the additional space isn't shown within the file but the datasource validator still flags as an error and refuses to use the datasource
Comment by External U.
19244 | June 07, 2012 06:09:51 PM GMT
This bug prevents us from moving legacy code from Coldfusion 9
Vote by External U.
19255 | June 07, 2012 06:11:02 PM GMT
This was also occurring on a Linux 64 Bit install *** Workaround *** Setup a new datasource with type other JDBC URL = jdbc:mysql:// Driver class = com.mysql.jdbc.Driver Driver name = MySQL (Other)
Comment by External U.
19245 | June 07, 2012 06:21:51 PM GMT
Looking at new-datasource.xml the datasource, after being created, has the following extra characters in the URL var for the connection: <char code='0a'/><char code='09'/><char code='09'/><char code='09'/><char code='09'/><char code='09'/><char code='09'/><char code='09'/> Removing those and restarting CF allows the datasource to be verified. If the datasource is then edited via the CF Admin UI the problem returns.
Comment by External U.
19246 | June 09, 2012 01:03:39 AM GMT
The latest updater (10.0.1) did not fix this issue -- it continues to be a show-stopping problem for getting code that worked fine on CF9 to work on CF10 because that code assumes this setting in the CF datasource.
Comment by External U.
19247 | September 04, 2012 07:11:57 PM GMT
I am also seeing this bug with zeroDateTimeBehavior=convertToNull
Comment by External U.
19248 | October 15, 2012 06:04:53 PM GMT
I am unable to create a DSN as required for legacy database reasons. This needs urgent fixing.
Vote by External U.
19256 | October 16, 2012 02:14:51 PM GMT
issue appears in this thread
Comment by External U.
19249 | October 16, 2012 02:50:02 PM GMT
This does not work in CF10. When you use the zeroDateTimeBehavoir=convertToNull in your connection string in CF10, you will receive this error please fix asap
Vote by External U.
19257 | October 16, 2012 02:50:52 PM GMT
Can you please try using & instead of ; in the Connection String, that should not cause this error.Also i see the same issue happening with CF9.0.2. Can you please let us know the exact Connection String you are using.
Comment by Asha K.
19250 | November 09, 2012 06:31:54 AM GMT
Just applied Updater 4 - this error is still present. Exact string tried is: allowMultiQueries=yes Adding "&" at the end of the string entered in the CF Administrator is a great work-around to this!
Comment by External U.
19251 | November 16, 2012 11:58:17 PM GMT
Adobe, you have done it again !! Please read and listen to the handfull of people that are still holding on to your server products. We are at update 5 for ColdFusion 10 and it still hasn't been resolved !!! Come-on !!
Vote by External U.
19258 | November 21, 2012 12:51:15 AM GMT
I just installed CF10 update 10 and this issue still exists, why is it not fixed?
Comment by External U.
19252 | June 10, 2013 08:35:41 AM GMT
Yes, this needs to be fixed as soon a possible. This makes moving from CF9 to CF10 questionable when you see such minor problems like this go unsolved. It also makes long term administration in CF10 more difficult when you have to manually hack a fix into the XML every time a DNS change is needed.
Vote by External U.
19259 | June 26, 2013 10:07:38 AM GMT
@screennameunavailable99: This is only occurring when I am giving spaces deliberately at the end of "allowMultiQueries=yes" Can you please verify it once and provide me the exact connection string which you are using? Regards, Nimit
Comment by Nimit S.
19253 | December 04, 2013 12:01:21 AM GMT
We have not heard anything back on this issue. Hence, closing this bug. If you are still facing this issue please let us know so that we can re-open this bug.
Comment by Nimit S.
19254 | December 03, 2014 01:09:24 AM GMT