tracker issue : CF-3214734

select a category, or use search below
(searches all categories and all time range)

sameformfieldsasarray appears to be on by default when using Application.cfm on Linux / x64

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/CannotReproduce

Reporter/Name(from Bugbase): Joe Zack / Joe Zack (Joe Zack)

Created: 06/14/2012

Components: Application Deployment

Versions: 10.0

Failure Type: Incorrect w/Workaround

Found In Build/Fixed In Build: Final /

Priority/Frequency: Normal / Some users will encounter

Locale/System: English / Linux All

Vote Count: 2

Problem Description:
Form fields with the same name are combined into an array when using an Application.cfm file on Ubuntu 12.04 x64 install of ColdFusion 10.

The setting should be off by default, and when using an Application.cfm file there is no way to turn the setting off.

Steps to Reproduce:
Create a folder with the following two files, submit the form.
(Code can be found here:

<!--- Application.cfm file: --->
<cfapplication name="test-application" />

<!--- index.cfm file --->
<cfdump var="#form#" />

	<form method="post">
		<input name="formField" />
		<input name="formField" />
		<input type="submit" />

Actual Result:
The form struct contains an array called formField

Expected Result:
The form struct should contain a list called formField

Any Workarounds:
Can loop through the form scope on every request and convert arrays to lists

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3214734

External Customer Info:
External Company:  
External Customer Name: Joe Zack
External Customer Email:  
External Test Config: My Hardware and Environment details:

Ubuntu 12.04 amd64 (3.2.0-24-generic)

ColdFusion Server Developer


  1. June 15, 2012 00:00:00: 1_Selection_065.png


Ran code on Windows Server 2003 amd64 and it worked as expected
Comment by External U.
19018 | June 14, 2012 01:11:50 PM GMT
This is a very significant bug if it's endemic to *nix installs. It'll basically break any sites using <cfapplication> and have forms with checkboxes on them, won't it?
Vote by External U.
19025 | June 14, 2012 01:40:19 PM GMT
I'm not able to reproduce this on Ubuntu or Redhat Linux (both 64 bit). I'm using the same code as mentioned in the bug i.e. Application.cfm <cfapplication name="test-app" /> index.cfm <cfdump var="#form#" /> <cfoutput> <form method="post"> <input name="formField" /> <input name="formField" /> <input type="submit" /> </form> </cfoutput> Do you have Application.cfc file in the same directory which has the setting sameFormFieldsAsArray set to true? (Comment added from ex-user id:sagarg)
Comment by Adobe D.
19019 | June 14, 2012 10:02:32 PM GMT
No, this directory contains only the sample Application.cfm and a blank index.cfm file.
Comment by External U.
19020 | June 19, 2012 12:25:07 PM GMT
I'm not able to reproduce this. Can you mail the source files to (Comment added from ex-user id:sagarg)
Comment by Adobe D.
19021 | June 20, 2012 04:58:34 AM GMT
I can't send you my main Application, it's proprietary. However, I am able to reproduce the problem with the attached files. Are there any coldfusion files I can send you? Binaries, logs etc.
Comment by External U.
19022 | June 25, 2012 12:41:13 PM GMT
Can you check if changing the application name to something random helps? I guess there might be another application with the same name already existing on the server and setting from the other application is getting picked up.
Comment by Rupesh K.
19023 | June 26, 2012 03:34:14 AM GMT
The server was restarted over the weekend and my sample code is working as expected now. I had restarted the CF service multiple times when I originally ran into the problem, but this is the first time that the machine has been rebooted since installing CF.
Comment by External U.
19024 | June 27, 2012 02:27:37 PM GMT
This is Still not working
Vote by gavy r.
19026 | May 30, 2017 04:49:01 PM GMT