tracker issue : CF-3216317

select a category, or use search below
(searches all categories and all time range)

Service Not available after reboot.

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Peter Compton / Peter Compton (Ripples)

Created: 06/16/2012

Components: Installation/Config, Connector

Versions: 10.0

Failure Type: Crash

Found In Build/Fixed In Build: Final / 282891

Priority/Frequency: Critical / Some users will encounter

Locale/System: English / Win 2008 Server R2 64 bit

Vote Count: 0

Duplicate ID:	CF-3318104

Problem Description: 

After upgrade from CF9, web sites would intermittently fail with "service not available" and a footnote of "jakarta/isapi/isapi_redirector/1.2.32"

Steps to Reproduce: 

Uninstalled and re-installed a fresh copy. Sites work after installation but intermittently fail after each reboot. Not every site fails, but after each reboot often a different site would fail to connect to CF.

Has not occured on my development computer that's running Win7 Ultimate 64bit

Actual Result:

Expected Result:

Any Workarounds: 

None - reverted to CF9

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3216317


External Customer Info:
External Company:  
External Customer Name: Ripples
External Customer Email:  
External Test Config: My Hardware and Environment details:

Hi-end Dedicated server with Softlayer. Windows 2008 R2 Server 64 bit running IIS 7.5

CF10 64 bit windows

ASP.Net, CGI and ISAPI are all installed and prior to this attempted upgrade server has been stable on CF9 64 bit for 2+ years.



Been programming for 30+ years and full time with ColdFusion since 1998. See for more detail. Appears the Tomcat connector "drops out" after reboot.
Comment by External U.
19000 | June 16, 2012 10:24:48 AM GMT
I tried to reproduce the above but I am not able to. I tried the setup on a Windows 2008 server R2. Steps which I followed: 1. Configure IIS connector to "All" sites 2. Checked all the sites. It works fine. 3. Reboot the server(shutdown+start) 4. After restart, the CF server is up and running 5. Access all the sites. Works fine 6. Wait for half an hour. Access all the sites. Still they are working fine. Am I missing something? (Comment added from ex-user id:kamaiya)
Comment by Adobe D.
19001 | June 18, 2012 05:13:27 AM GMT
Hi Kavya, Have updated the entry. Basically, I've reinstalled CF10 as an upgrade and also tried having removed CF9 first. Error occurs every time after a reboot with one or more of my 4 sites failing to come online. Error can be fixed by using the CF10 Connector tool removing and reinstalling for bad site. Its NOT the same site(s) that fail each time. Error is immediate after reboot. No need to wait. Mostly browser stalls, but eventually I get "service unavailable". Checked CF10 logs and can see anything other than lots of "null null" errors: +++++++++++++++++++++++ Jun 20, 2012 1:28:18 PM org.apache.tomcat.util.http.Parameters processParameters INFO: Invalid chunk starting at byte [2] and ending at byte [2] with a value of [null] ignored +++++++++++++++++++++++++++ Did find one: ++++++++++++++++++++++++++++++++++++++++ Error: Could not load mediaLib accelerator wrapper classes. Continuing in pure Java mode. Occurs in: +++++++++++++++++++++++++++++++++++++++++ After a full Acronis boot C:\ drive restore to get back to CF9 then all is stable with no issues at all. Problem only occurs in CF10. Any help would be appreciated
Comment by External U.
19002 | June 20, 2012 08:46:03 AM GMT
Kavya, Although I've returned to CF9, I did backup the C: drive with CF10 installed before it was rebooted. It installed fine and was running successfully for several hours before this reboot connector issue. So I do have access through the archive to any files that you feel might give you a clue. I have spent many hours looking at CF and IIS logs, but have not seen anything that would indicate where the problem is. Peter
Comment by External U.
19003 | June 21, 2012 05:19:24 AM GMT
Kavya, FYI When a site fails, IIS shows the correct CF10 Handler(connector) and correct default document. As an aside: If I install the CF10 connector to a specific site after a "stall" using the CF10 Web Connector Tool it does not always install index.cfm in the default documents. This despite IIS having index.cfm in place. I have to use "revert from parent" or type index.cfm in manually in IIS Default Documents. If I uninstall a connector it does remove the index.cfm however!
Comment by External U.
19004 | June 21, 2012 08:50:54 AM GMT
Update Still have not found a fix and no response from Adobe or the Cf Community. I'm unable to upgrade Ver 9 to Ver 10.
Comment by External U.
19005 | July 02, 2012 02:15:33 PM GMT
UPDATE 8/3/2012 I spent the past week trying to troubleshoot this issue in a little more depth. Have used the Web Server Configuration Tool in all combinations of "ALL" or individual sites or both. If I remove all connectors and start afresh, selecting "ALL" does not always flow down the CF file Handlers to the individual sites. Only way this seemed to work is if I reset the handlers for each individual site to "revert to parent". However, even when connectors could be confirmed to exist correctly through IIS Manager, this intermittent failure for all sites to start after a reboot continued. After much testing I've found I can resolve the problem every time by waiting a couple of minutes after a reboot and then restarting the IIS Service. Subsequently the server works well. CF10 is fast and I see no issues. I did find a couple of entries in the C:\CF10\cfusion\logs\coldfusion-error.log that may offer a clue +++++++++++++++++++++++++++++++++++++++++++++++++++ During CF Start several.... ******************************* Jul 31, 2012 1:17:51 PM org.apache.tomcat.util.http.Parameters processParameters INFO: Invalid chunk starting at byte [0] and ending at byte [0] with a value of [null] ignored ******************************** and.... ********************************* Jul 31, 2012 1:22:23 PM org.apache.catalina.core.AprLifecycleListener init INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\\CF10\\cfusion\lib;C:\\CF10\\cfusion\jintegra\bin;C:\\CF10\\cfusio n\jintegra\bin\international;C:\\CF10\\cfusion\lib\oosdk\classes\win ********************************** and.... ********************************** Jul 31, 2012 1:22:36 PM com.adobe.coldfusion.launcher.Launcher run INFO: Server startup in 14761 ms Error: Could not load mediaLib accelerator wrapper classes. Continuing in pure Java mode. Occurs in: *********************************** and several times..... (exceeded note field allowance - I'll post 2nd note) ***********************************
Comment by External U.
19006 | August 06, 2012 08:57:49 AM GMT
UPDATE 8/3/2012 - Part 2 The SEVERE entry in the log concerns me... +++++++++++++++++++++ Jul 31, 2012 2:15:47 PM org.apache.coyote.ajp.AjpProcessor getRealPathFromServer SEVERE: Error in getRealPathFromConn Connection reset by peer: socket write error at Method) at at at org.apache.coyote.ajp.AjpProcessor.getRealPathFromServer(AjpProcessor .java:391) at org.apache.coyote.ajp.AbstractAjpProcessor.getRealPath(AbstractAjpPro at org.apache.naming.resources.FileDirContext.doGetRealPath(FileDirConte at org.apache.naming.resources.BaseDirContext.getRealPath(BaseDirContext .java:412) at org.apache.catalina.core.StandardContext.getRealPath(StandardContext. java:4475) at org.apache.catalina.core.ApplicationContext.getRealPath(ApplicationCo at org.apache.catalina.core.ApplicationContextFacade.getRealPath(Applica at coldfusion.runtime.ServletContextWrapper.doGetRealPath(ServletContext at coldfusion.runtime.ServletContextWrapper._doGetRealPath(ServletContex at coldfusion.runtime.ServletContextWrapper.getRealPath(ServletContextWr at coldfusion.runtime.TemplateProxyFactory.getFullName(TemplateProxyFact at coldfusion.runtime.TemplateProxyFactory.resolveName(TemplateProxyFact at coldfusion.runtime.TemplateProxyFactory.resolveName(TemplateProxyFact at coldfusion.runtime.TemplateProxyFactory.resolveFile(TemplateProxyFact at coldfusion.cfc.CFCProxy.<init>( at coldfusion.cfc.CFCProxy.<init>( at coldfusion.runtime.AppEventInvoker.<init>( at coldfusion.filter.ApplicationFilter.invoke( ) at coldfusion.filter.RequestMonitorFilter.invoke(RequestMonitorFilter.ja va:48) at coldfusion.filter.MonitoringFilter.invoke( at coldfusion.filter.PathFilter.invoke( at coldfusion.filter.ExceptionFilter.invoke( ......................... ***************************************
Comment by External U.
19007 | August 06, 2012 09:00:07 AM GMT
Appreciate the detailed information. We will have someone from the team look into this, and if needed, get in touch with you for more information.
Comment by Vamseekrishna N.
19008 | August 06, 2012 09:06:48 AM GMT
Can we have connect session so that we can try to identify the problem quickly.Please let us know a convenient time.Also please keep the CF-IIS setup ready , so that we can check the setup. (Comment added from ex-user id:evelinv)
Comment by Adobe D.
19009 | August 10, 2012 01:03:40 AM GMT
Coding error on undeclared variable caused the "SEVERE: Error in getRealPathFromConn" entry in the log. Despite clearing this error the failure of all sites to start after reboot persists. CF Logs show no errors duing or after the latest reboot.
Comment by External U.
19010 | August 10, 2012 05:27:00 AM GMT
Hi Is it possible to have a connect session as we are not able to replicate this issue at our end?Please sepcify a time convenient for you. (Comment added from ex-user id:evelinv)
Comment by Adobe D.
19011 | August 10, 2012 06:24:34 AM GMT
Appreciate all the information but to nail the issue and enable a fix, could we get onto a connect session? If we are not able to replicate this issue, we will not be able to fix it.
Comment by Vamseekrishna N.
19012 | August 13, 2012 12:57:09 AM GMT
The exception int his issue is the same as getrealpath issue.So marking this as to Fix and I have added the duplicate id CF-3318104 (Comment added from ex-user id:evelinv)
Comment by Adobe D.
19013 | September 05, 2012 05:55:51 AM GMT
I can't open access to the server for security reasons. Prolem still existed after every reboot. It required either an IIS restart but sometimes a CF10 restart as well. Also a restart on CF10 is painfully several minutes longer than CF9. But when Tomcat crashed twice in one day I gave up with CF10 and restored CF9 at the beginning of September. Its good to get back to a stable server. Would be nice that the getrealpath was the issue but I'm not prepared to try CF10 again until I can be 100% sure its stable on the 64bit Windows platform. I still see no update available on the Adobe site so have to assume there's still no fix. I can only advise anyone thinking of upgrading from CF9 on Win64 to think again. Peter
Comment by External U.
19014 | September 17, 2012 10:34:51 AM GMT