tracker issue : CF-3327626

select a category, or use search below
(searches all categories and all time range)

Another CacheManager with same name '_ORM_...........' already exists in the same VM

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Dik Klop / Dik Klop (Dik Klop)

Created: 09/09/2012

Components: Caching

Versions: 10.0

Failure Type: Non Functioning

Found In Build/Fixed In Build: Final / cf11:284254, cf10:284261

Priority/Frequency: Critical / All users will encounter

Locale/System: English / Mac 10.7 64-bit

Vote Count: 7

Related Bugs:
CF-3181617 - Similar to

Problem Description: Application cannot startup if secondary caching is enabled. Even after patching to version 10.0.1 the error still exists. The following error occurs:

Another CacheManager with same name '_ORM_........' already exists in the same VM. Please provide unique names for each CacheManager in the config or do one of following: 1. Use one of the CacheManager.create() static factory methods to reuse same CacheManager with same name or create one if necessary 2. Shutdown the earlier cacheManager before creating new one with same name. The source of the existing CacheManager is: URLConfigurationSource [url=jar:file:/Applications/ColdFusion10/cfusion/lib/ehcache-core-2.5.1.jar!/ehcache-failsafe.xml] 

Steps to Reproduce: set secondaryCacheEnabled="true", cacheProvider="ehcache" in ormSettings

Actual Result: Application failes to start

Expected Result:

Any Workarounds: ?

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3327626


External Customer Info:
External Company:  
External Customer Name: Skygod37
External Customer Email:  
External Test Config: My Hardware and Environment details:


  1. September 09, 2012 00:00:00: 1_exceptionLog.txt
  2. February 22, 2013 00:00:00:
  3. February 22, 2013 00:00:00:


The error showed up in version 10.0. But after installing the hotfix 10.0.1 it's still impossible to start the application when Secondary caching is enabled.
Comment by External U.
18126 | September 09, 2012 07:44:07 AM GMT
Just confirmed with my collegue. The error is not only showing up on Mac OS X, but also on Windows 7 Ultimate.
Comment by External U.
18127 | September 10, 2012 02:34:57 AM GMT
As a workaround I downgraded the ehcahe-core to version 2.4.7 and that solved the issue.
Comment by External U.
18128 | September 25, 2012 10:00:28 AM GMT
We are experiencing this as well. Any short-term workarounds?
Vote by External U.
18136 | October 05, 2012 02:57:33 PM GMT
same problem here. Also after the hotfix
Vote by External U.
18137 | November 12, 2012 07:16:53 AM GMT
It has indeed not been fixed yet.
Vote by External U.
18138 | November 12, 2012 07:21:19 AM GMT
Same here, secondary caching can't be used.
Vote by External U.
18139 | November 12, 2012 07:22:06 AM GMT
I'm not sure how this ticket got set to Fixed. Perhaps there's isn't a selection in the Adobe BugBase for Known Issue. At any rate, this problem still exists with ColdFusion 10 Hotfix 4. It is difficult to prevent an application from ever stopping. Is there really no solution other than disabling ORM second level cache or downgrading to Ehcache 2.4.7?
Vote by External U.
18140 | November 12, 2012 12:14:34 PM GMT
same problem for us. We hope that Adobe is currently working to fix this issue!?!
Vote by External U.
18141 | November 27, 2012 06:46:49 AM GMT
I am on the phone with Adobe paid support right now. Hopefully this will help move things along. But otherwise, please give us some feedback on the status of this bug. The ability to leverage ORM with EhCache is critical for a number of my company's new projects, as I am sure it is to many other loyal ColdFusion shops out there.
Vote by External U.
18142 | November 29, 2012 04:31:04 PM GMT
Can we have a repro case for this. We did try the case provided in the bug # CF-3181617 but couldn't reproduce the issue.
Comment by Himavanth R.
18129 | February 21, 2013 03:19:42 AM GMT
To reproduce, extract the file to your webroot. Then: 1. Browse to http://yoururl/test.cfm -> This will produce an error because I put an invalid line of code on line 18 of the Application.cfc 2. Correct the error in Application.cfc by removing the complete line of code at line 18. 3. Again, browse to http://yoururl/test.cfm -> Now you will see the Secondary Caching error. Note, I found this simple way to reproduce the caching problem just by accident. In our case there are no errors in the Application.cfc, but is the startup time of the application quite long. Maybe too long? And therefore have this error?
Comment by External U.
18130 | February 22, 2013 07:18:20 AM GMT
I found the reason that causes the error in our code. We use orm over different datasources. As soon as you have a CFC that connects to a different dsn as the standard dsn, the application will fail to startup. To reproduce: 1. Extract to your webroot 2. Browse to http://yoururl/test.cfm Now you will see the caching error as described above.
Comment by External U.
18131 | February 22, 2013 08:01:31 AM GMT
Work around which worked for me:
Comment by External U.
18132 | April 10, 2013 02:29:10 AM GMT
This bug is fixed. Tested in CF10 version 285099 update 11 and CF11 version 285086 (Comment added from ex-user id:nawani)
Comment by Adobe D.
18133 | June 06, 2013 10:57:14 PM GMT
I'm seeing this issue on 10,0,10,284825 (update 10). Did it resurfaced in current build?
Comment by External U.
18134 | June 18, 2013 12:10:48 PM GMT
Never mind. Just saw the last comment. Will wait for update 11.
Comment by External U.
18135 | June 18, 2013 12:11:41 PM GMT