tracker issue : CF-3335478

select a category, or use search below
(searches all categories and all time range)

Unable to delete a REST service

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Raymond Camden / Raymond Camden (Raymond Camden)

Created: 09/22/2012

Components: REST Services

Versions: 10.0

Failure Type: Non Functioning

Found In Build/Fixed In Build: Final /

Priority/Frequency: Normal / Unknown

Locale/System: English / Mac 10.7 64-bit

Vote Count: 1

I try to delete a REST service and the CF Admin tells me:

Unable to delete REST service.

Nothing is logged in any log that I can see.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3335478

External Customer Info:
External Company:  
External Customer Name: cfjedimaster
External Customer Email:  
External Test Config: My Hardware and Environment details:



Most likely a locking issue? I restarted CF and was then able to delete the service.
Comment by External U.
18025 | September 22, 2012 07:15:03 AM GMT
I have the same error. I have tried restarting CF, but still "Unable to delete a REST service" If I try to refresh, I get "Unable to refresh a REST service" If I try to edit, I get "Error registering REST service. Please ensure that you have entered a proper mapping and path." The audit log indicates "User admin deleted REST service : C:/inetpub/wwwroot/api/" and "User admin refreshed REST service : C:/inetpub/wwwroot/api/" even though the REST page says unable. Coldfusion-Out log indicates the same, but also includes: "Jun 4, 2013 16:08:44 PM Error [ajp-bio-8012-exec-1] - Not able to connect to Update Site: Connection Failure: Status code unavailable" CF version 10,0,10,284825 64-Bit Windows 2008 R2 Standard SP 1 / 64-bit
Comment by External U.
18026 | June 04, 2013 02:54:53 PM GMT
Follow Up: After installing latest Windows updates and updating to Java version 7, update 21, the error stopped occurring.
Comment by External U.
18027 | June 05, 2013 08:02:07 AM GMT
I can duplicate this issue on my end. If you install a REST service, then delete the directory, the admin panel will not delete the registered REST service. It gives the error "Unable to delete REST service", followed by "Error registering REST service. Please ensure that you have entered a proper mapping and path." It's like it is trying to re-register the missing service in order to delete it.
Comment by External U.
18028 | August 22, 2013 02:39:20 PM GMT
I see this too. CF10, windows 7 and server 2008. See my note for reproduction.
Vote by External U.
18035 | August 22, 2013 02:40:39 PM GMT
In my case, I changed an Application.cfc that caused a REST service to fail to reinitialize (some really cryptic NullPointerError). Likewise, I got the "Unable to delete REST service" error in the ColdFusion Administrator until I corrected the issue with the Application.cfc. Once corrected, I could delete and reinitialize the REST service. Seems like it should be something that could be unregistered even if compilation/runtime errors occur, but maybe I'm missing something.
Comment by External U.
18029 | September 13, 2013 03:31:36 PM GMT
We are able to replicate the issue: register rest service through CF Admin -> Remove the directory containing service -> try deleting service from CF Admin -> Gives error Unable to delete REST service. REST service can not be registered. d_isenhower -> Can you please attach Application.cfc that caused REST service to fail to reinitialize. As I tried replicating this case as below: Create rest service cfc: <cfcomponent rest="true" restPath="/timeService"> <cffunction name="sayHello" access="remote" httpMethod="get" returntype="string"> <cfreturn dateTimeFormat(now())> </cffunction> </cfcomponent> Register this service remove returntype="string" from above cfc to make it fail to reinitialize refresh the service CF Admin gives error Still Able to remove the service from CF Admin (Comment added from ex-user id:nawani)
Comment by Adobe D.
18030 | September 17, 2013 06:02:01 AM GMT
I got an email saying I needed to provide more info for this bug, but I do not see a question for me.
Comment by External U.
18031 | September 17, 2013 08:29:55 AM GMT
Please specify the scenerio in which the REST service is not getting deleted. As in normal case when i create rest service, i am able to delete it through CF Admin in CF10 update 11 and update 8 (Comment added from ex-user id:nawani)
Comment by Adobe D.
18032 | September 18, 2013 12:26:14 AM GMT
I'm not able to reproduce it with the latest - so possibly it was fixed.
Comment by External U.
18033 | September 18, 2013 08:56:44 AM GMT
This bug is fixed in the latest build, so closing the bug (Comment added from ex-user id:nawani)
Comment by Adobe D.
18034 | September 19, 2013 01:37:53 AM GMT