tracker issue : CF-3339107

select a category, or use search below
(searches all categories and all time range)

cfpdfform not working

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/Duplicate

Reporter/Name(from Bugbase): Frank Stocker / Frank Stocker (fstocker1)

Created: 09/29/2012

Components: Document Management

Versions: 10.0

Failure Type:

Found In Build/Fixed In Build: Final /

Priority/Frequency: Major / All users will encounter

Locale/System: English / Linux All

Vote Count: 2

Duplicate ID:	CF-3581597

Problem Description: When trying to use the "read" action of cfpdfform it failes with various error messages (depending on PDF Format)

Steps to Reproduce: Take a PDF Form i.e., but tried with many different ones including i.e. one generated with LiveCycle Designer (saved as Static PDF Form).
Run the following two-liner CF-Template with it
<cfpdfform source="/tmp/abm.pdf" result="resultStruct" action="read"/>
<cfdump var="#resultStruct#">

Actual Result:
CF Error: Either datafile XML or data XML contained in the PDF document is invalid. 

Expected Result:
Dump of Fields in this form.

Any Workarounds:
none found

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3339107

External Customer Info:
External Company:  
External Customer Name: fstocker1
External Customer Email:  
External Test Config: Coldfusion 10 running on Linux. 

When trying exactly the same on a Coldfusion 9 running on Solaris, it works fine.

See for Error Message on Linux/Coldfusion 10

See for working version on Solaris/Coldfusion 9



@fstocker1 Can you please provide sample pdf and code snippet? Thanks (Comment added from ex-user id:vnigam)
Comment by Adobe D.
17789 | May 30, 2013 12:29:45 AM GMT
Code SNippet <cfpdfform source="/tmp/abm.pdf" result="resultStruct" action="read"/> <cfdump var="#resultStruct#"> sample PDF: -frank
Comment by External U.
17790 | May 30, 2013 01:00:31 AM GMT
Thanks Frank We'll try again and let get back to you (Comment added from ex-user id:vnigam)
Comment by Adobe D.
17791 | May 30, 2013 01:03:34 AM GMT
I also found this in Coldfusion 10 Enterprise running on RHEL 6.4
Vote by External U.
17795 | June 17, 2013 05:47:41 PM GMT
@fstocker1 Still unable to replicate your issue I ran the mentioned and got the dump successfully Im running my server on a 32 bit OpenSuse, ColdFusion Version : 10,0,6,283435Java : 1.6.0_29 Please check your ColdFusion Version and Java and let me know . -Viny (Comment added from ex-user id:vnigam)
Comment by Adobe D.
17792 | June 20, 2013 11:31:35 PM GMT
I'm also using 1.6.0_29 (the one that comes bundled with cf 10) /opt/coldfusion10/jre/bin/java -version java version "1.6.0_29" Java(TM) SE Runtime Environment (build 1.6.0_29-b11) Java HotSpot(TM) 64-Bit Server VM (build 20.4-b02, mixed mode) Of the CF side I just installed all latest Updateset so I should be on the lastest Version now. One funny thing thoug: Even though my Update jar says: Update Level /opt/coldfusion10/cfusion/lib/updates/hf1000-CF-3332326.jar The CF Version still says 10,0,10,282462 (and its not the japanese version and I reapplied the mandatory update today)
Comment by External U.
17793 | June 22, 2013 04:11:16 PM GMT
could see one difference is I'm on 64 bit while you are on 32 bit ... dont know if this makes a big difference.
Comment by External U.
17794 | June 22, 2013 04:12:39 PM GMT
I'm seeing this in CF10 OSX.
Vote by External U.
17796 | February 01, 2014 09:48:08 AM GMT