tracker issue : CF-3351451

select a category, or use search below
(searches all categories and all time range)

Cannot edit or delete scheduled tasks

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/Duplicate

Reporter/Name(from Bugbase): Tom Lofts / Tom Lofts (loftx)

Created: 10/23/2012

Components: Scheduler

Versions: 10.0

Failure Type:

Found In Build/Fixed In Build: Final /

Priority/Frequency: Major / Some users will encounter

Locale/System: English / Win 2003 Server

Vote Count: 9

Duplicate ID:	CF-3701046

Problem Description:

We recently put a fresh install of ColdFusion 10 on a server and created a number of scheduled tasks. I'm now looking to edit or delete one of the scheduled tasks, but when clicking the delete button in the task scheduler or updating the task and clicking submit I receive an error. Refreshing the list of scheduled tasks indicates the task has not been deleted or updated. 

Also, all scheduled tasks are now upper case, though I believe they were mixed case when created.

Steps to Reproduce:

The error doesn't occur with newly created scheduled tasks, but ones I've created previously so I'm unable to reproduce the issue. With the current scheduled task either delete or edit the task and the following appears:

Actual Result:

Error Occurred While Processing Request

Error Diagnostic Information

The following task could not be found: [Task Name]. 
The error occurred on line 141.

Date/Time: {ts '2012-10-23 09:48:31'} 
Browser: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.94 Safari/537.4 
Remote Address: [Address]
HTTP Referer: [Referer]

Please inform the site administrator that this error has occurred (be sure to include the contents of this page in your message to the administrator).

Expected Result:

The task should be deleted or updated

Any Workarounds:

I was able to remove the tasks by deleting the relevent sections from neo-cron.xml

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3351451

External Customer Info:
External Company:  
External Customer Name: loftx
External Customer Email:  
External Test Config: My Hardware and Environment details:



@loftx, Regarding task names become uppercase after .car deploy and CF restart, this is a known issue #CF-3194041 and is marked Open/ToTest/Fixed. Regarding pre-CF10 tasks being undeletable/uneditable, I recall this issue but not sure if it was ever filed. The issue is likely related to CF10's new scheduler engine (Quartz Scheduler) being case-sensitive. This is likely why parts of CF are having difficulty 'locating' the tasks in CF10. Looks like .car deploy wasn't updated in this regard. Thanks!, -Aaron
Comment by External U.
17404 | October 24, 2012 04:44:22 AM GMT
We have the same issue with scheduled task names getting converted to uppercase. We did manually edit the neocron.xml file to import from our old CF install. This brought the old tasks over successfully though the names were uppercase. I then hand-edited the tasks including changing the name to mixed case, and changing the names of a few. They looked fine for a while, but after restarting CF all of the tasks names are now exactly as I entered them, but uppercase. All the rest of my changes were still intact. It's only the case of the names that change. Not a huge bug, but mildly annoying for those of us with OCD. ;-)
Vote by External U.
17409 | January 17, 2013 11:02:59 AM GMT
This is occurring on my server - also a fresh CF 10 Enterprise install.
Vote by External U.
17410 | March 14, 2013 05:14:30 AM GMT
I have a similar problem: any time I edit an existing scheduled task, it throws the error "Unable to store Job: 'xyz', because one already exists with this identification.". If I then go back to the list of scheduled tasks, the task does not show up, however, if I try to re-create the task, it says the task already exists. Only after restarting the application server am I able to re-create the task. This is a high priority issue and must be fixed ASAP. It's hard to believe Coldfusion 10 would ship with such serious bugs. Coldfusion version: 10,0,11,285437; Standard edition; Windows Server 2008 R2
Vote by External U.
17411 | September 13, 2013 02:06:41 PM GMT
I'm seeing the same issue.
Vote by External U.
17412 | September 13, 2013 02:12:16 PM GMT
This is occurring on my server
Vote by External U.
17413 | September 13, 2013 02:14:48 PM GMT
have same problem
Comment by External U.
17405 | September 18, 2013 02:16:13 PM GMT
Have you verified this in the latest build?
Comment by Suchika S.
17406 | September 25, 2013 05:11:55 AM GMT
Confirmed with us as well - this persists through the latest build.
Vote by External U.
17414 | December 02, 2013 07:45:22 AM GMT
•An error occured scheduling the task. Unable to store Job : 'SERVERSCHEDULETASK#$%^DEFAULT.job_DOMAIN_ORG: SCHEDULE_NAME', because one already exists with this identification - Windows Server 2012 R2 x64 CF10
Vote by External U.
17415 | March 18, 2014 04:12:46 PM GMT
Problem still exists on a fully patched fresh install of ColdFusion 10 Standard x64 on Windows Server 2012 x64.
Vote by External U.
17416 | April 17, 2014 08:55:08 AM GMT
Seems to be something Adobe enjoy BALLSING UP including the archive deployment. When you build a new product based on CF10 (aka CF11) did they start from scratch? They must have to have introduced so many NEW issues without addressing those still outstanding for CF10. Adam Cameron must be nearly rolling in his grave (if he was in one of course - which thankfully he is not!). I am no fool - or am I - using CF for 18 years nearly. Railo is looking better all the time.
Comment by External U.
17407 | April 17, 2014 10:17:27 PM GMT
I am running into same issue on Windows 2012R2 x64. I have CF10 Update 13. Task was created and showed up in list. Tried to run it and got an error. Hitting the file directly works fine. So I went into task to check for a typo, tried to "submit" and got an error. Now it is not showing in the list anymore. I tried to recreate, and I get the already exists error. I can't restart CF because the server is in production.
Vote by External U.
17417 | August 29, 2014 10:09:34 AM GMT
Fixed for CF10_HF14.
Comment by Suchika S.
17408 | October 13, 2014 06:10:41 AM GMT