tracker issue : CF-3493990

select a category, or use search below
(searches all categories and all time range)

CFPDF doesn't add headers/footers to PDF files

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/CannotReproduce

Reporter/Name(from Bugbase): Rob Kolosky / Rob Kolosky (rkolosky)

Created: 01/31/2013

Components: Document Management

Versions: 10.0

Failure Type: Crash

Found In Build/Fixed In Build: Final /

Priority/Frequency: Critical / All users will encounter

Locale/System: English / Windows 7 SP1 64-bit

Vote Count: 1

Problem Description: When attempting to add a header of footer to a PDF file, ColdFusion throws an error

Steps to Reproduce: With any PDF, run the code:

<cfpdf action="addheader" source="C:\inetpub\wwwroot\Safety\documents\delivery\2012.pdf" align="left" text="Header header header" />

The system responds with:

The system has attempted to use an undefined value, which usually indicates a programming error, either in your code or some system code.
Null Pointers are another name for undefined values.
Platform, Locale, and Platform Name must not be null

Browser  	Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17
Remote Address  	::1
Date/Time  	31-Jan-13 11:45 AM
Stack Trace
at cfact_test2ecfm2073822786.runPage(C:/inetpub/wwwroot/Safety/controller/act_test.cfm:58) at cfmain2etest2ecfm560424310.runPage(C:/inetpub/wwwroot/Safety/parsed/main.test.cfm:20) at cfApplication2ecfc1236191549$funcONREQUEST._factor2(C:/inetpub/wwwroot/fusebox5/Application.cfc:228) at cfApplication2ecfc1236191549$funcONREQUEST.runFunction(C:/inetpub/wwwroot/fusebox5/Application.cfc:218) 

java.lang.NullPointerException: Platform, Locale, and Platform Name must not be null
	at com.adobe.fontengine.fontmanagement.platform.PlatformFontDescription.<init>(Unknown Source)
	at com.adobe.fontengine.font.opentype.OpenTypeFont.getPlatformFontDescription(Unknown Source)
	at com.adobe.fontengine.font.FontImpl.getPlatformFontDescription(Unknown Source)
	at com.adobe.fontengine.font.FontImpl.getPlatformFontDescription(Unknown Source)
	at com.adobe.fontengine.fontmanagement.platform.PlatformFontResolverImpl.addFont(Unknown Source)
	at com.adobe.internal.pdftoolkit.core.fontset.impl.PDFFontSetImpl.addFont(Unknown Source)
	at com.adobe.internal.pdfm.util.FontSetBuilder.loadFontsPath(
	at com.adobe.internal.pdfm.util.FontSetBuilder.loadSystemFonts(
	at com.adobe.internal.pdfm.util.FontSetBuilder.makePDFFontSet(
	at com.adobe.internal.pdfm.util.FontSetBuilder.getPdfFontSet(
	at com.adobe.internal.pdfm.PDFM7Factory.getPdfFontSet(

Plus more ...

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3493990

External Customer Info:
External Company:  
External Customer Name: rkolosky
External Customer Email:  
External Test Config: My Hardware and Environment details: Windows 7 SP1 x64

Chrome Browser version 24.0.1312.56 m

Running Cold Fusion 10,0,7,283649



I would add the entire stack trace but the system won't allow it.
Comment by External U.
16427 | January 31, 2013 11:23:11 AM GMT
I have the same issue when trying to add a test header. This issue also happens when you try to add a text watermark.
Vote by External U.
16430 | March 20, 2013 08:55:55 AM GMT
Tried a simple PDF and it worked for me @rkolosky Can you please try again and let me know if it is still failing for you? If yes then please attach the pdf and provide config details Thanks (Comment added from ex-user id:vnigam)
Comment by Adobe D.
16428 | June 06, 2013 10:44:11 PM GMT
As there is no response from the user, Closing the bug as Cannot Reproduce. If you are still facing the issue, please provide the repro case, will re-open the bug.
Comment by Suchika S.
16429 | December 03, 2014 01:21:31 AM GMT