tracker issue : CF-3512854

select a category, or use search below
(searches all categories and all time range)

Error connecting to Oracle servers using Oracle Advanced Security

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Dave Irovic / Dave Irovic (Dave Irovic)

Created: 03/04/2013

Components: Database

Versions: 10.0

Failure Type:

Found In Build/Fixed In Build: Final / CF11 Update5

Priority/Frequency: Major / All users will encounter

Locale/System: English / Win 2008 Server R2 64 bit

Vote Count: 0

Listed in the version Issues Fixed doc
Problem Description:

When attempting to setup a data source using the ColdFusion Oracle driver to connect to an Oracle database using Oracle Advanced Security, we always get the error: "java.sql.SQLNonTransientConnectionException: [Macromedia][Oracle JDBC Driver]No more data available to read." We tried to add the parameters to use encryption in the connection string for the data source "EncryptionLevel=accepted;EncryptionTypes=(AES256,RC4_256,AES192,3DES168,AES128,RC4_128);" but we get the same error.  Can someone document the steps to add a data source using this encryption method?  Thanks.

Steps to Reproduce:

Follow the standard steps for adding an Oracle data source by entering the SID Name, Server, port, user name, password with the Oracle data source type.  Click Show Advanced Settings and enter "EncryptionLevel=accepted;EncryptionTypes=AES256,RC4_256,AES192,3DES168,AES128,RC4_128);" into the connection string field.  Press Submit.  The above error appears on verification, and any call to query the data source.

Any Workarounds:

Nothing works using the ColdFusion driver.  If we download the native thin Oracle JDBC driver, we can create a connection using the Other data source type, and it connects fine.  The problem with using this option is we lose the query timeout parameter, and long or runaway queries never return and hang threads in ColdFusion.  We are trying to avoid this with the CF10 upgrade.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3512854

External Customer Info:
External Company:  
External Customer Name: IrovicD
External Customer Email:  
External Test Config: My Hardware and Environment details:

Server is a VM running with 4 CPU and 12GB RAM (3GB allocated to the JVM ColdFusion instance), and running on Windows Server 2008 R2 Enterprise.



The status says this issue has been fixed. Can you tell me how do I go about getting the fix for this?
Comment by External U.
16107 | March 14, 2014 11:25:56 AM GMT
This fix will be available in the next major release of ColdFusion,
Comment by Vamseekrishna N.
16108 | March 17, 2014 05:12:24 AM GMT
The fix for this bug is available in the pre-release build of ColdFusion 11 Update 5
Comment by CFwatson U.
16109 | February 20, 2015 09:24:04 AM GMT
I have CF11 update 5 installed. Can you tell me the specific parameters we need to set to enable this feature? Or does it work by default this way?
Comment by External U.
16110 | June 11, 2015 09:27:57 AM GMT