tracker issue : CF-3536673

select a category, or use search below
(searches all categories and all time range)

Problem with empty CGI variables/Windows authentication in CF10/IIS 7.5

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Philipp Cielen / Philipp Cielen (Philipp Cielen)

Created: 04/05/2013

Components: Installation/Config

Versions: 10.0

Failure Type: Data Loss

Found In Build/Fixed In Build: Final / CF11 Update7,CF10 Update18

Priority/Frequency: Major / Some users will encounter

Locale/System: English / Win 2008 Server R2 64 bit

Vote Count: 7

Listed in the version Issues Fixed doc
Problem Description: After installation of CF 10 on  Win 20ß08 Server R2/IIS 7.5 Windows authentication no longer works, cgi.remote_user and other variables in the CGI scope are not filled even after logging on via Windows authentication. CF 9 was installed on the same machine previously and worked fine with windows authentication via IIS. 

Additional information on this bug can be found on the Adobe forums

We have reinstalled the CF connector several times, tried all possible and impossible authentication settings in IIS admin but it still does not work.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3536673

External Customer Info:
External Company:  
External Customer Name:
External Customer Email:  
External Test Config: My Hardware and Environment details: Windows 2008 Server R2 64 bit with IIS 7.5 on a virtual server environment.



this bug is critical to our organization as it prevents the company to move its several ColdFusion 8 and 9 servers to ColdFusion 10.
Comment by External U.
15792 | April 05, 2013 07:02:22 AM GMT
This was tested on ColdFusion 10,0,8,284032
Comment by External U.
15793 | April 05, 2013 08:28:54 AM GMT
I think the solution to your problem may be here I found that setting them at the site level vs server level seems to work as well. Using CF10 and Windows authentication without any issues on a dozen virtual server.
Comment by External U.
15794 | April 05, 2013 12:24:26 PM GMT
We have set Windows authentication on all levels: Server, Site and Folder and have tried all possible combinations of enabling/disabling anonymous access. We restarted IIS and the client browser after each change. Still cgi.remote_user is not set. Authentication information is passed correctly to .htm pages and images but not to .cfm and .cfc files (as can be seen in the IIs server logs) which shows that it is not a browser/authentication issue but soemthing that has to do with IIS 7.5's connection to CF 10. The same server worked with CF 9 without a problem. All hotfixes are installed, CF connector has been reinstalled after updating.
Comment by External U.
15795 | April 11, 2013 09:29:28 AM GMT
this happened only after upgrading from CF 9 to CF 10. After reinstalling both IIS and CF everything worked ok.
Comment by External U.
15796 | April 12, 2013 04:02:36 AM GMT
Is the issue resolved and can we close this bug ?
Comment by Asha K.
15797 | May 21, 2013 08:53:18 AM GMT
no, this is not resolved. It still happens on updates. The only way to circumvent this was to completely uninstall both IIS and ColdFusion and then reinstall both from scratch. This is not acceptable, imho the bug should be tracked and fixed.
Comment by External U.
15798 | July 02, 2013 08:01:41 AM GMT
Please resolves this ASAP. We just had Windows authentication configuration error that has now caused a problem on 5 servers. Setting it at the server level or site level is no longer having an effect.
Vote by External U.
15809 | September 19, 2013 10:34:45 AM GMT
This issue is not solved - we're experiencing this with CF10 / Win 2012R2 IIS 8.5
Vote by External U.
15810 | January 31, 2014 01:52:04 AM GMT
Having the same issue with Win 2012 / IIS 8.5
Comment by External U.
15799 | January 31, 2014 01:52:59 AM GMT
This is still a huge problem with CF10 / Win 2012R2 IIS 8.5 keeping us from deploying CF10 to our call center.
Vote by External U.
15811 | January 31, 2014 02:05:57 AM GMT
This bug is preventing us from moving 15 CF8 servers to CF10.
Comment by External U.
15800 | January 31, 2014 02:07:34 AM GMT
This is still broken and preventing us from completing our upgrade to CF10.
Vote by External U.
15812 | January 31, 2014 11:42:02 AM GMT
This is a show stopper for us.
Vote by External U.
15813 | January 31, 2014 11:42:21 AM GMT
This is hampering our effort to upgrade to CF10 big time
Vote by External U.
15814 | January 31, 2014 11:45:00 AM GMT
We are unable to reproduce the said scenario. ColdFusion 10 with Update 13 installed displays CGI.REMOTE_USER and CGI.AUTH_USER variables as expected on a Windows 2008 R2 / IIS 7.5 when Windows Authentication is enabled. Do you notice any other CGI variables missing / incorrectly displayed?
Comment by Immanuel N.
15801 | February 06, 2014 04:28:46 AM GMT
Immanuel, unfortunately I can no longer deliver details on this as we have completely reinstalled the said server from scratch to get this working. Another CF 9 server that was similarly configured and upgraded to CF 10 earlier this year was not affected by this issue. Meanwhile it was decided not to update any of the other servers and skip version 10. This response 10 months after I have posted this issue is rather disappointing. You might want to get in touch with the other people who have voted on this bug. I can only try to imagine what this bug alone has cost Adobe in lost revenue.
Comment by External U.
15802 | February 19, 2014 09:25:12 PM GMT
Closing the bug as "Not a Bug" since the defined scenario works as expected on our end, and because we did not receive any additional information from the customer. If this bug still exists on your environment, please report back, and we will be reopening this bug.
Comment by Immanuel N.
15803 | December 03, 2014 01:33:04 AM GMT
This issue is not solved - we're experiencing this with CF11 / Win 2012R2 IIS 8.5
Vote by External U.
15815 | January 20, 2015 12:50:26 PM GMT
I don't think the resolution is "not a bug" as you never proved that. All you can say is "could not reproduce".
Comment by External U.
15804 | January 21, 2015 05:36:37 AM GMT
@Paolo Rabinelli Could you please provide more details on this. 1) The update installed on ColdFusion 11 server 2) Was the connector reconfigured after the update has been installed If you see the issue with HF3 installed on CF11, and also has the connectors reconfigured, could you please send across the connector logs to Changed the bug status appropriately.
Comment by Immanuel N.
15805 | January 21, 2015 05:43:23 AM GMT
Hi Immanuel, I also see CGI.REMOTE_USER is populated correctly for Windows Authentication in CF11 Update 5. I see this ticket is Closed/Fixed. I am trying to reproduce this issue. How were you able to reproduce it? Thanks!, -Aaron
Comment by External U.
15806 | December 03, 2015 06:06:45 PM GMT
Aaron, The issue would crop up when anonymous authentication is enabled at the site level, while windows auth was enabled at the server and folder level. Remote_user would not be populated for files under the folder level.
Comment by Immanuel N.
15807 | December 03, 2015 09:21:26 PM GMT
Hi Immanuel, I see CGI.REMOTE_USER is populated in Update 5 for index.cfm under folder level for this config: Server level: Windows auth enabled; all others disabled Site level: Anonymous auth enabled; all others disabled Folder level: Windows auth enabled; all others disabled Do I have the right config? At server & folder level, only Windows auth enabled. At site level, only Anonymous auth enabled? Thanks!, -Aaron
Comment by External U.
15808 | December 04, 2015 03:32:34 AM GMT