tracker issue : CF-3540876

select a category, or use search below
(searches all categories and all time range)

Excel functionality - SpreadsheetFormatCell missing method

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): andy hudson / andy hudson (AndyHudson1979Coppull)

Created: 04/12/2013

Components: Charting/Graphing

Versions: 9.0.1

Failure Type: Non Functioning

Found In Build/Fixed In Build: 9.0.1 /

Priority/Frequency: Major / Some users will encounter

Locale/System: English / Win 2003 Server

Vote Count: 13

Problem Description: After applying a security fix on April 9, 2013 - we have encountered a problem using SpreadsheetFormatCell function in CF's excel functionality. Basically, the function no longer seems to exist!

Steps to Reproduce: Try to use SpreadsheetFormatCell

Actual Result:
java.lang.NoSuchMethodError: coldfusion.excel.Excel.formatCell(Lcoldfusion/excel/ExcelInfo;Lcoldfusion/runtime/Struct;IIZ)V

Expected Result: It would not throw an error and would just work as before.

Any Workarounds: Do not use the function anymore

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3540876

External Customer Info:
External Company:  
External Customer Name: AndyHudson1979Coppull
External Customer Email:  
External Test Config: My Hardware and Environment details:



updating to hf901-00009.jar created this issue. This functionality is critical to supporting the excel exports built with coldfusion.
Vote by External U.
15706 | April 17, 2013 11:14:24 AM GMT
same is happening to me. This is a critical issue for me as we rely on our app creating spreadsheets. Should I reverse the patch and be exposed or remove some spreadsheet functionality?
Vote by External U.
15707 | April 18, 2013 05:59:11 AM GMT
We use this function all over the place and is fundamental to the reports we produce for our clients... obviously we don't want to be exposed to security vulnerabilities either so please re-implement.
Vote by External U.
15708 | April 18, 2013 07:35:31 AM GMT
Also experiencing this problem. I'm guessing this is a bug seeing as spreadsheetFormatCell is such a widely used function and it wouldn't be pulled without notice. Please fix and release hotfix (that won't break any other core functions) ASAP.
Vote by External U.
15709 | April 18, 2013 08:01:43 AM GMT
We're also running into this problem! Adding my vote as this is a critical issue that cannot be worked around except by removing a security patch.
Vote by External U.
15710 | April 18, 2013 08:46:22 AM GMT
I encounter the same problem. SpreadsheetFormatCell function is frequently used in my application,so that I cannot be applied to this patch for this problem. I am hoping this problem to be fixed as soon as possible.
Vote by External U.
15711 | April 19, 2013 12:40:57 AM GMT
I encountered the same error on any file that tries to create a spreadsheet. If I comment out all of the spreadsheetformatcell lines the spreadsheet will get created. I backed out the APSB13-10 update and it created spreadsheets normally. I am running on a windows server 2008 R2, CF 9.01 patched to HF4.
Comment by External U.
15701 | April 19, 2013 10:34:23 AM GMT
I have the exact same problem. CF 9.0.1 with cumulative hot fix 4 on Server 2008 R2.
Vote by External U.
15712 | April 22, 2013 09:09:16 AM GMT
CF9.01 throws an error when I try to open any file that creates an Excel spreadsheet. If I comment out all of the spreadsheetformatcell lines the spreadsheet will get created. I backed out the APSB13-10 update and it created spreadsheets normally. I am running on a windows server 2008 R2, CF 9.01 patched to HF4.
Vote by External U.
15713 | April 22, 2013 09:52:27 AM GMT
Also broken inexplicably on our installation just after this update. Please fix!
Vote by External U.
15714 | April 24, 2013 12:02:19 PM GMT
Unacceptable. A security fix shouldn't break spreadsheet functionality.
Vote by External U.
15715 | April 25, 2013 07:11:25 AM GMT
After applying hotfix APSB13-10, CF 9 SpreadsheetFormatCell function for formatting Excel spreadsheets is no longer working.
Vote by External U.
15716 | May 03, 2013 08:43:31 AM GMT
was working fine and now I get this error as well
Vote by External U.
15717 | May 03, 2013 02:28:09 PM GMT
Also experiencing this on our production Update Level /opt/coldfusion9/lib/updates/hf901-00009.jar instance. No workaround known as of yet.
Vote by External U.
15718 | May 06, 2013 06:11:12 PM GMT
Use SpreadsheetFormatCellRange as a workaround. Set endRow and endColumn to the same values as startRow and startColumn respectively to obtain the same functionality as SpreadsheetFormatCell
Comment by External U.
15702 | May 14, 2013 09:56:45 PM GMT
This issue is fixed in APSB13-13. For more details: Regards, Nimit
Comment by Nimit S.
15703 | May 16, 2013 07:49:55 AM GMT
The status of this bug is "fixed", but the "Fixed In Build" section is empty. What does this mean? Does this mean that it's fixed but hasn't been released yet?
Comment by External U.
15704 | May 20, 2013 10:08:45 AM GMT
Jamao, as Nimit noted, the fix has indeed been released, as APSB13013.
Comment by External U.
15705 | May 20, 2013 08:03:09 PM GMT