tracker issue : CF-3616682

select a category, or use search below
(searches all categories and all time range)

Support plain-named query param types

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Adam Cameron / Adam Cameron (Adam Cameron)

Created: 08/22/2013

Components: Database, CFQuery

Versions: 10.0

Failure Type: Enhancement Request

Found In Build/Fixed In Build: Final / 286322

Priority/Frequency: Trivial / Unknown

Locale/System: English / Platforms All

Vote Count: 9


Railo supports more obvious type names for <cfqueryparam> tags, eg: "integer" rather than "CF_SQL_INTEGER". CF could join the party on that one.

Whilst I'm here, how about getting rid of the "cf" on "cfsqltype". Indeed, just get rid of "cfsql". It's a type. It's in a <CFQUERY> tag... we know it's CF and SQL, so why belabour the point?



----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3616682

External Customer Info:
External Company:  
External Customer Name: Adam Cameron.
External Customer Email:  
External Test Config: My Hardware and Environment details:



This should be added because it makes sense.
Vote by External U.
14667 | August 22, 2013 02:09:28 PM GMT
Simplifies the code, not a bad thing
Vote by External U.
14668 | August 22, 2013 02:26:49 PM GMT
I support this. It just makes sense.
Vote by External U.
14669 | August 22, 2013 03:46:34 PM GMT
sure, sounds good 25chars yet? damn it
Vote by External U.
14670 | August 22, 2013 08:21:22 PM GMT
+infinity! It would be a cleaner approach to that attributes values.
Vote by External U.
14671 | August 22, 2013 10:58:28 PM GMT
+1 .
Vote by External U.
14672 | August 23, 2013 01:05:07 PM GMT
excellent idea CF_SQL_ isn't necessary
Vote by External U.
14673 | August 23, 2013 02:16:19 PM GMT
Excellent idea. It will cut down on a lot of unnecessary characters in coding, and just makes sense.
Vote by External U.
14674 | August 27, 2013 12:11:21 PM GMT
I note this has been marked "to fix". 1) cool! 2) does that cover both simplifying the type names as well as the attribute name (eg: "cfsqltype" to "sqltype" or just "type"), or is it just a simplification of the type names? Cheers. -- Adam
Comment by External U.
14656 | September 03, 2013 11:51:48 AM GMT
+1. Always for fewer keystrokes. Easier to read and understand if "cf_sql_" is dropped. Way overdue.
Vote by External U.
14675 | September 03, 2013 10:10:34 PM GMT
Hello? Could we get clarification on this pls? -- Adam
Comment by External U.
14657 | October 19, 2013 09:49:18 AM GMT
We have simplified type names as you suggested. However we are not changing the attribute names.
Comment by Rupesh K.
14658 | November 12, 2013 12:56:32 PM GMT
Cheers Rupesh, no probs. Just out of interest, why persist with the tautological attribute names? Cheers for dealing with this, btw. -- Adam
Comment by External U.
14659 | November 12, 2013 01:30:59 PM GMT
Hello? -- Adam
Comment by External U.
14660 | January 09, 2014 08:44:24 AM GMT
This enhancement has been included in the next major version. However, we have not changed any attribute name.
Comment by Nimit S.
14661 | February 26, 2014 06:24:28 AM GMT
@Rupesh: you never answered my question. This has come up again. Can you pls follow-up properly? Cheers.
Comment by External U.
14662 | July 23, 2015 01:44:05 PM GMT
It could have been named sqltype but I think it was named differently because it is slightly different from standard sql types. For example, we can have cfsqltypes as "Money", "Money4", "IdStamp", "RefCursor" etc which are not standard sqltypes and we map it to appropriate sql types internally. Also, since this attribute has been there for such a long time, I don;t see any compelling need to change it.
Comment by Rupesh K.
14663 | October 26, 2015 08:33:02 PM GMT
Hi Rupesh, thanks for finally coming back to us. Seriously: almost two years to do so? What's with that? "Also, since this attribute has been there for such a long time, I don;t see any compelling need to change it." Because *it would be an improvement*. Your "logic" here implies you guys always get everything perfect first time. Which we all know... *you really don't*. As for "cfsqltype" vs "sqltype", you make a point on that one. But this does not explain why you don't simply make it "type".
Comment by External U.
14664 | October 27, 2015 12:58:38 AM GMT
We need to have a consistency between cfqueryparam and cfprocparam as both have cfsqltype attribute. And type is already an attribute on cfprocparam tag. That rules out 'type'
Comment by Rupesh K.
14665 | October 27, 2015 09:02:39 PM GMT
Yep, fair enough. Cheers for the timely feedback on this. Keep it up!
Comment by External U.
14666 | October 28, 2015 02:41:55 AM GMT