tracker issue : CF-3627310

select a category, or use search below
(searches all categories and all time range)

Websockets fail on Safari for IOS

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/CannotReproduce

Reporter/Name(from Bugbase): Andy Leontovich / Andy Leontovich (washcocf)

Created: 09/05/2013

Components: Web Socket

Versions: 10.0

Failure Type: Non Functioning

Found In Build/Fixed In Build: Final /

Priority/Frequency: Critical / All users will encounter

Locale/System: English / Win 2008 Server R2 64 bit

Vote Count: 0

Problem Description: I am unable to get any of the demos by Adobe staff and unable to get my own code to operate on Safari or Chrome for iOS the same way it works on PC browser.

Steps to Reproduce: Load any of the websocket demo files onto a webserver with CF 10 standard, IIS7.5. Access the url to the demo file from a wifi iPad or iPphone with iOS 6.1.3

Actual Result: When the demos are run, the page is unresponsive. There is no result.

Expected Result: The page should respond the same way PC browsers operate.

Any Workarounds: None that I can find.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3627310

External Customer Info:
External Company:  
External Customer Name: washcocf
External Customer Email:  
External Test Config: My Hardware and Environment details:

Servers on VMWare

Windows 7 with Chrome 29.0.1547.62 m, IE9, and Safari 5.1.7

iPad2 with iOS 6.1.3

iPhone with iOS 6.1.3



I Googled the problem and found some discussion about how iOS drops connections with some kinds of websocket requests. I am able to get 3rd part websocket pages to operate fine, but none of the Adobe CF10 websocket pages work.
Comment by External U.
14575 | September 05, 2013 10:32:25 AM GMT
Please verify and put the steps to reproduce it.
Comment by Awdhesh K.
14576 | September 24, 2013 05:09:29 AM GMT
I have verified it and it is working fine. Can you please try to verify it again? Regards, Nimit
Comment by Nimit S.
14577 | September 26, 2013 01:12:29 AM GMT
Download the demo: and install it. It will run fine on Chrome. Now access the URL on an iPad2 (not upgraded to iOS 7). The page renders but the buttons don't work. Tap and nothing happens. I have tried other demos and while the desktop browsers will reflect changes-the iOS devices don't.
Comment by External U.
14578 | January 02, 2014 01:34:49 PM GMT
I followed the instructions: Procedure: 1. Extract the demo JAR to wwwroot. 2. Access the websocket.cfm file from your browser. 3. This CFM template has a subscribe button to subscribe to a channel and a publish button to publish a message to the registered channel. 4. Once you are comfortable with initial concept, please comment the third line and uncomment the fourth line in application.cfc to check server-side callback invocation. 5. Check allowSubscribe, allowPublish and beforePublish callback function of 'stockChannelListner.cfc' . When I refresh the Chrome page, again it works fine. I get: WebSocket connection opened Successfully. {"clientid":393723230,"ns":"coldfusion.websocket.channels","reqType":"welcome","code":0,"type":"response","msg":"ok"} {"clientid":393723230,"ns":"coldfusion.websocket.channels","reqType":"subscribeTo","code":0,"type":"response","msg":"ok","channelssubscribedto":"chat"} When I refresh the iPad, nothing shows up under the form.
Comment by External U.
14579 | January 02, 2014 01:38:58 PM GMT
I have tried it with iPad and iPhone and it seems to be working fine. Please share the information mentioned below: 1. Enable websocket logging using neo-websocket.xml file located at <cfinstall>\cfusion\lib. 2. Console error from chrome browser, if any.
Comment by Nimit S.
14580 | December 05, 2014 01:23:34 AM GMT
Are you still facing this issue? If yes, then please provide the requested information.
Comment by Nimit S.
14581 | May 07, 2015 01:30:25 AM GMT
We have not received any update on this issue, so closing this bug. If anyone still facing this issue, please feel free to write back.
Comment by Nimit S.
14582 | June 04, 2015 11:33:05 PM GMT