tracker issue : CF-3653076

select a category, or use search below
(searches all categories and all time range)

Bad apache / tomcat connector for Mac OSX Mavericks 10.9

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Rob Sherman / Rob Sherman (CFDad)

Created: 10/22/2013

Components: Installation/Config

Versions: 10.0

Failure Type: Non Functioning

Found In Build/Fixed In Build: Final / 286522

Priority/Frequency: Critical / All users will encounter

Locale/System: English / Mac 10.6 for Intel

Vote Count: 48

Problem Description:  the apache connector for ColdFusion 10 on Mac Osx 10.9 (Mavericks) does not work.  Apache fails to start with a sigterm error when it hits the line to process:

in /etc/apache2/httpd.conf
Include "/private/etc/apache2/mod_jk.conf"

Steps to Reproduce:  Do a plain install of ColdFusion 10, server edition, apache connector for /etc/apache2/ on a Mac OSX 10.9 (Mavericks) machine - any.

Actual Result:  Apache fails to start, ColdFusion Administrator page can not be launched and further updated.

Expected Result:

Any Workarounds:
Uninstall ColdFusion - not a work around but at least it returns Apache to a working state or comment out the above line referenced in httpd.conf.

Another note:  if you use in a terminal:  sudo apachectl -e debug I get the following:
[[Tue Oct 22 21:44:19 2013] [debug] mod_so.c(246): loaded module jk_module
/usr/sbin/apachectl: line 90: 62575 Abort trap: 6           $HTTPD $ARGV

That last line about the Abort trap: 6 and $HTTPD $ARGV lead me to believe that there is something in this modified connector in /Applications/ColdFusion10/config/wsconfig/1/ that is the crux of the problem.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3653076

External Customer Info:
External Company:  
External Customer Name: CFDad
External Customer Email:  
External Test Config: My Hardware and Environment details:

 Osx 10.9 Mavericks

 Model Name:	MacBook Pro

  Model Identifier:	MacBookPro10,1

  Processor Name:	Intel Core i7

  Processor Speed:	2.8 GHz

  Number of Processors:	1

  Total Number of Cores:	4

  L2 Cache (per Core):	256 KB

  L3 Cache:	8 MB

  Memory:	16 GB

  Boot ROM Version:	MBP101.00EE.B03



I confirm this issue. As an addition: dumps shared memory files every second into /wsconfig/1 directory. The latest version of 1.2.37 won't compile on Mavericks as well.
Vote by External U.
14120 | October 23, 2013 08:36:46 AM GMT
I can confirm as well. Apache fails to start and with LogLevel set to debug you can see that the connector continues to load and crash repeatedly until apache is killed. Apache is never able to fully start.
Vote by External U.
14121 | October 23, 2013 10:25:20 AM GMT
Confirmed...I also experienced what is described in the original report. ColdFusion 10 is non-functional under Mavericks.
Vote by External U.
14122 | October 23, 2013 11:11:57 AM GMT
Confirmed same Apache behaviour after system was update to Mavericks
Vote by External U.
14123 | October 23, 2013 12:16:04 PM GMT local development environment is toast after updating to Mavericks - Apache 2.2.24. Commenting out the mod_jk loader in apache2/httpd let's apache startup which is good for standard but still need ColdFusion 10 up and running.
Vote by External U.
14124 | October 23, 2013 12:31:05 PM GMT
Also experiencing the same issue after upgrading to mavricks.
Vote by External U.
14125 | October 23, 2013 12:45:21 PM GMT
Not sure why Apple insists on screwing things up with every new version, but this is affected my local dev as well. It would be great if Adobe could release an update ASAP for this!
Comment by External U.
14053 | October 23, 2013 01:41:27 PM GMT
@Nik S all Apple has done is upgrade Apache modestly (from 2.2.22 to 2.2.24, not even the latest which is 2.4.x). Not to mention that Apple has had builds of OS X 10.9 available for months for members of the developer program which of course Adobe is one. On a side note, if you use MAMP Pro and the version of Apache that comes with it (2.2.22 at this time) the connector works fine.
Comment by External U.
14054 | October 23, 2013 01:44:48 PM GMT
Bumping up this bug because I plan to be installing Maverick, but not until this is fixed.
Vote by External U.
14126 | October 23, 2013 01:46:23 PM GMT
Preventing our devs from upgrading, please update as soon as possible!
Vote by External U.
14127 | October 23, 2013 01:49:53 PM GMT
@Sean Coyne Point taken, just seems every major OS X release causes newfound headaches with CF. Adobe has clearly stated that their mod_jk will only work with Apache up to 2.2.22, but hasn't done anything about it when 2.4 has been out for what, 2 years now?
Comment by External U.
14055 | October 23, 2013 01:58:33 PM GMT
Updated to Mavericks and it crashed my Apache/CF environment. Can'
Vote by External U.
14128 | October 23, 2013 01:58:34 PM GMT
I am always pushing my development Mac to the limits, even with 16 Gigs of RAM. The new performance enhancements in 10.9 Mavericks should greatly improve my development performance, especially in RAM usage.
Vote by External U.
14129 | October 23, 2013 02:03:52 PM GMT
To add to the description, this is error that's written to the log when the mod_jk is included in httpd: "httpd[...]: detected source and destination buffer overlap" Which then prevents the apache from (re-)starting up.
Comment by External U.
14056 | October 23, 2013 02:37:04 PM GMT
Please fix or at least provide a solution so that we can update the files/configurations ourselves...we need your help Adobe.
Vote by External U.
14130 | October 23, 2013 02:39:39 PM GMT
CF wants to run on dev-class macs. Dev-class macs run Mavericks.
Vote by External U.
14131 | October 23, 2013 02:46:05 PM GMT
My dev environment is OS-X
Vote by External U.
14132 | October 23, 2013 03:00:08 PM GMT
This is verified as it no longer works.
Vote by External U.
14133 | October 23, 2013 03:23:44 PM GMT
Can't do local CF dev on 10.9 without messy workarounds if this bug isn't fixed.
Vote by External U.
14134 | October 23, 2013 03:39:51 PM GMT
Recompiling after making a small changed worked fine for me, Adobe do provide their version of the source: I replaced this line in /native/common/jk_map.c: strcpy(buf, rc); with: memmove(buf, rc, len + 1); I'm not a C programmer so I can't guarantee I've introduced some horrible bug, but things have been working for me so far. Here's the copy I'm using if anybody else wanted to try:!618&authkey=!AOZJmH3HBrjvJ7s
Comment by External U.
14057 | October 23, 2013 03:40:31 PM GMT
Adobe - what's the rationale for using a custom mod_jk instead of the standard Tomcat connector? All it seems to cause is headaches every time something is updated.
Comment by External U.
14058 | October 23, 2013 03:41:40 PM GMT
I don't use a Mac but the ColdFusion team need to improve their game with supporting current OS versions. we've already been through all this with the previous version of OSX and Windows 8. There's been a dev release of this available to Adobe since June... they should have been ready for this. Adobe need to understand developers keep their machines current, and this means CF needs to work on the current releases of the operating systems developers will be using. -- Adam
Vote by External U.
14135 | October 23, 2013 03:48:47 PM GMT
I can confirm that Mike's recompiled version does work
Comment by External U.
14059 | October 23, 2013 03:50:29 PM GMT
Also confirmed Mike's file works...
Comment by External U.
14060 | October 23, 2013 04:26:32 PM GMT
Mike's version of works good for me. Mike, thank you
Comment by External U.
14061 | October 23, 2013 04:26:45 PM GMT
I am experiencing the same thing and will be trying Mike's file to see if it works for now.
Vote by External U.
14136 | October 23, 2013 04:59:33 PM GMT
Cannot use ColdFusion 10 on my Mac workstation without doing MAMP or internal ColdFusion server.
Vote by External U.
14137 | October 23, 2013 05:03:40 PM GMT
Mikes Version works for me as well .. ridiculous that the CF Team has not been testing this or ready for it .. same goes for Creative Cloud .. their app is currently incompatible with Mavericks ... pretty lame if you ask me
Comment by External U.
14062 | October 23, 2013 05:07:54 PM GMT
also confirmed - same issue
Vote by External U.
14138 | October 23, 2013 07:12:31 PM GMT
Confirming Mike's file works for me. Thanks Mike!
Comment by External U.
14063 | October 23, 2013 07:38:39 PM GMT
+1 - just tested Mike's file and it works fine
Comment by External U.
14064 | October 23, 2013 10:09:20 PM GMT
definitely needs to be fixed!
Vote by External U.
14139 | October 23, 2013 10:11:07 PM GMT
this needs to be fixed! actually, this shouldn't have been an issue...
Vote by External U.
14140 | October 24, 2013 02:58:15 AM GMT
Same issue here, but with CF 9 and OS X 10.9. It's impossible to run the webserver connector or modify the config manually.
Vote by External U.
14141 | October 24, 2013 03:51:29 AM GMT
Ik just bought new Mac's for development yesterday. We work with CF10 and with this my dev team will stop developing. That's an issue.
Vote by External U.
14142 | October 24, 2013 05:50:18 AM GMT
we shouldn't have this kind of issue every time there is an update to apache. how hard can it be to get the connector to work with the current apache version?
Vote by External U.
14143 | October 24, 2013 05:50:37 AM GMT
This bug causes all of our Mac systems to be unable to be updated to OS X Mavericks. Numerous systems have already come across this issue and development is now impeded.
Vote by External U.
14144 | October 24, 2013 06:40:49 AM GMT
Mike, Thanks for the fix! Your file worked great!
Comment by External U.
14065 | October 24, 2013 06:41:58 AM GMT
Waiting for an Update ................. It is not possible to get the CF10 developer edition to run on OSX Mavericks.
Vote by External U.
14145 | October 24, 2013 08:20:55 AM GMT
FYI...the Apple updater also replaces your httpd.conf file, but luckily it makes a backup for you. Read more here...
Comment by External U.
14066 | October 24, 2013 08:34:55 AM GMT
This really does need to be supported. CF10 is the current version of ColdFusion and needs to support modern OS's.
Vote by External U.
14146 | October 24, 2013 12:23:56 PM GMT
Thank you Mike, I managed to get it up and running.
Comment by External U.
14067 | October 24, 2013 01:33:26 PM GMT
Please fix this asap .
Vote by External U.
14147 | October 24, 2013 01:53:08 PM GMT
Don't understand how this wasn't anticipated by Adobe?
Vote by External U.
14148 | October 24, 2013 04:27:15 PM GMT
Same Here, Upgraded my OS to 10.9, now I am unable to continue developing CF10 on my machine. Please Fix SOON!
Vote by External U.
14149 | October 24, 2013 05:02:02 PM GMT
Wow. The current version of CF on the current version of Mac and Windows seems obvious. Please fix it soon!
Vote by External U.
14150 | October 25, 2013 12:45:13 AM GMT
weird, Mike's file isn't working for me. It's just not processing
Comment by External U.
14068 | October 25, 2013 01:27:29 AM GMT
Please provide fix through updater.
Vote by External U.
14151 | October 25, 2013 08:48:51 AM GMT
Mike's file is working for me as well.
Comment by External U.
14069 | October 25, 2013 09:31:50 AM GMT
If this bug was fixed for CF11 that is *unacceptable* to us developers who have spent time and money on CF10!!! CF11 is not even out yet (anyone knows *when* it will be out btw?), and we cannot stop our production process moving to OS X Mavericks simply because Adobe did not bother to test CF10 with it. I'm *very* disappointed at the way Adobe is handing this issue, and I'm also having second thoughts about the long-term prospects of CF with this attitude Adobe has in relation to us developers.
Vote by External U.
14152 | October 25, 2013 09:48:17 PM GMT
I update to mavericks and now I cant develop in coldfusion please guys fix this asap
Vote by External U.
14153 | October 25, 2013 10:05:42 PM GMT
I can confirm that I followed Mike's directions, recompiled from the connector source after changing the exact same lines with his fix and it's working on my machine now.
Comment by External U.
14070 | October 25, 2013 11:40:37 PM GMT
This makes it hard to upgrade to Mavericks and use CF at the same time.
Vote by External U.
14154 | October 26, 2013 09:39:02 AM GMT
Its time for Adobe to actually get ahead of the game and update software for new OS's and web servers.
Vote by External U.
14155 | October 26, 2013 10:27:23 AM GMT
As others have stated, Mac OS X is my primary dev platform (and many other developers that I know), need this fixed.
Vote by External U.
14156 | October 26, 2013 08:14:31 PM GMT
My main development platform is MacOS. This severely interrupts my development cycle and posses a huge problem for me in producing for my clients. I chose ColdFusion because I believed it offered better solutions when compared to other development languages such as ASP or PHP. But I think I may have to seriously consider PHP as my development language of choice as I cannot afford this type of down-time. This absolutely cripples the small-business/freelance developer/designer such as myself.
Vote by External U.
14157 | October 27, 2013 09:28:26 AM GMT
Adobe please make an update ASAP.
Vote by External U.
14158 | October 27, 2013 10:50:47 AM GMT
Has Adobe even acknowledged this problem yet? It's been 4 days, now. Does anyone else find that concerning?
Comment by External U.
14071 | October 27, 2013 01:35:08 PM GMT
@Mike McConnell, the status of the bug got changed to "ToFix", and the reason "BugVerified" - I think that is promising. but I wish Adobe would chime in here and say whats going on.
Comment by External U.
14072 | October 27, 2013 01:40:17 PM GMT
Ahhh...Thank you. I didn't notice that before. MLM
Comment by External U.
14073 | October 27, 2013 01:49:32 PM GMT
I am running OSX Mavericks. Im trying to install CF10 on XAMPP XAMPP fails after installing CF I have fixed the JAVA_home path and java.home path, etc etc etc. tried the so file listed in this article no joy. I must say adobe... its things like this that make me want to just stop using CF. I need a fix for this please respond.
Vote by External U.
14159 | October 27, 2013 11:37:54 PM GMT
I too had trouble with the file Mike posted, but I figured out how to fix and compile, thanks to Mike Nicholls. I wrote out some instructions if it helps anyone else:
Comment by External U.
14074 | October 29, 2013 09:25:01 PM GMT
The Apache Tomcat bug report is here:
Comment by External U.
14075 | October 30, 2013 09:54:28 PM GMT
Either needs fixed or I need to come up with an alternate library to mod_jk
Vote by External U.
14160 | October 31, 2013 10:50:08 AM GMT
It's impossible to develop for Coldfusion on the latest version of Mac OS.
Vote by External U.
14161 | November 09, 2013 11:11:46 AM GMT
This is a problem because I've updated to Mavericks and cannot reconnect ColdFusion 10. Will try the workarounds but this should be direct, at least through straight-forward commands in the Terminal.
Vote by External U.
14162 | November 09, 2013 04:54:47 PM GMT
As a CF Developer on a Mac I'm stalled until this is fixed.
Vote by External U.
14163 | November 16, 2013 11:36:21 AM GMT
Umm how does it impact productivity? It doesn't work -- does that make sense?
Vote by External U.
14164 | November 25, 2013 04:06:00 PM GMT
Mike's works for us. Thank you Mike!!
Comment by External U.
14076 | November 25, 2013 04:12:44 PM GMT
logged another bug #CF-3679774 for Apache restart issue. closing this.
Comment by Piyush K.
14077 | December 05, 2013 02:19:02 AM GMT
How is this one "Fixed"? Was there a patch released that included this fix?
Comment by External U.
14078 | December 05, 2013 01:03:11 PM GMT
If this is fixed, where is the fix? The installer still does not work on OSX 10.9 Mavericks. Please keep this ticket open until so.
Comment by External U.
14079 | December 05, 2013 05:27:37 PM GMT
I looked for #CF-3679774 but couldn't find it . . . has anyone been able to find this bug report?
Comment by External U.
14080 | December 05, 2013 05:40:34 PM GMT
TO ADOBE: It has been nice using CF all these years, but your lack of appropriate response on this issue is unfortunately the last straw for me. I have been a loyal CFer for about 12 years. Not any longer. From this point forward I will not build any new sites in CF. I will maintain the ones that have to be maintained and eventually migrate them all to another platform other than CF. Unfortunately, I don't think you [Adobe] care. But you will, because there are a lot of CFers making the same decision and your loyal customers are dwindling.
Comment by External U.
14081 | December 05, 2013 08:15:09 PM GMT
@xiinteractiv: You can add me to that list as well. I've already started porting applications over to Railo. It's faster and I have yet to run in to compatibility issues (not to mention it's free). For me, Adobe started losing it's luster about the time they abandoned the Flex/Flash platform. Looks like they're heading that way with ColdFusion as well. It was a good ride, but time to move on. M. McConnell
Comment by External U.
14082 | December 06, 2013 07:50:21 AM GMT
This bug has been fixed for the upcoming version of CF.
Comment by Piyush K.
14083 | December 09, 2013 08:11:05 AM GMT
Let me see if I understand this - the upcoming version as in, CF11?
Comment by External U.
14084 | December 09, 2013 10:07:07 AM GMT
Isn't the issue here that it's not supported in *ColdFusion 10*? Fixing it in CF11 ain't much help to anyone. -- Adam
Comment by External U.
14085 | December 09, 2013 10:27:18 AM GMT
saying you fixed it in CF11 is the WRONG ANSWER - it doesn't help anyone today. So I guess you expect all the CF developers on Mac to just stop working on everything CF until you release CF11??? If the CF11 release date is sometime in the next few days then you might make us happy. What you are saying is you really don't grasp the problem and furthermore... you just plain don't care. Maybe we should stop talking about the CF10 fix in this thread and use it to discuss CF alternatives that will work on the Mac platform. Earth to Piyush Kumar Nayak - did you fall off the planet or something? You need to ESCALATE this issue and get us a reasonable ETA for the fix. The longer you delay the worse the problem gets.
Comment by External U.
14086 | December 09, 2013 11:16:03 AM GMT
If this bug was fixed for CF11 that is *unacceptable* to us developers who have spent time and money on CF10!!! CF11 is not even out yet (anyone knows *when* it will be out btw?), and we cannot stop our production process moving to OS X Mavericks simply because Adobe did not bother to test CF10 with it. I'm *very* disappointed at the way Adobe is handling this issue, and I'm also having second thoughts about the long-term prospects of CF with this attitude Adobe has in relation to us developers. Does anyone know of a way to get to top managers at Adobe so they can check this issue out. I think the top-level managers must be unaware of the severity of this problem and the urgency to fix it correctly. They're literally single-handily stopping thousands of OS X developers from upgrading to OS X Mavericks with this tactic!!!
Comment by External U.
14087 | December 09, 2013 11:23:07 AM GMT
Just on the basis that this has 46 votes and 42 comments, if I was Adobe, I'd just suck it up and get the fix out for CF10 as an exercise in PR. This is all dragging out a bit too much, innit? -- Adam
Comment by External U.
14088 | December 09, 2013 11:40:30 AM GMT
Dear Adobe, is this some sort of sick joke? This answer is laughable to say the least. It should be in a hotfix and not in the 'next version' Thanks for making me very easy to advise my customers about dealing with ACF ever again after been onboard since 1998. Good bye and thanks for all the fish.
Comment by External U.
14089 | December 09, 2013 12:43:31 PM GMT
@jcelias - its not just stopping developers from upgrading... if you haven't upgraded you can still work. Many of us have already upgraded to OSX Mavericks and for CF development we are dead in the water... with no help on the way. Simply put, we cannot develop in CF at all on our OSX Mavericks macs.
Comment by External U.
14090 | December 09, 2013 12:43:47 PM GMT
So yet again Adobe has decided to just not support a widely used platform. Again the issue here isn't OS X! The issue is Adobe failing to support newer versions of APACHE Web server. Apache is one of the most widely used web servers out there. Adobe has failed! Again! Saying you will add support in the next version of ColdFusion isn't a valid solution. This will affect more than just OS X users. It will affect anyone trying to use the newer versions of Apache. See this bug for more proof that Adobe is essentially ignoring Apache.
Comment by External U.
14091 | December 09, 2013 12:50:44 PM GMT
A workaround for some (and yes, I admit it is a royal pain in the rear): If you use Parallels Desktop, you could install the Developer version of CF10 on Windows inside your Mac, and develop on Windows until Adobe gives us a proper fix for CF10 users on OS X, or until CF11 makes its grand appearance on OS X...
Comment by External U.
14092 | December 09, 2013 07:23:51 PM GMT
Sorry for the confusion folks. This has been fixed in both CF 10 & CF 11 and the fix is scheduled to come in CF 10 update 13. Piyush missed including the second part :-)
Comment by Rupesh K.
14093 | December 09, 2013 10:46:12 PM GMT
@Rupesh, that's nice that the fix will be in a ColdFusion update, but the problem is in the ColdFusion installer DMG for Mac. How can a Mac user, who has to reinstall ColdFusion due to an upgrade to Mavericks even get a working version of ColdFusion going in the first place? Will there be an updated ColdFusion Developer/Server installer for Mac released soon, and if so when?
Comment by External U.
14094 | December 09, 2013 10:55:27 PM GMT
@CFDad - I guess you can always still install it and run it with the internal web server to get it patched up, and then do the web server connector. Not ideal, but it doesn't totally "brick" the install to not have this in the downloadable installer.
Comment by External U.
14095 | December 09, 2013 11:08:14 PM GMT
more shoddy nonsense from the CF team
Vote by External U.
14165 | December 11, 2013 08:32:44 AM GMT
This issue is marked as fixed, but can anyone show me how to find or apply this fix? My dev machine is now out of action. I hadn't noticed as I'd been working on non-CF bits with no problem. I actually use the Apple Server App, but underneath that is simply a wrapper to Apache. Should still work and should have been tested and patched well in advance. Really want to dump CF and go with another language, but as a working professional that's not something you can do overnight. Clients can't wait for me to learn something new before I can build their sites!
Comment by External U.
14096 | December 11, 2013 10:56:12 AM GMT
@Rupesh or @Piyush - can you give us a date when ColdFusion 10 Update 13 will be available? My computer is getting refreshed this week at work so I'm getting a new MacBook Pro running Mavericks. I'm trying to figure out what I need to do for ColdFusion. If this update is available soon, that would be great timing. So, can you give us a date? Thanks.
Comment by External U.
14097 | December 23, 2013 08:41:11 AM GMT
So what's the drill? How do we upgrade to Mavericks and where can we find the patch? Do we apply the patch and then upgrade to Mavericks and all will work well? or is there some command-line work we need to do to get this going? This is getting *ridiculous*. No one can upgrade their machines to OS X Mavericks simply because of this issue. I'm already looking at alternatives to Adobe's Coldfusion, this is unacceptable behavior from Adobe's part. Check this out:
Comment by External U.
14098 | December 30, 2013 03:01:34 AM GMT
I'm a longtime CF developer, and to not be able to use CF on my Mavericks laptop is incredibly frustrating.
Vote by External U.
14166 | January 07, 2014 06:32:19 PM GMT
The fix for this bug has been incorporated and released as Update 13 for CF10. You should get an auto notification in the CF admin console to download and install it. For further details you may refer the following article:
Comment by Piyush K.
14099 | January 10, 2014 08:51:10 AM GMT
I think it is obvious why this bug impacts productivity. Unless I work on one web site project at a time... sure that sounds like a wonderful working business model that I can pitch to my clients.
Vote by External U.
14167 | January 15, 2014 05:36:16 AM GMT
Has this update made its way into the DMG installer for CF10 that is available from the Adobe website? I have come across this issue while attempting to install CF10 on my MacbookPro running 10.9.1 using the .dmg I downloaded from the Adobe website this evening. The crash logs I viewed from the Console app referred to the '' plugin as the problem. So although "Update 13" has been released, I'm unable to successfully install CF10 using the available installer from Adobe.
Comment by External U.
14100 | February 09, 2014 08:31:05 PM GMT
The fix is included in Update 13 only. This is not incorporated within the DMG installer at Adobe's site. After installing CF10 from the DMG installer, please apply CF10 Update 13, to make it work with OS X Mavericks.
Comment by Anit K.
14101 | February 09, 2014 08:39:47 PM GMT
Hello Anit, that course of action will not work. Reason is because once CF10 is installed, I'm unable to access the ColdFusion Administrator Panel to finish the installation and setup in order to patch the update. The errors in my console after installing via the DMG state that this plugin is the reason for failures. The settings I chose during my installation was to make use of my Apache configuration instead of using the builtin server and I also disabled the option to auto start CF at boot. I don't know if that helps you or not, but your recommended course of action is not sufficient for my problem. If you need more information, please let me know.
Comment by External U.
14102 | February 10, 2014 11:26:26 AM GMT
@anilnatha just use the built in web server and connect to apache AFTER you install the updater
Comment by External U.
14103 | February 10, 2014 01:07:28 PM GMT
Trying both Download and Download & Install results in: Error occurred while installing the update: Failed Signature verification I am on OS X Mavericks.
Comment by External U.
14104 | February 10, 2014 01:43:25 PM GMT
@seancoyne, thank you for that tip. I didn't know you could change the the CF server to make use of the Apache configuration after CF server was installed. I'll give that a try. Thanks!
Comment by External U.
14105 | February 10, 2014 01:44:39 PM GMT
@anilnatha: Open the server.xml at \ColdFusion10\cfusion\runtime\conf\ and search for (internal webserver start). Uncomment the connector section and restart CF service. You can then access the CF admin by http://ip:port/CFIDE/administrator/index.cfm where port no is the mentioned inside the connector section in server.xml. By default it is 8500.
Comment by Anit K.
14106 | February 10, 2014 01:51:04 PM GMT
@lolajl There is a mandatory update that has to be installed before you can use the built in update system
Comment by External U.
14107 | February 10, 2014 01:56:40 PM GMT
I was getting the same error that lolajl was encountering, but worked around it by going to this URL, and downloading the jar file and installing the update via terminal.
Comment by External U.
14108 | February 10, 2014 02:06:47 PM GMT
@lolajl You need to install the mandatory update before you update the server. Here is the link with the instructions. If you still facing any challenge, please send at email to cfinstal<AT>adobe<DOT>com
Comment by Anit K.
14109 | February 10, 2014 06:32:12 PM GMT
Sorry for the repeated posting . . . whenever this page got reloaded it kept sending out the cached text.
Comment by External U.
14110 | February 10, 2014 06:48:17 PM GMT
So I took the risk for everyone, and did the following: 1. Installed Update 13 for Coldfusion from the Coldfusion administrator. 2. Installed Mavericks (from the App Store update). 3. Now when I call my coldfusion websites they are not recognized. It is as if Apache had forgotten how to pass .cfm requests to Coldfusion... So now I'm left with a workstation I cannot develop on... Great. Thanks Adobe... Question to others: Any ideas of what the setting should be in httpd.conf to get this working again on Mavericks? I'm about to use TimeMachine to see what happens if I restore to a previous httpd.conf file... p..s: This is *frustrating*, and I'm *extremely* disappointed at Adobe because of the way it is handling this issue... p.p.s.: Adobe, how about you write a simple step-by-step guide on how to upgrade an existing coldfusion installation to OS X 10.9???
Comment by External U.
14111 | February 11, 2014 10:39:26 AM GMT
jcelias If you have not used apache since you upgraded to Mavericks, then the first thing you need to do is go find your old httpd.conf file. Upgrading OS X replaces your httpd.conf with a new one. You old one is saved in /etc/apache2/ as httpd.conf.pre-update. This is well known and expected behavior when upgrading OS X because Apache gets upgraded too.
Comment by External U.
14112 | February 11, 2014 10:49:18 AM GMT
Wilgeno, If I replace httpd.conf with the old one, apache does not start. I figured it had to do with this line: Include "/private/etc/apache2/mod_jk.conf" Which commented... #Include "/private/etc/apache2/mod_jk.conf" And that allowed Apache to reload and work again, BUT coldfusion still does not work. Also, if I try to manually launch Coldfusion from the Coldfusion launcher I get an error saying that it cannot launch coldfusion, and to please check the logs. I check the logs and I get this error: ------ LOGS START ------- Error when opening jrun.xml: /Applications/JRun4/servers/cfusion/SERVER-INF/jrun.xml. Make sure file has the proper permissions ( read/write ). java.lang.NullPointerException at<init>( at jrunx.launcher.GUIView$9.actionPerformed( at javax.swing.AbstractButton.fireActionPerformed( at javax.swing.AbstractButton$Handler.actionPerformed( at javax.swing.DefaultButtonModel.fireActionPerformed( at javax.swing.DefaultButtonModel.setPressed( at javax.swing.plaf.basic.BasicButtonListener.mouseReleased( at java.awt.Component.processMouseEvent( at javax.swing.JComponent.processMouseEvent( at java.awt.Component.processEvent( at java.awt.Container.processEvent( at java.awt.Component.dispatchEventImpl( at java.awt.Container.dispatchEventImpl( at java.awt.Component.dispatchEvent( at java.awt.LightweightDispatcher.retargetMouseEvent( at java.awt.LightweightDispatcher.processMouseEvent( at java.awt.LightweightDispatcher.dispatchEvent( at java.awt.Container.dispatchEventImpl( at java.awt.Window.dispatchEventImpl( at java.awt.Component.dispatchEvent( at java.awt.EventQueue.dispatchEventImpl( at java.awt.EventQueue.access$400( at java.awt.EventQueue$ at java.awt.EventQueue$ at Method) at$1.doIntersectionPrivilege( at$1.doIntersectionPrivilege( at java.awt.EventQueue$ at java.awt.EventQueue$ at Method) at$1.doIntersectionPrivilege( at java.awt.EventQueue.dispatchEvent( at java.awt.EventDispatchThread.pumpOneEventForFilters( at java.awt.EventDispatchThread.pumpEventsForFilter( at java.awt.EventDispatchThread.pumpEventsForHierarchy( at java.awt.EventDispatchThread.pumpEvents( at java.awt.EventDispatchThread.pumpEvents( at -------- LOGS END ------- And based on that error, I try to find the path /Applications/JRun4/servers/cfusion/SERVER-INF/jrun.xml but it does not exist, since all I can find is that in the /Applications/JRun4/servers/cfusion/ directory is just one subdirectory called cfusion-ear/ So what now???
Comment by External U.
14113 | February 11, 2014 11:06:33 AM GMT
jcelias I would have hope that telling you this is a new version of apache that you would just copy the settings you needed from the old file to the new one. (facepalm) You did save a copy of the new httpd.conf file? right?
Comment by External U.
14114 | February 11, 2014 11:11:52 AM GMT
@jcelias you are mixing up CF 10 and CF 9. Anything "JRun" related is CF9, so it has no bearing on CF10. Perhaps you have your apache config mixing the two. In any case the bug report is not an appropriate forum for issues like this. Try the CF forums on the Adobe site or StackOverflow or ServerFault (probably the better option in this case). As Wil said, any OS X upgrade will overwrite your Apache configuration files. It is up to you to back them up and then either restore them or make the appropriate changes to get them functional again.
Comment by External U.
14115 | February 11, 2014 11:13:22 AM GMT
How the fuck do I UNwatch a bug in this thing? -- Adam
Comment by External U.
14116 | February 11, 2014 11:17:07 AM GMT
Wilgeno, Yes, I did make a backup, and yes, I did copy only the settings. Sean Coyne, I had no clue that the coldfusion launcher Adobe left installed when I upgraded from CF9 to CF10 a year ago was deprecated (Adobe's installer should have removed it when we upgrade to CF10). In any case, I had CF10 working perfectly on OS X 10.8, and after I applied the Update 13 patch I upgraded to OS X 10.9 and now things don't work. So my question is very simple: What changes should I make to my system to have CF10 working again on OS X 10.9 Mavericks??? So far I have apache running, but when I call a .cfm page all I get is the source code displayed (meaning, obviously, that apache is simply returning the file, and not sending it to the coldfusion preprocessor). So, how can I tell apache to use coldfusion again? Note that I had to comment out the line that said Include "/private/etc/apache2/mod_jk.conf" in httpd.conf to have apache running again.
Comment by External U.
14117 | February 11, 2014 11:18:48 AM GMT
Well, lets see... If you had to comment out that file to get Apache to start, where do you think you should look? Perhaps IN that file? Maybe? Again, this is not the appropriate forum for help. Did you re-run the apache connector after installing updater 13, as the instructions specify you need to? Again, don't answer this question here. This will be the last reply I make on the subject. You need to determine where in your config apache is having a problem and fix that problem. Try the apache config test, "sudo apachectl configtest" which will point out obvious syntax issues. My guess is that you didn't re-run the connector. Considering the bug is IN the connector, this is a pretty important step.
Comment by External U.
14118 | February 11, 2014 11:25:33 AM GMT
I managed to fix my problems by following this guide: I hope that can help at least some of you... In any case, I really do not understand why Adobe makes Coldfusion developers' lives so hard... Tip: After you manage to get Coldfusion working again, go to the coldfusion administrator, then Settings, and click on the "Clear Template Cache Now" button. If you don't do that, and like me, was trying some local coldfusion page to bring it up, that page will continue failing.
Comment by External U.
14119 | February 11, 2014 11:50:40 AM GMT