tracker issue : CF-3689365

select a category, or use search below
(searches all categories and all time range)

Installing Update 12 corrupts CF Administrator

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/CannotReproduce

Reporter/Name(from Bugbase): Douglas Boberg / Douglas Boberg (dougboberg)

Created: 01/06/2014

Components: Administrator

Versions: 10.0

Failure Type: Crash

Found In Build/Fixed In Build: Final /

Priority/Frequency: Major / Unknown

Locale/System: English / Win All

Vote Count: 2

Problem Description:
After installing Update 12 from the CF Administrator page and restarting the ColdFusion services the CF Administrator shows errors on multiple pages.  The "Scheduled Tasks" page throws a ColdFusion "Error Occurred While Processing Request" on scheduletasks.cfm: line 188.  See attached image cf10,283922-schedtask.jpg.  The "Settings Summary" page throws an error on _report.cfm: line 1748.  Finally, the "Save as PDF" option at the top right of the Settings Summary page also throws an error on _report.cfm: line 1748.

Steps to Reproduce:
Installed Update 12, restarted the ColdFusion services.  Open the ColdFusion administrator.

Actual Result:
The scheduled task management page does not display and settings summary pages do not display.  The 

Expected Result:
No errors.

Any Workarounds:

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3689365

External Customer Info:
External Company:  
External Customer Name: dougboberg
External Customer Email:  
External Test Config: My Hardware and Environment details:

Windows Server 2012 R2 Standard

Intel Xeon CPU E5-5220 v2 @ 2.20 GHz

2.86 GB RAM

64-bit Operating System, x64-based processor


  1. January 07, 2014 00:00:00: 1_cf10,283922-schedtask.jpg
  2. January 07, 2014 00:00:00: 2_cf10,283922-settingsummary.jpg
  3. January 07, 2014 00:00:00: 3_cf10,283922-summaryerror.jpg
  4. January 07, 2014 00:00:00: 4_cf10,283922-summarypdf.jpg
  5. February 26, 2014 00:00:00: 5_cf10schedulingError.JPG


I uninstalled the Update in attempt to recover. As you can see from the screenshots the corruption remains.
Comment by External U.
13738 | January 06, 2014 02:32:57 PM GMT
Hi, Can you please tell us which config did you face this issue on.Also the browser that you ran admin on. Thanks (Comment added from ex-user id:vnigam)
Comment by Adobe D.
13739 | February 13, 2014 04:15:36 AM GMT
We have the very same issue. I think it's not related to update 12, but rather to some sort of overflow (possibly) due to to many errors while running scheduled tasks.
Comment by External U.
13740 | February 25, 2014 04:21:07 PM GMT
Are scheduled tasks being stored in xml files and is it possible that those files somehow get corrupted and generate this error ? Also, no schedules are running, infact I noticed that no schedules were running and went to the cf admin to check on schedules and finally saw the error in the cf admin. Scary. What now? Had this issue many times before and the "simple" fix is to delete the infamous xml file containing the scheduled tasks (don't remember what file nor where to look for, so let's ask Google since Adobe doesn't seem to have time for this)
Comment by External U.
13741 | February 25, 2014 04:30:20 PM GMT
Vinay, I faced the issue on the Standard version's scheduled task and settings summary pages. I was using a Google Chrome browser. You can see it in the attached screenshots.
Comment by External U.
13742 | February 25, 2014 05:22:27 PM GMT
Hi Doug, Can you share "neo-cron.xml" file, If you are still facing this issue? -Nimit
Comment by Nimit S.
13743 | April 12, 2014 06:40:16 AM GMT
Hi Doug I have exactly the same problem. Did you ever find a solution? Cheers Graham
Comment by External U.
13744 | June 24, 2014 07:06:17 PM GMT
Having this same problem. Please advise.
Comment by External U.
13745 | August 23, 2014 08:28:10 AM GMT
I'm having this same problem. Please advise.
Vote by External U.
13750 | August 23, 2014 08:28:58 AM GMT
Can you please apply update 14 and see if you are still facing the issue? We tried it our end and we are not able to reproduce this issue. (Comment added from ex-user id:amkum)
Comment by Adobe D.
13746 | December 03, 2014 03:44:28 AM GMT
I have this same issue. My instance of CF 10 is up to date. My neo-cron.xml and neo-cron.bak files are empty. I had several scheduled tasks set up even three days ago. My workaround was to copy and paste in XML from another CF server instance. Save that into neo-cron.xml and restart ColdFusion. I will have to re-set up some scheduled tasks, but at least now the scheduled tasks page is loading. It seems that three days ago the neo-cron.xml file's contents were deleted. So when cfadmin or, in my case, a call to createobject("java","coldfusion.server.ServiceFactory").getCronService().listall() was called, the empty neo-cron.xml file was returning null and that is what was throwing the error.
Comment by External U.
13747 | December 08, 2014 11:01:02 AM GMT
Just ran into this on update 15 in CF10. Need at least a workaround if not a fix!!
Vote by External U.
13751 | February 27, 2015 11:49:26 AM GMT
Ran into this bug on update 15, appears to still be an issue.
Comment by External U.
13748 | February 27, 2015 11:50:08 AM GMT
We are closing this bug. In case you please happen to observe the same behavior after applying U16/17, let us know. We tried it our end and we are not able to reproduce this issue.
Comment by Mukesh K.
13749 | September 23, 2015 04:54:09 AM GMT