tracker issue : CF-3701046

select a category, or use search below
(searches all categories and all time range)

Task name with a colon in it (:) shows a " Task not found error " on editing the task.

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Daniel Garcia / Daniel Garcia (Daniel Garcia)

Created: 01/29/2014

Components: Scheduler

Versions: 10.0

Failure Type:

Found In Build/Fixed In Build: Final / CF10_Update14

Priority/Frequency: Major / Some users will encounter

Locale/System: English / Win All

Vote Count: 0

Problem Description:

Task name with a colon in it (:) shows a "An error occured scheduling the task." on editing the task.  When going back to the scheduled tasks list that item no longer exists.  Trying to add it again with the same name gives the same error.

Steps to Reproduce:

1.  Create task with a colon in the name.  For example:  Reports: Task 1
2.  Edit the new task from the tasks list and save.
3.  View error.
4.  Try creating a new task with that same name.
5.  View error on save.

Actual Result:

The same error appears in steps 3 and 5 above.

An error occured scheduling the task.
Unable to store Job : 'SERVERSCHEDULETASK#$%^DEFAULT.job_REPORTS: TASK 1', because one already exists with this identification.

Expected Result:

The task can be edited and still appear in the list.

Any Workarounds:

Don't use colons in the file names.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3701046

External Customer Info:
External Company:  
External Customer Name: Daniel J Garcia
External Customer Email:  
External Test Config: My Hardware and Environment details:



I am running this on Windows 2012. This has happened in multiple environments.
Comment by External U.
13560 | January 29, 2014 05:28:27 PM GMT
Bug Verified on CF10 Update 12 (Comment added from ex-user id:vnigam)
Comment by Adobe D.
13561 | January 29, 2014 10:10:23 PM GMT
I remember this kind of bug has already been raised and has been fixed also. Test in latest version
Comment by Uday O.
13562 | February 03, 2014 08:00:22 AM GMT
I did test in latest version. Please try testing it yourself to see if it works.
Comment by External U.
13563 | February 03, 2014 09:11:50 AM GMT
Does not occur in CF11 but can be reproduced in CF10HF13
Comment by Suchika S.
13564 | February 12, 2014 12:45:37 AM GMT
Same test case as bug no:CF-3600359
Comment by Suchika S.
13565 | September 17, 2014 06:47:50 AM GMT