tracker issue : CF-3713398

select a category, or use search below
(searches all categories and all time range)

Application.cfc does not respect server-wide mappings when extending other components

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Rob Bilson / Rob Bilson (Rob Bilson)

Created: 02/25/2014

Components: General Server

Versions: 11.0

Failure Type:

Found In Build/Fixed In Build: PublicBeta /

Priority/Frequency: Major / Most users will encounter

Locale/System: ALL / Win 64

Vote Count: 0

Problem Description: Application.cfc is not respecting server-wide mappings in the extends attribute of cfcomponent. This is a regression in Splendor.

Steps to Reproduce:

Create a directory outside the webroot called "foo" and create a mapping to it in the ColdFusion Administrator (to make it server-wide).  Now, create a component in that directory called parent.cfc with the following code:

<cfcomponent displayName="parent" output="true">
<cfset variables.parent = true>

Now, back in your webroot, create another component called Application.cfc with the following code:

<cfcomponent extends="foo.parent" output="true">
<cfset variables.myApp = true>

Now create a test.cfm file in your web root. You just need it so that Application.cfc runs:

Hello World!

Actual Result:

When you run test.cfm, you'll get the following error: 

Could not find the ColdFusion component or interface foo.parent.

Ensure that the name is correct and that the component or interface exists.
If you then change the name of Application.cfc to mapping.cfc and modify test.cfm with this:

<cfset y = createObject('component', 'mapping')>

<cfdump var="#y#">

You'll see that it's able to extend the object fine. This confirms that the issue is isolated to mappings within Application.cfc.

Expected Result:

Any Workarounds:

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3713398

External Customer Info:
External Company:  
External Customer Name: Rob Brooks-Bilson
External Customer Email:  
External Test Config: My Hardware and Environment details:



I just tried this in the released version of ColdFusion 11, and it is still not fixed. This is a critical issue preventing us from deploying CF 11 in production.
Comment by External U.
13173 | May 21, 2014 11:19:28 AM GMT
Ignore my previous note. The bug is indeed fixed in CF 11 final.
Comment by External U.
13174 | May 21, 2014 11:36:50 AM GMT