tracker issue : CF-3758172

select a category, or use search below
(searches all categories and all time range)

First Request Slow on IIS8 (Windows 8 and Server 2012)

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Giancarlo Gomez / Giancarlo Gomez (Giancarlo Gomez)

Created: 05/09/2014

Components: Installation/Config, Connector

Versions: 11.0

Failure Type: Performance Issue

Found In Build/Fixed In Build: CF11_Final /

Priority/Frequency: Critical / Unknown

Locale/System: English / Win 2012 Server x64

Vote Count: 7

Listed in the version Issues Fixed doc
Problem Description:
I have had the same results on my Windows 8 Development Machines as well as Windows Server 2012 (including R2). Basically after a restart or a long time of the machine being idle, the first request takes generally 14+ seconds to render. This applies to any 1st request, including just the Admin Login page. I did not experience this on my Mac using Apache. I have Fusion-Reactor installed on 1 of the machines and I can see the request that takes long but even their interface does not display any information in regards to what is making the request take so long. I have also looked at the CF logs and even tried running CFSTAT and could not see anything that could help me figure out what the issue is.

Steps to Reproduce:
Start ColdFusion Server and access the administrator (running thru IIS8)

Actual Result:
14+ seconds for first render

Expected Result:

Any Workarounds:

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3758172

External Customer Info:
External Company:  
External Customer Name: Giancarlo Gomez
External Customer Email:  
External Test Config: My Hardware and Environment details:


  1. August 30, 2014 00:00:00: 1_Screen_Shot_2014-08-29_at_3.36.46_PM.png
  2. August 30, 2014 00:00:00: 2_Screen_Shot_2014-08-29_at_3.36.53_PM.png


Ok will anyone contact me in regards to this issue? Some type of communication would be nice. Just for testing I decided to install Apache on my Windows 8 VM to make sure it was not an OS issue as CF11 on my Mac runs fine and when I configured the connectors for the Apache install, first request was normal and fast unlike with IIS.
Comment by External U.
12204 | May 13, 2014 01:53:16 PM GMT
@extuser, Can you share more details about your environment and setup. Please send an email to cf<DOT>install<AT>adobe<DOT>com
Comment by Anit K.
12205 | May 13, 2014 03:38:07 PM GMT
You can also replicate the issue by simply recycling the IIS 8 application Pool
Comment by External U.
12206 | May 13, 2014 07:28:12 PM GMT
Or making a change to the web.config which automatically recyles app pool in IIS
Comment by External U.
12207 | May 13, 2014 08:34:39 PM GMT
I emailed the specs as requested, still no form of reply .. can someone please advise what time we can expect to have an answer when entering a bug? You are creating an issue where my client wants to completely do away with ColdFusion.
Comment by External U.
12208 | May 14, 2014 09:08:18 AM GMT
I am also having this issue. not happy this is like this for the up to date stack.
Vote by External U.
12216 | May 22, 2014 01:52:19 PM GMT
adding support for this bug fix
Vote by External U.
12217 | May 22, 2014 01:55:33 PM GMT
We have fixed the Bug# CF-3758172 with ColdFusion11. Please send an email at cfinstal<AT>adobe<DOT>com, to test the fix.
Comment by Anit K.
12209 | May 26, 2014 03:45:07 PM GMT
Anit, could you update the status on this bug to "ToFix" or something to indicate we've moved beyond "Unverified"? Thx
Comment by External U.
12210 | May 27, 2014 12:12:29 PM GMT
Adding support as I'm getting ready to move from Windows Server 2008R2 to 2012R2.
Vote by External U.
12218 | May 27, 2014 12:13:00 PM GMT
Same issue here too. Win2012 R2 all critical patches as of 6/4/2014. In addition, if site is idle for few hours, 30+ second delay on initial request. Also, if I make any change in IIS manager, CF fails to process any additional requests. Check Task Manager and see additional threads piling up on w3wp process for that site. Kill worker process and site starts functioning again. Tried recycling the app pool and that sometimes works, more often than not, it doesn't. Have to use TM to kill the worker.
Vote by External U.
12219 | June 04, 2014 02:03:05 PM GMT
Exact same situation here. Also had issues with any changes to web.config (manually or through IIS GUI) would cause CF to become completely unresponsive. Switched to BonCode connector and having no problems.
Vote by External U.
12220 | August 11, 2014 04:35:16 PM GMT
Almost the same issue, my entire CF installation hangs after any change in the IIS config(through the GUI and the web.config(auto reload on)). After this I have to restart the application pool for the application, and restart CF.
Vote by External U.
12221 | August 25, 2014 07:01:33 AM GMT
I upgraded my live site and my local development and I am experiencing this delayed responsiveness when I just don't access that site for 10 minutes. I am on a Windows 7 with SQL 2012 Express. If this is the same bug, I vote for it to be fixed, it is very annoying, especially when showing to a client and it looks like the website is very slow (initially).
Vote by External U.
12222 | August 26, 2014 10:47:22 AM GMT
Anit, Thank you for your time today! The DLL delivered does fix the issue. I tested the very basic scenarios that would causea problem, which was create a virtual directory or make a web config change and the response was immediate. I will comment if there is any issue later in regards pool timeout but as of now I can say it works. Again, thank you for calling me to clarify the file delivery issue I had.
Comment by External U.
12211 | August 28, 2014 12:41:41 PM GMT
Anit, As per my email. Simple FORM posts fail with this new DLL. I get a 404. You can test with the following: <!DOCTYPE html> <html lang="en"> <head> <meta charset="UTF-8"> <title>Test</title> </head> <body> <cfscript> writeDump(form); </cfscript> <form action="./form.cfm" method="POST"> <input type="hidden" value="This is a good post" name="field"> <input type="submit" value="Submit"> </form> </body> </html>
Comment by External U.
12212 | August 29, 2014 02:09:03 PM GMT
Anit, I added the screenshots which I emailed as well.
Comment by External U.
12213 | August 29, 2014 02:09:55 PM GMT
Reverting to previous DLL for now.
Comment by External U.
12214 | August 29, 2014 02:10:13 PM GMT
Both the bugs, CF-3758172 and CF-3777189 are fixed. Please send an email to cfinstal<AT>adobe<DOT>com referring to bug# CF-3777189, to get the latest fix.
Comment by Anit K.
12215 | September 01, 2014 09:41:02 AM GMT