tracker issue : CF-3772481

select a category, or use search below
(searches all categories and all time range)

cfhtmltopdf does nothing

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/NotABug

Reporter/Name(from Bugbase): A. Bakia / A. Bakia (A. Bakia)

Created: 06/07/2014

Components: Document Management, PDF generation

Versions: 11.0

Failure Type: Non Functioning

Found In Build/Fixed In Build: CF11_Final /

Priority/Frequency: Critical / All users will encounter

Locale/System: English / Windows 7 SP1 64-bit

Vote Count: 0

Problem Description: When I run a CFM test page to demonstrate the tag cfhtmltopdf or the function cfhtmltopdf, nothing happens. 

Steps to Reproduce: Create the pages test.cfm and html2pdfTest.cfm. The page test.cfm contains the code


The page html2pdfTest.cfm contains the following code:

This is a test: <cfoutput>#now()#</cfoutput>

     cfhtmltopdf(source="test.cfm", destination="example.pdf", overwrite="true");

First run the tag code. Then comment it out and run the cfscript code.

Actual Result: Neither the cfhtmltopdf tag nor the cfhtmltopdf() function has any effect. The browser's request for the page receives no response until the session eventually times out. The logs register nothing, except the session timeout.

Expected Result: The tag code should have generated a PDF page, and the cfscript version of the code should have generated a PDF file. Failing that, ColdFusion should have registered an error message in the logs, giving the reason for failure.

Any Workarounds: None that I am aware of.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3772481

External Customer Info:
External Company:  
External Customer Name: BKBK
External Customer Email:  
External Test Config: My Hardware and Environment details:



Did you verify that the ColdFusion 11 Add-on service is installed and running? Norton AV had issues the first time I tried to install. I have it working on Windows 8.1, Windows Server 2008r2 and 2012.
Comment by External U.
11990 | June 08, 2014 10:07:27 AM GMT
The ColdFusion 11 Add-on service was, and is still, running. I will take your tip and disable my antivirus software.
Comment by External U.
11991 | June 13, 2014 09:12:26 AM GMT
I turned off my antivirus program, and restarted the ColdFusion 11 Add-on service, and turned the antivirus back on. The cfhtmltopdf tag and cfhtmltopdf() function worked as expected.
Comment by External U.
11992 | June 13, 2014 02:24:25 PM GMT