tracker issue : CF-3840648

select a category, or use search below
(searches all categories and all time range)

Coldfusion 11 Update 2 impossible due to error in Coldfusion Administrator

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/CannotReproduce

Reporter/Name(from Bugbase): A. Bakia / A. Bakia (A. Bakia)

Created: 10/17/2014

Components: Administrator, HotFix Notification

Versions: 11.0

Failure Type: Non Functioning

Found In Build/Fixed In Build: CF11_Final /

Priority/Frequency: Critical / All users will encounter

Locale/System: English / Windows 7 64-bit

Vote Count: 2

Problem Description: When you attempt to update ColdFusion 11.0.1 to Coldfusion 11 Update 2 using the update facility in the ColdFusion Administrator, you get an error, which halts the update process. 

Steps to Reproduce: (This assumes you had already installed Coldfusion 11 Update 1.) Open the ColdFusion Administrator in a browser (I tested with Chrome and Internet Explorer). Go to the Updates page. Click on the button "Download and Install". 

Actual Result: You will get a prompt saying that an error has occurred. The message is "Error retrieving markup for element hf-0002-body: Element UPDATES is undefined in SESSION. [Enable debugging by adding 'cfdebug' in your URL parameters to see more information]"

Expected Result: Coldfusion 11 Update 2 should install without error.

Any Workarounds:

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3840648

External Customer Info:
External Company:  
External Customer Name: BKBK
External Customer Email:  
External Test Config: My Hardware and Environment details:



I am not able to repro the issue. I tried the following steps (with both chrome and IE) : Install ColdFusion 11 Go to Admin page -> Updates -> Download and install Update 1 Sever comes up fine Admin page -> Updates -> Download and install Update 2 Installation was done successful without any error. Can you please provide some more details using which I can repro this issue? (Comment added from ex-user id:amkum)
Comment by Adobe D.
10582 | October 22, 2014 02:56:05 AM GMT
Have you applied any of the steps in the lockdown guide (link given below) before getting update 2 ? (Comment added from ex-user id:amkum)
Comment by Adobe D.
10583 | October 22, 2014 03:27:21 AM GMT
Amit Kumar, Thank you, for looking into the issue. Because of it, I have since re-installed Coldfusion 11, applying update 2 directly. Nevertheless, you might be interested in the following error message, which I retrieved from the log files of the previous installation: "Error [http-bio-8500-exec-9] - Element UPDATES is undefined in SESSION. The specific sequence of files included or processed is: C:\ColdFusion11\cfusion\wwwroot\CFIDE\administrator\updates\installer_input.cfm, line: 31".
Comment by External U.
10584 | October 22, 2014 03:40:53 AM GMT
From the bug report it seems that you were able to observe the issue repeatedly and consistently. I am unable to observe the issue with a standalone installation of CF on windows 7 x64 running on default CF JRE. The error msg implies that the session is intact but the udpates element in the session struct is somehow not defined, but it does not provide any clues on the events that lead to that state. But the steps you've mentioned in the bug report are pretty staright forward, unless we are missing something there. Is your CF installed with the secure profile? Have you applied any steps to lock down your CF installation? Which web server are you using, if any? Are you using the default CF JRE? Do you have any sandbox security enabled? (Comment added from ex-user id:amkum)
Comment by Adobe D.
10585 | October 22, 2014 09:20:26 AM GMT
Is your CF installed with the secure profile? No. Have you applied any steps to lock down your CF installation? No. Which web server are you using, if any? ColdFusion's built-in web server. Are you using the default CF JRE? Yes. Do you have any sandbox security enabled? No.
Comment by External U.
10586 | October 22, 2014 09:40:33 AM GMT
Please explain in 25 characters or more how this bug impacts productivity and why you are adding a vote.
Vote by External U.
10592 | October 29, 2014 03:51:57 PM GMT
I am getting the exact same error. I have CF11 installed with no updates applied so far. I am also using the-built in web server and have not applied any lockdown steps or enabled secure mode.
Comment by External U.
10587 | October 29, 2014 03:52:46 PM GMT
Update, clearing my cookies fixed the issue. Note I also access a Railo administrator on this same domain so I had Railo cookies also set. Here are the cookies I had before the issue. Note there is an upper and lower case version of the CFID and CFTOKEN cookies: RAILO_ADMIN_LANG=en; RAILO_ADMIN_PW_SERVER=e573f7a2cd...snip...; cfid=9a550220-8652-4c31-81e2-15386ef8c902; cftoken=0; RAILO_ADMIN_LASTPAGE=server.compiler; JSESSIONID=1FF563DBAA97388839A49660DD4AE7C7.cfusion; CFAUTHORIZATION_cfadmin="YWRtaW4NY2ZhZG1pbg0x...snip..."; CFADMIN_LASTPAGE_ADMIN=%2FCFIDE%2Fadministrator%2Fupdates%2Findex%2Ecfm; CFID=1723; CFTOKEN=566b96d1903186c1-A9F1A78B-5056-C000-01B1CDFD60ECD20F
Comment by External U.
10588 | October 29, 2014 04:00:00 PM GMT
Did you just clear the cookies or cleared the browser cache also? Perhaps it was picking old javascript files which has the code of showing the updater page
Comment by Uday O.
10589 | November 24, 2014 05:09:19 AM GMT
we are closing this issue as we are not able to reproduce this issue . If anyone faces this issue even after clearing the browser cookies and cache. please revert. (Comment added from ex-user id:amkum)
Comment by Adobe D.
10590 | December 03, 2014 03:34:12 AM GMT
I was able to reproduce this issue after installing the ColdFusion 11 Linux AWS AMI via the Chrome Browser. I tried it in Edge and it worked. Likely a Cookie issue. Needs to be resolved on the AMI.
Comment by External U.
10591 | June 22, 2016 12:52:12 PM GMT
Please see my note for details.
Vote by External U.
10593 | June 22, 2016 12:52:27 PM GMT