tracker issue : CF-3843498

select a category, or use search below
(searches all categories and all time range)

CFC Invoke Broken for Half an Hour or Code Change

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/CannotReproduce

Reporter/Name(from Bugbase): Aaron Taylor / Aaron Taylor (Aaron Taylor)

Created: 10/27/2014

Components: Web Socket

Versions: 11.0

Failure Type: Non Functioning

Found In Build/Fixed In Build: CF11_Final /

Priority/Frequency: Critical / All users will encounter

Locale/System: English / Win 2012 Server x64

Vote Count: 0

Problem Description: At the beginning of the day, every day; I will open my application only to get a 4001 error for my initial data invoke. All other functions work perfectly fine, even when run from the same CFC. About a half an hour to an hour will pass and magically the WebSocket likes the CFC and the 4001 error is gone. Or, I will have to make a code change to the client side file or CFC, and within a few minutes The 4001 error is gone.

Steps to Reproduce: Unsure of what would reproduce this error. I have developed other WebSockets applications without this issue existing. I am dealing with quite a bit of data, we're talking 2000 rows by 40 columns, nothing even approaching enterprise levels. 

Actual Result: 4001 error.

Expected Result: JSON Data

Any Workarounds: Making a code change to the client side file, or CFC seems to make it work shortly after.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3843498

External Customer Info:
External Company:  
External Customer Name: AaronG33K
External Customer Email:  
External Test Config: My Hardware and Environment details:



Please provide below mentioned details: 1. Settings summary : CF Admin > Settings > Settings Summary 2. Are you using Built-In WebSocket server or WebSocket proxy server? 3. Have you started facing this issue recently? If yes, Is there any configuration changes which you made to ColdFusion? Regards, Nimit
Comment by Nimit S.
10454 | November 09, 2014 11:00:05 PM GMT
Yes, this is a recent bug. I am using the built in web sockets. I have worked around the issue for now. It seems like WebSockets can only handle light weight data. The moment I try and use the Web Socket to grab the applications Initial Data, I get a disaster. Yes the data throughput can be adjusted in the CF Administrator however the result is still poor performance. Removing the initial data load from the web sockets seemed to work, but definitely would like heavier lifting capabilities out of it in future updates or versions of CF.
Comment by External U.
10455 | November 10, 2014 08:19:32 AM GMT
I don't believe it has anything to do with my settings. I have had a Vivio Tech (a coldfusion parter of adobe) look over the server up and down twice for settings issues. Also, I have been using ColdFusion for almost 10 years and don't see myself messing up settings.
Comment by External U.
10456 | November 10, 2014 08:22:33 AM GMT
Hi Aaron, can you help us wth repro-able test scenario? It is really tough to create a valid testcase out here and without that its very hard to fix it.
Comment by Awdhesh K.
10457 | November 26, 2014 12:38:32 AM GMT
Hi Aaron, Can you please help us with reproducing this issue?
Comment by Nimit S.
10458 | December 03, 2014 04:19:04 AM GMT
Hi Aaron, Are you still observing this issue? Regards, Nimit
Comment by Nimit S.
10459 | May 07, 2015 01:31:11 AM GMT
Yes, these issues are still persistent, It seems to have come down to how much data you can send across the websocket effectively. In my scenario I was attempting to do initial data loads of a large data set over the websocket which was undoubtedly causing performance issues with the websocket. I have since fallen back to a standard Ajax call to grab my initial data then use the websocket to carry changes to that dataset client side. Perhaps your websockets aren't designed to do that sort of heavy lifting?
Comment by External U.
10460 | May 07, 2015 06:40:07 AM GMT
Hi Aaron, I have tried it with almost 30000 records but I didn't see any issue. It only gives this exception, if the max data size defined in ColdFusion administrator is smaller than the amount of data which is being sent/received. To change this value navigate to: ColdFusion Administrator > Server Settings > WebSocket > Max Data Size.
Comment by Nimit S.
10461 | August 24, 2015 09:09:57 AM GMT
Hi Aaron, Please provide me an update on this issue. Have you tried increasing max data size?
Comment by Nimit S.
10462 | September 13, 2015 12:27:43 PM GMT