tracker issue : CF-3845476

select a category, or use search below
(searches all categories and all time range)

Unhandled error in CFAdmin

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Adam Cameron / Adam Cameron (Adam Cameron)

Created: 10/30/2014

Components: Administrator

Versions: 11.0

Failure Type:

Found In Build/Fixed In Build: CF11_Final / CF11 Update5

Priority/Frequency: Major / Some users will encounter

Locale/System: English / Platforms All

Vote Count: 1

Listed in the version Issues Fixed doc
Full repro here:

I went into CFAdmin, into the Security section, and user manager.
I added a user apiuser, and when trying to set it for "Allow Administrative Access", I got a pop-up thus:

Sigh, yeah, fair enough. So I dismissed that, also selected "API Access Only", then saved the user and moved back to the Administrator screen as suggested.

On this screen I selected "Separate user name [etc]..." and submitted the changes. And was confronted with this:

Dammit. Not being one to give up immediately, I just changed the radio button again and resubmitted:

It's getting worse! I tried another time and the message was the same.

So I sighed and wondered if it was getting confused because I had already created another user, or something, so went back to the "User Manager", and got this:

And no amount of reattempts to load that page worked. But that, to me, is a bug. Indeed it's twofold: a) simply using the UI should not... well.. break it; b) have you heard of error trapping, Adobe? Blimey. you shouldn't just let errors throw up on the screen: catch 'em and present something less amateur-looking than just a raw error message.

There are screencaps in the article which will help that make more sense.


----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3845476

External Customer Info:
External Company:  
External Customer Name: Adam Cameron.
External Customer Email:  
External Test Config: My Hardware and Environment details:



It precludes local development, which I usually do. It sounds similar to a bug I've encountered which has cut my productivity in half.
Vote by External U.
10379 | December 09, 2014 01:16:12 PM GMT
The fix for this bug is available in the pre-release build of ColdFusion 11 Update 5
Comment by CFwatson U.
10377 | February 20, 2015 09:20:13 AM GMT
Confirmed fixed, cheers.
Comment by External U.
10378 | February 21, 2015 08:03:18 PM GMT