tracker issue : CF-3853343

select a category, or use search below
(searches all categories and all time range)

WAR / EAR deployment - unable to initialise Security service: java.lang.NullPointerException

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Andrew Myers / Andrew Myers (Andrew Myers)

Created: 11/18/2014

Components: Installation/Config

Versions: 11.0

Failure Type: Non Functioning

Found In Build/Fixed In Build: CF11_Final /

Priority/Frequency: Normal / Very few users will encounter

Locale/System: English / Windows 8.1

Vote Count: 1

Listed in the version 2016.0.0.297996 Issues Fixed doc
Problem Description:

WAR or EAR files created via the installing when the "30 day trial" option is selected fail to start, due to the error:

"Unable to initialise Security service: java.lang.NullPointerException"

Steps to Reproduce:

Run the ColdFusion installer.  Select "30-day trial". Select JEE configuration.  Select WAR file.  Select Production Profile.   Deselect all subcomponents.  Deselect all servlets.  Deploy resulting war file to tomcat.

Actual Result:

Server reports the error "Unable to initialise Security service: java.lang.NullPointerException"

Expected Result:

Server starts correctly.

Any Workarounds:

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3853343

External Customer Info:
External Company:  
External Customer Name: am2605
External Customer Email:  
External Test Config: My Hardware and Environment details:

Windows 8.1 64bit

Apache Tomcat 7.0.57 

Oracle JDK 1.7.0_60 (64bit)

Also tested on RHEL 6.5, with Tomcat 7.0.57 and Oracle JDK 1.7.0_71.  Identical results were observed.



+1 / subscribe / .....................
Vote by External U.
10041 | November 18, 2014 04:50:12 AM GMT
This may be more widespread that I initially thought. I've just tried to install CF11 in *server* mode on Windows 7, and I am seeing the same issue when I select 30 day trial. Perhaps the 30 day trial feature, doesn't work? My requirement is to provision a CF11 server to do some testing with, as we wish to migrate from C9 before support expires on Dec 31. I don't want to run it in development mode, because we have numerous people internally doing testing. Can I do this (short of buying the licence up front - which I don't want to do)?
Comment by External U.
10036 | November 18, 2014 05:23:37 PM GMT
Same behaviour if "Developer Edition" is selected, Development Production Profile is selected and "Production Profile" is chosen. In fact, I'm not even sure why the Developer Edition gives you the option of selecting Production Profile?
Comment by External U.
10037 | November 18, 2014 05:46:00 PM GMT
Okay - I've found what is causing it. A password with a trailing backslash It fails in *every* mode. Here's the one I was using: WN%rD/exA&!6**ezb1`\ The reason it was initially working for me in development mode is that the installer allowed me to put in a simple password (which I did). In other cases I was using the above one which my password manager generated for me. I have also tried with a backslash not as a last character in a password. The server starts, but I can only log in if I omit the backslash when typing the password. So I suggest some weirdness is happening here with backslashes in passwords that the CF team need to look at.
Comment by External U.
10038 | November 18, 2014 06:54:05 PM GMT
Only the installer appears to be affected. Setting a password without a trailing backslash during install, then changing it to the one below from within the ColdFusion administrator does not cause this issue on next server startup.
Comment by External U.
10039 | November 18, 2014 07:05:39 PM GMT
This issue is fixed and the fix for this issue will be included as part of next release.
Comment by Nimit S.
10040 | December 21, 2014 04:24:40 AM GMT