tracker issue : CF-3856685

select a category, or use search below
(searches all categories and all time range)

CFPOP - Apple Mail - Attachments can't be seen

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/CannotReproduce

Reporter/Name(from Bugbase): Daniel Mackey / Daniel Mackey (Daniel Mackey)

Created: 11/24/2014

Components: Net Protocols, POP

Versions: 11.0

Failure Type: Non Functioning

Found In Build/Fixed In Build: CF11_Final /

Priority/Frequency: Critical / All users will encounter

Locale/System: English / Win 2008 Server

Vote Count: 1

Problem Description:

When you create an email from Apple Mail (or iPad Mail, iPhone Mail) and the attachment is inline then CFPOP doesn't see the attachment. 

Steps to Reproduce:

Create an email from Apple Mail and use an image that is inline. Send the email and then use CFPOP to get the email. Attachments are blank.

Actual Result:

No attachments found

Expected Result:

Attachments should be shown

Any Workarounds:

None bar using Java directly instead of CFPOP

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3856685

External Customer Info:
External Company:  
External Customer Name:
External Customer Email:  
External Test Config: My Hardware and Environment details:

Windows, CF11



If you do an inline image and a file that is not inline such as a PDF then *both* files show up. A single inline image though causes this issue from Apple Mail, iPad Mail and iPhone Mail. Railo doesn't have this issue and CF9, CF10 and CF11 does have this issue.
Comment by External U.
9974 | November 24, 2014 06:03:35 AM GMT
Please attach some example code that I can test. I've resolved email attachment issues for others. Let see if this is a bug or code.
Comment by External U.
9975 | November 26, 2014 05:16:45 PM GMT
Hi Dan, I tried sending a mail from Apple Mail, and accessed it using CFPOP, I can see that CIDs has the attachment file name and i have set the attribute attachmentpath, and was able to get the file downloaded to the path. I have tried it with CF 11 update 3. Is there anything else that i am missing here?
Comment by HariKrishna K.
9976 | December 01, 2014 04:16:02 AM GMT
Since there has been no response, closing the bug. If you are still facing the issue, please revert will re-open the bug.
Comment by HariKrishna K.
9977 | December 08, 2014 02:40:52 AM GMT
Although this bug was closed because there was no follow up from the author, I believe that this same bug is evident in CF9, CF10 and CF11: and so I'm voting for the identical issue here in CF11 in hopes that it will be addressed in CF12.
Vote by External U.
9979 | July 06, 2015 12:44:56 PM GMT
How do I reopen this? I can give you a test mail showing the issue if you need. Dan.
Comment by External U.
9978 | July 13, 2015 12:53:06 PM GMT