tracker issue : CF-3923565

select a category, or use search below
(searches all categories and all time range)

J2EE Session Vars Break ColdFusion on Win 2012 EC2

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Christopher Tierney / Christopher Tierney (Christopher Tierney)

Created: 01/19/2015

Components: Installation/Config

Versions: 11.0

Failure Type: Crash

Found In Build/Fixed In Build: CF11_Final /

Priority/Frequency: Critical / Unknown

Locale/System: English / Win 2012 Server x64

Vote Count: 1

Listed in the version Issues Fixed doc
Problem Description:

A clean install of ColdFusion 11 64-bit for Windows will not restart/start in Windows 2012 R2 Standard on a Amazon EC2 instance after J2EE Session Variables are enabled in the ColdFusion Administrator. The version of ColdFusion installed is 11,0,03,292480 downloaded from Adobe's website today. An upgrade of Java to jdk1.8.0_25 yields same result.

Manually turning off J2EE Session Variables in neo-runtime.xml will not resolve issue. An uninstall and reinstall of ColdFusion is required to get the server working again.

Multiple re-installs of ColdFusion where done to narrow this issue down and is repeatable on this instance.

The ColdFusion logs don't appear to help any.

Steps to Reproduce:

1. Install ColdFusion with a production + secure profile. No options (like SOLR). Use built-in web server.
2. Restart service to verify it will restart correctly (which it does)
3. Log into ColdFusion Administrator
4. Turn on J2EE Session Variables
5. Restart ColdFusion Service (service will not start)

Actual Result:

Service will not restart. Dialogue shows service timed out.  The System log shows "The ColdFusion 11 Application Server service terminated with the following service-specific error: The system cannot find the file specified. I do notice while the service is trying to restart that coldfusion.exe and coldfusionsvc.exe are running. They eventually go away after a period of time.

Expected Result:

ColdFusion Service starts

Any Workarounds:

I have a Windows 2008 install of ColdFusion 11 with update 3 applied after install; version 11,0,03,292480. J2EE session variables are turned on with no ill effect.
You can also just not enable J2EE Session Variables and the server works fine on EC2 Windows 2012 R2 Standard.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3923565

External Customer Info:
External Company:  
External Customer Name: CFJSGeek
External Customer Email:  
External Test Config: My Hardware and Environment details:

Amazon EC2 m3.medium instance at us-east-la

Windows Server 2012 R2 Standard 64-bit

3.75GB RAM

Intel Xeon CPU E5-2670 v2 @ 2.50GHz



If I start ColdFusion via the command-line, the built-in server never responds for an admin page ( Here's the console output: C:\ColdFusion11\cfusion\bin>coldfusion start console Jan 20, 2015 1:41:36 AM org.apache.catalina.core.AprLifecycleListener init INFO: The APR based Apache Tomcat Native library which allows optimal performanc e in production environments was not found on the java.library.path: C:\ColdFusi on11\cfusion\lib;C:\ColdFusion11\cfusion\jintegra\bin;C:\ColdFusion11\cfusion\ji ntegra\bin\international;C:\ColdFusion11\cfusion\lib\oosdk\classes\win Jan 20, 2015 1:41:37 AM org.apache.coyote.AbstractProtocol init INFO: Initializing ProtocolHandler ["http-bio-8500"] Jan 20, 2015 1:41:37 AM org.apache.coyote.AbstractProtocol init INFO: Initializing ProtocolHandler ["ajp-bio-8014"] Jan 20, 2015 1:41:37 AM org.apache.catalina.core.StandardService startInternal INFO: Starting service Catalina Jan 20, 2015 1:41:37 AM org.apache.catalina.core.StandardEngine startInternal INFO: Starting Servlet Engine: Apache Tomcat/7.0.54 Jan 20, 2015 1:41:41 AM org.apache.catalina.util.SessionIdGenerator createSecure Random INFO: Creation of SecureRandom instance for session ID generation using [SHA1PRN G] took [113] milliseconds.
Comment by External U.
8898 | January 19, 2015 08:14:08 PM GMT
Note when I state I have a working instance in my workarounds, that is on a non-Amazon server. It is on a dedicated server.
Comment by External U.
8899 | January 19, 2015 08:17:01 PM GMT
Hi CFJSGeek, I've noticed at least 1 case (and I think 2, but I forget what the 2nd was) where CF behaves differently if secure profile was enabled during install vs enabling it post-install. Have you also determined if this same issue exists if secure profile isn't enabled during install? Thanks!, -Aaron
Comment by External U.
8900 | January 20, 2015 04:35:08 AM GMT
Aaron, I will try your suggestion. Adobe, note that the pre-built AMI from you has J2EE turned on and runs fine. This is CF11 standard in us-east1-1a on a t2.medium instance. I have also tried installing using just IIS servers instead of the built-in server with the same result.
Comment by External U.
8901 | January 20, 2015 10:59:43 AM GMT
I have found a resolution to this issue. It appears to be a bug in the new CF11 installer with U3. In the original installer, C:\ColdFusion11\cfusion\runtime\conf\context.xml does not comment out: "<Manager pathname="" />". In the U3 installer, this statement is commented out. Uncommenting out this statement resolves the issue. This appears to be a bug that found its way back from CF10 per:
Comment by External U.
8902 | January 20, 2015 11:25:31 AM GMT
CF 11 won't restart after upgrade. HUGE issue!
Vote by External U.
8907 | January 20, 2015 02:33:40 PM GMT
Hi Christopher, I do not use the new CF11 installer that has U3 bundled, b/c it has an issue that I didn't have time to look into yet. Perhaps it is related to the issue you are seeing here. So I use the CF11 Final installer, and then I install U3 post-install. I've verified that the statement is not commented out on any of those installs. Sometime I may try the new CF11+U3 installer again and see if the issue I ran into exists due to that line being commented out in that specific installer. Thanks!, -Aaron
Comment by External U.
8903 | January 20, 2015 05:52:45 PM GMT
Adobe, Perhaps the CF11+U3 installer should've been available for testing during the beta. Could a note please be added to ensure future update-bundled-installers are available for testing during update betas? Thanks!, -Aaron
Comment by External U.
8904 | January 20, 2015 05:53:57 PM GMT
Fix is available in the refreshed Full installers. More information on this is available here at:
Comment by Krishna R.
8905 | January 20, 2015 11:52:22 PM GMT
The fix for this bug is available in the pre-release build of ColdFusion 11 Update 5
Comment by CFwatson U.
8906 | February 20, 2015 09:25:48 AM GMT