tracker issue : CF-3944298

select a category, or use search below
(searches all categories and all time range)

cfcollection action="create" fails when Solr is installed after CF10 with ColdFusion_10_Jetty_Solr_win.exe

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/CannotReproduce

Reporter/Name(from Bugbase): Henry Ho / Henry Ho (Henry Ho)

Created: 02/23/2015

Components: Text Search, Solr

Versions: 10.0

Failure Type: Non Functioning

Found In Build/Fixed In Build: Final /

Priority/Frequency: Critical / All users will encounter

Locale/System: English / Win All

Vote Count: 0

Problem Description:

cfcollection action="create" fails.

Steps to Reproduce:

Install CF w/o full-text search
Install ColdFusion_10_Jetty_Solr_win.exe
<cfcollection action="create" collection="test" path="d:\collections\">

Actual Result:

Unable to create Solr collection test2.

An error occurred while creating the collection: org.apache.solr.common.SolrException. Check the Solr logs for more detail.

(see attchment)

Expected Result:

No exception

Any Workarounds:

Use CFAdmin seems to work, but that screen cannot set Language for the new collection.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3944298

External Customer Info:
External Company:  
External Customer Name: Henry
External Customer Email:  
External Test Config: My Hardware and Environment details:

CF10 u15


  1. February 24, 2015 00:00:00: 1_cf_exception.txt
  2. February 24, 2015 00:00:00: 2_solr_exception.txt


Henry, a quick look at your logs suggests that you have insufficient permission to create collection files/directories at the specified location. excerpts from the logs: "SEVERE: org.apache.solr.common.SolrException: Error executing default implementation of CREATE" "Caused by: java.lang.RuntimeException: Can't find resource 'solrconfig.xml' in classpath or 'D:\collections\test2\conf/'," Can you check if Solr service (or more specifically the user account with which the service is running) has write permission to the folder : "D:\collections\"
Comment by Piyush K.
8295 | February 24, 2015 04:47:21 AM GMT
ColdFusion10JettyService : C:\ColdFusionJetty\jetty.exe -zglaxservice ColdFusion10JettyService Log On: Local System Account It should have right to write to anywhere. I even tried setting log on as my own user account and the same error occurs.
Comment by External U.
8296 | February 24, 2015 12:24:18 PM GMT
Henry, Just for the sake of isolating the issue, can you assign recursive "Full control" permission to account "everyone" to the folder where you are trying to create the collection, and retry creating the collection. Besides using cfcollection tag in a cfm page, you can also create a test collection with CF administator > Data & Services > ColdFusion Collections. Can you also confirm the update level and build no. of your CF server (you can find the info in CF administrator> server settings > settings summary) and the version of Windows OS you are using.
Comment by Piyush K.
8297 | February 26, 2015 06:44:11 AM GMT
Just tried, the "test" folder is created but still the same exception. Feb 26, 2015 10:16:23 AM org.apache.solr.core.SolrResourceLoader <init> INFO: Solr home set to 'D:\collections\test\' Feb 26, 2015 10:16:23 AM org.apache.solr.common.SolrException log SEVERE: org.apache.solr.common.SolrException: Error executing default implementation of CREATE at org.apache.solr.handler.admin.CoreAdminHandler.handleCreateAction(
Comment by External U.
8298 | February 26, 2015 12:49:27 PM GMT
Henry, I am unable to reproduce the issue with CF10 update 15 (10,0,15,292620) on Windows 2012. The Solr server (64 bit) is installed separately (dedicated Jetty installer) on the same machine as the CF server. Creating collection with the CF admin works. Can you please confirm the following as well: - the update level and build no. of your CF server (you can find the info in CF administrator> server settings > settings summary) - the version of Windows OS you are using. is it 32-bit or 64-bit. - Did you try granting recursive "Full control" permission, specifically to user account "everyone" on the folder you are trying to create the collection in.
Comment by Piyush K.
8299 | March 13, 2015 05:57:15 AM GMT
Closing this, since this is not reproducible and we haven't heard back from the reporter. We can reopen this if more info is made available.
Comment by Piyush K.
8300 | June 16, 2015 03:08:06 AM GMT