tracker issue : CF-3952949

select a category, or use search below
(searches all categories and all time range)

ColdFusion 11 CFPrint not printing portion of PDF generated by Adobe Central (jetForms)

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/PRNeedInfo

Reporter/Name(from Bugbase): Shirak Avakian / Shirak Avakian (Shirak Avakian)

Created: 03/13/2015

Components: CFPRINT

Versions: 11.0

Failure Type: Data Loss

Found In Build/Fixed In Build: CF11_Final / CF11 Update7

Priority/Frequency: Critical / All users will encounter

Locale/System: English / Win8 Server 64-bit

Vote Count: 1

Listed in the version Issues Fixed doc
Problem Description: After upgrading to CF11 cfprint stoped printing 1 portion (paragraph) from a PDF form generated by Adobe Central Print aka JetForm

Steps to Reproduce: Use CFprint to print attached file.

Actual Result: Missing 1 portion (Coverage)

Expected Result: All PDF portions should print

Any Workarounds: Use third party tools, for server side print like smartJPrint or use CF9 cfprint

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3952949

External Customer Info:
External Company:  
External Customer Name: Shirak
External Customer Email:  
External Test Config: My Hardware and Environment details:

Windows Server 2008 R2 Standard

IIS 7.5.7600.16385

ColdFusion 11 Ent Update 4


  1. March 13, 2015 00:00:00: 1_PUP.PDF


This is a mission critical production issue effecting all policy holders and marked as urgent in our department. Please provide fix as soon as possible. We already have full support package from Adobe.
Comment by External U.
8049 | March 13, 2015 11:14:23 AM GMT
I see this ticket is marked Open/ToTrack/VerifyLater. Not sure why "VerifyLater" Repro is simple: <cfprint printer="#myPrinter#" fidelity="yes" source="#expandPath('./PUP.PDF')#" pages="2" attributestruct="#{usePdfPageSize=true}#"> It'll take about 2 minutes to verify this :) Much of the bottom of the printed page is blank. Thanks!, -Aaron
Comment by External U.
8050 | September 24, 2015 02:26:39 PM GMT
+1 ......................
Vote by External U.
8057 | September 24, 2015 02:27:08 PM GMT
This fix will be made available in the upcoming ColdFusion update. Thanks.
Comment by Akhila K.
8051 | October 23, 2015 05:17:56 AM GMT
This is not fixed in CF11 Update 7 (build 11,0,07,296330). In fact, the repro code from my "12:56:39 PM GMT+00:00 Sep 24, 2015" comment still shows the same issues. In CF10 Update 15 (build 10,0,15,292620): 1) only page 2 is printed (good) 2) page 2 is fully printed w/o blank areas (good) In CF11 Update 7 build 11,0,07,296330: 1) both page 1 and page 2 are printed (bad) 2) much of the bottom of page 2 is blank (bad) Thanks!, -Aaron
Comment by External U.
8052 | December 03, 2015 03:36:24 AM GMT
Hi Akhila, I added a comment nearly 2 years ago. This ticket is not fixed in CF11 Update 7. Please re-open. Fixed In Build says: CF11 Update7. That is wrong. It is not fixed. Thanks!, -Aaron
Comment by Aaron N.
8053 | July 30, 2017 07:39:05 AM GMT
Umm, that code in my 09/24/2015 14:26:39 GMT comment doesn't even run in CF2016! It throws: java.lang.NullPointerException at org.jpedal.utils.PdfPageFormat.getDefaultMediaSizeName(Unknown Source) Can someone at Adobe please re-open this ticket and we can have a discussion? Thanks!, -Aaron
Comment by Aaron N.
8054 | July 30, 2017 07:50:11 AM GMT
Hi Aaron, I tried in 2016 base build as well as on Update 4 on 2016. Worked fine for me . Content of my cfm: <cfset myPrinter= " Your Printer Path"> <cfprint printer="#myPrinter#" fidelity="yes" source="#expandPath('./PUP.PDF')#" pages="2" attributestruct="#{usePdfPageSize=true}#"> Am i missing something in here ?? Thanks, Manas
Comment by Manas M.
8055 | August 10, 2017 11:27:58 AM GMT
Hi Aaron, Could you please let us know if it still didn't work for you in 2016. Thanks, Manas
Comment by Manas M.
8056 | January 08, 2018 10:06:17 AM GMT