tracker issue : CF-3979497

select a category, or use search below
(searches all categories and all time range)

ColdFusion 11 and Solr Search

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/UserError

Reporter/Name(from Bugbase): Dawn Green / Dawn Green (Dawn Green)

Created: 04/30/2015

Components: Installation/Config, Config

Versions: 11.0

Failure Type: Non Functioning

Found In Build/Fixed In Build: CF11_Final /

Priority/Frequency: Critical / All users will encounter

Locale/System: English / Win 2008 Server R2 64 bit

Vote Count: 0

Problem Description: I have a brand new server. Everything is a fresh install including ColdFusion 11. I installed the Production Profile along with all the sub-components. ODBC, Solr Service, PDFG Service, Admin Component for Remote Start/Stop, .Net Integration Services. The install seems to have installed with out a problem. However, when I go to the Administrator, under Data & Services, ColdFusion Collections, nothing happens. It does not go to that page. I can click on Solr Services and it will go to that page. I can click on the ColdFusion Collections page, restart the ColdFusion Add on Components service and when I go back to the Administrator, the page says "Unable to retrieve collections from the Search Services. Ensure that you have installed ColdFusion Search Service and it is running."

I tried to create the collection manually and the page never did do anything. 

When I go to C:\ColdFusion11\cfusion\jetty\multicore\solr.xml

This file doesn't contain any collections in it. Isn't supposed to have a core0? This is all that is in the file

<?xml version='1.0' encoding='UTF-8'?><solr persistent="true">
<cores adminPath="/admin/cores">


Steps to Reproduce: I uninstalled CF 11. Restarted server. Installed CF 11. Restarted server. Tried the page, Restarted services and I have the same results as before.

Actual Result: I am unable to create a collection in order to search

Expected Result: To be able to create a collection and to search using it.

Any Workarounds:

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3979497

External Customer Info:
External Company:  
External Customer Name: Dawn
External Customer Email:  
External Test Config: My Hardware and Environment details: Brand new server. 

Windows 2008 Server R2 Standard 64 bit Service Pack 1.

Intel Xeon CPU E5-2640 0 @ 2.50GHz 2.50GHz (2 processors)




  1. April 30, 2015 00:00:00: 1_ColdFusion_11_option_chosen_when_installing.docx
  2. May 07, 2015 00:00:00: 2_2015_05_05.stderrout.txt
  3. May 07, 2015 00:00:00: 3_jetty.txt
  4. May 07, 2015 00:00:00: 4_Services3.jpg


I posted in the adobe forums. My post is at Let me know if you need any other information.
Comment by External U.
7675 | April 30, 2015 10:27:27 AM GMT
Dawn, I unable to observe the issue when installing CF11 with production profile on a Win 7 x64 machine. Can you pls. attach the stdout log at <cf_root>/cfusion/jetty/logs Also can you ensure that the Solr admin port at CF admin> Data & Services > Sole Server > advanced settigns matches the port setting in the jetty.xml file at <cf_root>/cfusion/jetty/etc directory. You can also try browsing to http://localhost:<jetty_port> to check is the service is running. The port no. typically is 8987.
Comment by Piyush K.
7676 | May 07, 2015 02:26:29 AM GMT
Thank you so much for looking into this. I don't have a stdout log at cfroot/cfusion/jetty/logs. I do have a stderrout.log. I will attach it. If this isn't what you need let me know. When I look in the cfadmin the Solr Admin port is 8987 the solr host name is localhost the solr home is C:\ColdFusion11\cfusion\jetty\multicore I try several variations of the address and they all do not load. http://localhost:8987 http://localhost:8987/solr
Comment by External U.
7677 | May 07, 2015 07:20:29 AM GMT
I have attached the jetty.xml file as well. It has port listed in it 2 times. <Set name="securePort"><Property name="" default="8998" /></Set> <Set name="port"><Property name="jetty.port" default="8987" /></Set>
Comment by External U.
7678 | May 07, 2015 07:28:39 AM GMT
Let me know if you need anything else. I am anxious to get this fixed.
Comment by External U.
7679 | May 07, 2015 07:34:21 AM GMT
I am looking at the configure Apache for ColdFusion in Windows. ColdFusion11_Installing.pdf 1. 2. 3. 4. 1. option to enable buffering and verbose debugging is available on the same page. Configuring IIS: Creates a folder 1 in cfroot\config\wsconfig, that contains all connector-related files. Creates a virtual directory Jakarta in cfroot\config\wsconfig (in IIS). Adds an entry, tomcat, under the{{ ISAPI FILTERS}}. This points to cfroot\config\wsconfig\1\isap i_redirect.dll. Adds an entry, tomcat, to cfroot\config\wsconfig\1\isapi_redirect.dll with permission allow ed under ISAPI and CGI Restrictions. It is applicable for global sites in IIS manager. Adds the following isapi handlers: cfcHandler, cfmHandler, cfmlHandler, cfrHandler, and cfswfH andler. For debugging issues, set the log level to debug, in the file present in the {{cfroot\config\wsconfig\1\ }}directory. To disable webserver buffer, change the is_buffer_enable to false in the cfroot\config\wsconfig \1\ file. Disable webserver buffer if you want cfflush to work over an IIS connector. If your application does not use cfflush, set it to true for increase in the performance. Configuring Apache web server in Windows You configure Apache by using the Web Server Configuration Tool in GUI or command-line mode. This discussion describes how to use GUI mode. Note To configure Apache connector in UNIX platforms, APXS installation is a prerequisite. (Server configuration only) To use the command line, open the batch files located in cf_root\cfusion\bin\connectors. For more information, see the Web Server Management topic in the Configuring and Administering ColdFusion guid e. Configure Apache for ColdFusion in Windows Start the Web Server Configuration Tool by selecting Start > Programs > Adobe > ColdFusion 11 > Web Server Configuration Tool. Click Add. In the Server pop-up menu, enter the host name and the cluster name to configure. Note The server or cluster does not have to reside on the web server computer. In the Web Server Properties area, select Apache and specify the path to the directory that contains the httpd.conf file. Where is the httpd.conf file at? I have done a search on the server and I can not find it.
Comment by External U.
7680 | May 14, 2015 10:40:51 AM GMT
can't see any errors in the attached stderr log. closing this as it seems from the forum thread, that the issue is resolved. Dawn, On a windows, the httpd.conf for Apache HTTP webserver is typically located in the <http_root>/conf directory.
Comment by Piyush K.
7681 | July 09, 2015 02:52:35 AM GMT