tracker issue : CF-3987564

select a category, or use search below
(searches all categories and all time range)

file attachments to cfmail messages are misnamed if they have spaces in the file name

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/CannotReproduce

Reporter/Name(from Bugbase): colin macallister / colin macallister (colin macallister)

Created: 05/13/2015

Components: Net Protocols, MAIL

Versions: 11.0

Failure Type: Usability Issue

Found In Build/Fixed In Build: CF11_Final /

Priority/Frequency: Major / All users will encounter

Locale/System: English / Win 2008 Server R2 64 bit

Vote Count: 0

Problem Description: Attaching a file to a message with cfmailparam leads to it being shown as "Untitled attachment ####" when the file has spaces in the name.

Steps to Reproduce: Attach a file with spaces in the name. See the name of the attachment in the mail that is sent.

Actual Result: An attachment in the email message called "Untitled attachment 12345.png", for example.

Expected Result: The original file name.

Any Workarounds: No.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3987564

External Customer Info:
External Company:  
External Customer Name: colin
External Customer Email:  
External Test Config: My Hardware and Environment details:



Hi colin, I have tried reproducing the same with attachment the same name "Untitled attachment 12345.png" and it worked. I have tried itin CF 11 HF3 and HF5. Can you please let me know in which configuration you are hitting this issue?
Comment by HariKrishna K.
7448 | May 18, 2015 08:01:55 AM GMT
It didn't happen in CF11 without updates, or update 3. It happened with update 5, and it may just be happening to images. This might be related to the other bug I submitted, in which the attachment file name is not downloaded via cfimap if the attachment is an image.
Comment by External U.
7449 | May 18, 2015 01:42:11 PM GMT
Also, naming it Untitled attachment 12345.png might be muddying the issue. Try naming it "File name with spaces.png". And in my case they were actually png attachments.
Comment by External U.
7450 | May 18, 2015 01:43:43 PM GMT
I have tried using "File name with spaces.png", and i was able to retrieve it thru cfimap. Please find the attached screen shot retrieving the attachment.
Comment by HariKrishna K.
7451 | May 21, 2015 05:39:04 AM GMT
Can you please attach the raw header of the mail.
Comment by HariKrishna K.
7452 | May 21, 2015 06:15:03 AM GMT
Return-Path: Received: from CF11-VM (localhost []) by ; Tue, 12 May 2015 17:51:32 -0400 Date: Tue, 12 May 2015 17:51:32 -0400 (EDT) From: "" <> Reply-To: To: testcolin <> Message-ID: <> Subject: [testcolin] image MIME-Version: 1.0 Content-Type: multipart/mixed; boundary="----=_Part_450_741776488.1431467492323" X-Mailer: ColdFusion 11 Application Server X-Envelope-From: Envelope-To: List-ID: testcolin <> List-Post: <> List-Subscribe: <> List-Unsubscribe: <> List-Digest: <> List-Owner: <> Precedence: list X-PBNML-PID: 535504
Comment by External U.
7453 | May 22, 2015 08:56:16 AM GMT
Not able to find anything from raw headers, can you please attach the entire raw mail with attachments
Comment by HariKrishna K.
7454 | July 09, 2015 12:52:55 AM GMT
Haven't heard back from the user, Closing it as Cannot Reproduce. Please revert with the info asked, we can consider of re-opening this bug.
Comment by HariKrishna K.
7455 | September 23, 2015 10:03:56 PM GMT