tracker issue : CF-3996225

select a category, or use search below
(searches all categories and all time range)

OpenOffice 4.1 Installation Not Found when Using CFDOCUMENT

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/NotABug

Reporter/Name(from Bugbase): Scotty I / Scotty I (Scotty I)

Created: 05/27/2015

Components: Document Management, Office Integration

Versions: 11.0

Failure Type: Non Functioning

Found In Build/Fixed In Build: CF11_Final /

Priority/Frequency: Critical / Some users will encounter

Locale/System: English / Linux CentOS 6.4

Vote Count: 1

Problem Description:

I've installed a fresh copy of ColdFusion 11 and updated it to the latest version 11,0,05,293506. After verifying that the installation was working correctly (running multiple CFM pages, etc.), I downloaded and installed OpenOffice 4.1. After setting the path in CFADMIN - Document to "/opt/openoffice4", I was presented with the green status message: "Local OpenOffice configuration updated."

When I attempt to use the CFDOCUMENT tag to convert a DOC file to PDF, I receive the following error message: "Could not determine OpenOffice installation."

Steps to Reproduce:

1. Install ColdFusion 11 and Update to latest version using CFADMIN.
2. Download and Install OpenOffice 4.1 from On RedHat, it was installed to "/opt/openoffice4"
3. Point your browser to a CFM page that includes <cfdocument format="pdf" srcFile="some/test/file.doc" ... >

Actual Result:

Receive the ColdFusion error message: "Could not determine OpenOffice installation."

Expected Result:

A converted PDF file is created from the source DOC file.

Any Workarounds:

I have also tried installing OpenOffice 4.1 FIRST before installing ColdFusion. With this attempt, I made sure to specify during the ColdFusion installation to integrate OpenOffice. It correctly identified the location of the OpenOffice installation (/opt/openoffice4/) and set the path in CFADMIN - Document. I am still receiving the same error message though.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3996225

External Customer Info:
External Company:  
External Customer Name: Scotty
External Customer Email:  
External Test Config: My Hardware and Environment details:

CentOS 6.6 (Release) x64

Kernel: 2.6.32-504.1.3.el6.x86_64

ColdFusion 11,0,05,293506 - Single Instance running in Development mode

OpenOffice 4.1.1



I'm also seeing this on AWS EC2 Coldfusion 11 AMI
Vote by External U.
7322 | July 11, 2015 12:34:01 AM GMT
Did you check if jars were there? I can not access the system
Comment by Uday O.
7316 | November 16, 2015 04:26:48 AM GMT
I am not able to remote debug. You had said debug port is 5005. But in admin it is showing 5006. Even at 5006 it is not connecting. On same system I am able to connect to port 6006. Lots of confusions. Please resolve this issue so that I can debug.
Comment by Uday O.
7317 | December 04, 2015 04:57:53 AM GMT
I debugged. Code is trying to connect to uno:pipe,name=uno_cf_pipe;urp;StarOffice.ComponentContext but getting NoConnectException exception. Can you check of OO is properly installed and running. Is it any OS or web server specific issue? Is it OO4 specific issue? Is it 64 bit/32 bit specific issue?
Comment by Uday O.
7318 | December 15, 2015 02:29:52 AM GMT
Have debugged and googled a lot. Could not find what is the issue. Code gets 'Connection refused' error while trying to connect to OO. nOT SURE IF IT IS RELATED TO oo INSTALLATION OR SOMETHING ELSE. pUNTING IT TO 13
Comment by Uday O.
7319 | January 13, 2016 12:34:28 AM GMT
PDFs are getting generated from DOC file using OO4.1.2 . Can you upgrade OO to 4.1.2 and try again ?
Comment by Nitin K.
7320 | January 21, 2016 03:59:46 AM GMT
It is working in OO4.1.2 . Have verified on RHEL7 & RHEL6.5 Closing the bug . In case you find this issue again ,please get back to us .
Comment by Nitin K.
7321 | March 21, 2016 12:11:36 AM GMT