tracker issue : CF-4070239

select a category, or use search below
(searches all categories and all time range)

BUG# 3853535 NOT fixed in Update 5 as stated

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/CannotReproduce

Reporter/Name(from Bugbase): Brian Salerno / Brian Salerno (Brian Salerno)

Created: 10/07/2015

Components: Installation/Config, Connector

Versions: 11.0

Failure Type:

Found In Build/Fixed In Build: CF11_Final /

Priority/Frequency: Major / Few users will encounter

Locale/System: English / Win 2008 Server R2 86 bit

Vote Count: 0

Problem Description: See  #3853535 

Steps to Reproduce:See  #3853535 

Actual Result:See  #3853535 

Expected Result:See  #3853535 

Any Workarounds:See  #3853535

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	4070239

External Customer Info:
External Company:  
External Customer Name: Brian Salerno
External Customer Email:  
External Test Config: My Hardware and Environment details:



I have Update 5 installed on my CF 11 server and I am still seeing this exact issue.
Comment by External U.
5616 | October 07, 2015 03:12:19 PM GMT
Hi Brian, Did you remove/re-add the connector via wsconfig.exe? Thanks!, -Aaron
Comment by External U.
5617 | October 07, 2015 10:52:27 PM GMT
Yes I have tried that. Files being downloaded using cfcontent are still being corrupted.
Comment by External U.
5618 | October 08, 2015 10:46:00 AM GMT
Hi Brian, I've added a comment on CF-3853535. I'm seeing the correct behavior in CF11 Update 4 & Update 5. Since I'm not seeing the incorrect behavior, there is seemingly another piece to this puzzle that I don't know of. Could you please attach a repro case here w/ details of how to repro this? And hopefully someone will be able to sort this out. Thanks!, -Aaron
Comment by External U.
5619 | October 09, 2015 11:09:43 PM GMT
Here is the code for the download page, this worked fine in CF 9.x we upgraded servers and installed CF 11 and it is not working anything downloaded is corrupted. <cfparam name="url.path" default=""/> <cfparam name="url.filename" default=""/> <cfparam name="mimeType" default="application/x-unknown"/> <cfif len(url.filename)> <cftry> <cfset filecontent = session.fileManager.getFile(url.path, url.filename)/> <!--- method for getting mime type taken from UDF getFileMimeType() at ---> <cfif len(getPageContext().getServletContext().getMimeType(url.filename))> <cfset mimeType = getPageContext().getServletContext().getMimeType(url.filename) /> </cfif> <cfcatch type="Any"> <cfset filecontent = cfcatch.message /> <cfheader statuscode="404" statustext="Not Found"> </cfcatch> </cftry> </cfif> <cfheader name="Content-Disposition" value='attachment; filename="#url.filename#"'> <cfcontent type="#mimeType#"><cfoutput>#filecontent#</cfoutput>
Comment by External U.
5620 | October 13, 2015 12:22:55 PM GMT
Brian, I am unable to observe the issue on CF11 update 5 / Win7 x64 SP1 / IIS 7.5.7600 The following rule (extracted from web.config): <rewrite> <rewriteMaps> <rewriteMap name="jelly"> <add key="jelly" value="getjelly.cfm" /> </rewriteMap> </rewriteMaps> <rules> <rule name="squishy"> <match url="^jelly" /> <action type="Rewrite" url="getjelly.cfm" /> </rule> </rules> </rewrite> works to redirect the following URLs http://localhost:81/jelly?some_qry_str=12345 http://localhost:81/jelly to getjelly.cfm <!--- getjelly.cfm ----> <cfcontent type="image/jpg" file=#expandPath('./x.jpg')# /><cfabort/> The image renders, as expected. can you share the rewrite URL, you are using and the relevant code in the session.fileManager.getFile method. Also, what do you mean by corrupted. Pls. elaborate.
Comment by Piyush K.
5621 | October 17, 2015 08:35:05 PM GMT
closing, since haven't heard back from the reporter. can be reopened, if the information requested in the previous comment is made available.
Comment by Piyush K.
5622 | December 19, 2015 01:48:30 PM GMT