tracker issue : CF-4091165

select a category, or use search below
(searches all categories and all time range)

cfdbinfo resource leak

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/CannotReproduce

Reporter/Name(from Bugbase): Russ Sivak / Russ Sivak (Russ Sivak)

Created: 11/23/2015

Components: Database

Versions: 11.0

Failure Type:

Found In Build/Fixed In Build: CF11_Final /

Priority/Frequency: Major / All users will encounter

Locale/System: English / Linux CentOS 6.4

Vote Count: 0

Problem Description:
running cfdbiinfo creates an open cursor on the database that doesn't get released in a timely fashion (at least using oracle).  This eventually leads to [Macromedia][Oracle JDBC Driver][Oracle]ORA-01000: maximum open cursors exceeded
Steps to Reproduce:
<cfloop from="1" to="10" index="x">

Actual Result:
10 cursors get allocated on the database side 
Expected Result:
No additional cursors are used after the calls complete.  
Any Workarounds:
Get the db version only once per application.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	4091165

Reason:	PRNeedInfo

External Customer Info:
External Company:  
External Customer Name: Russ Sivak
External Customer Email:  
External Test Config: Linux, CF11, Oracle 11g



Please share the information mentioned below: 1. Settings summary 2. DataSource details
Comment by Nimit S.
5226 | November 30, 2015 11:44:20 PM GMT
Russ, Please provide the details mentioned below.
Comment by Nimit S.
5227 | December 08, 2015 08:50:32 AM GMT
Russ, We are closing this bug as we have not received any update on this issue. We will re-open this bug once we get required information on this.
Comment by Nimit S.
5228 | May 30, 2016 12:38:27 AM GMT
Sorry I did not see previous emails. Exactly what info do you need? I'm sure this is easily reproduceable using standard drivers.
Comment by External U.
5229 | May 31, 2016 10:01:28 AM GMT
Thanks Russ for commenting on this bug. I am re-opening this bug and I am also able to repro this issue.
Comment by Nimit S.
5230 | June 06, 2016 10:01:57 AM GMT
Hi Russ, Please apply ColdFusion 11 Update 9 and see if you are still facing this issue. Thanks, Nimit
Comment by Nimit S.
5231 | June 16, 2016 03:56:03 AM GMT
Russ, Have you tried it with the latest update? -Nimit
Comment by Nimit S.
5232 | June 23, 2016 12:21:57 AM GMT
Unfortunately the latest update is broken (possibly related to this fix). We keep getting queryname is undefined.
Comment by External U.
5233 | June 23, 2016 08:24:08 AM GMT
Additionally, I have just tried the latest update (9) build 11,0,09,299201 and it still doesn't work. Every time I run that loop 20 additional cursors are created and not released. You can test on oracle using the following query select ms.SID, n.username, n.machine,, ms.value from V$SESSTAT ms inner join V$STATNAME sn on sn.STATISTIC# = ms.STATISTIC# and like '%cursor%' inner join V$SESSION n on n.sid = ms.sid where username='yourusername' and look at the opened cursors current.
Comment by External U.
5234 | June 23, 2016 10:38:02 AM GMT
Russ, I tried checking open cursors at the oracle database level. But it opens and closes all the cursors without any issue. I am able to execute this loop even 50000 times without any issue. Please share the details mentioned below: 1. Oracle Database version along with build number 2. ColdFusion settings summary 3. Datasource details.
Comment by Nimit S.
5235 | August 02, 2016 06:23:52 AM GMT
Russ, Please let us know if you are still facing this issue. If yes, then share the information asked in the previous comment.
Comment by Nimit S.
5236 | July 07, 2017 12:46:09 PM GMT
Russ, Please let us know if you are still facing this issue. If yes, then share the information asked in the previous comment. -Nimit
Comment by Nimit S.
5237 | July 11, 2017 08:59:04 AM GMT
Hi Russ, I am closing this bug since I have not received any update on this. If you are still facing this issue, please feel free to reach out to us to re-open this bug.
Comment by Nimit S.
5238 | September 04, 2017 05:26:47 AM GMT