tracker issue : CF-4119872

select a category, or use search below
(searches all categories and all time range)
Title:

cfdump bug with CLI

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Adam Cameron / Adam Cameron (Adam Cameron)

Created: 02/19/2016

Components: CLI

Versions: 2016

Failure Type: Incorrect w/Workaround

Found In Build/Fixed In Build: CF2016_Final /

Priority/Frequency: Normal / Some users will encounter

Locale/System: English / Platforms All

Vote Count: 0

Listed in the version 2016.0.02.299200 Issues Fixed doc
Problem Description:
[bad implementation]


Steps to Reproduce:
From the CLI:
<cfdump var="#structNew()#" format="html">

Actual Result:
C:\src\CF12\bugs\new>cf dump.cfm
Feb 19, 2016 13:28:20 PM Error [main] - Element USER_AGENT is undefined in CGI.
coldfusion.runtime.UndefinedElementException: Element USER_AGENT is undefined in
 CGI.
        at coldfusion.runtime.CfJspPage.resolveCanonicalName(CfJspPage.java:2213
)
[etc]

Expected Result:

CFDUMP not to rely on CGI.user_agent existing!?!?!


Any Workarounds:

[gimme a break... just sort it out]

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	4119872

External Customer Info:
External Company:  
External Customer Name: Adam Cameron
External Customer Email:  
External Test Config: My Hardware and Environment details:

Attachments:

Comments:

As a work-around, please use <cfdump var="#structNew()#"> We will fix this.
Comment by HariKrishna K.
4591 | February 21, 2016 11:09:09 PM GMT
test note
Comment by CFwatson U.
4592 | June 07, 2016 04:19:21 AM GMT
The fix for this bug is available as part of the early-access build for ColdFusion 2016 Update 2.
Comment by CFwatson U.
4593 | June 07, 2016 04:26:15 AM GMT