tracker issue : CF-4120075

select a category, or use search below
(searches all categories and all time range)
Title:

Docs for encodeForHtml() not helpful

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Adam Cameron / Adam Cameron (Adam Cameron)

Created: 02/20/2016

Components: Documentation

Versions: 2016

Failure Type: Usability Issue

Found In Build/Fixed In Build: CF2016_Final /

Priority/Frequency: Minor / Most users will encounter

Locale/System: ALL / Platforms All

Vote Count: 1

Listed in the version 2016.0.02.299200 Issues Fixed doc
https://helpx.adobe.com/coldfusion/cfml-reference/coldfusion-functions/functions-e-g/encodeforhtml.html

Description unusably superifical. It needs to explain the encoding rules.

They example is stupid and doesn't demonstrate the function at all. The example should demonstrate "before" and "after" of the various encoding transformations that take place. The current example demonstrates *nothing*.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	4120075

External Customer Info:
External Company:  
External Customer Name: Adam Cameron
External Customer Email:  
External Test Config: My Hardware and Environment details:

Attachments:

Comments:

This is ESAPI powered, isn't it?
Comment by External U.
4534 | February 23, 2016 04:44:45 PM GMT
Hi James, This is ESAPI powered function.
Comment by S P.
4535 | February 26, 2016 12:37:03 AM GMT
This is the updated page: https://helpx.adobe.com/coldfusion/cfml-reference/coldfusion-functions/functions-e-g/encodeforhtml.html
Comment by External U.
4536 | May 27, 2016 04:52:50 AM GMT
test note
Comment by CFwatson U.
4537 | June 07, 2016 04:19:08 AM GMT
The fix for this bug is available as part of the early-access build for ColdFusion 2016 Update 2.
Comment by CFwatson U.
4538 | June 07, 2016 04:25:56 AM GMT