tracker issue : CF-4126653

select a category, or use search below
(searches all categories and all time range)

error "javax.mail.MessagingException: Unable to load BODYSTRUCTURE" when using CFIMAP

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Toby Weston / Toby Weston (Toby Weston)

Created: 03/09/2016

Components: Net Protocols, IMAP

Versions: 11.0

Failure Type:

Found In Build/Fixed In Build: CF11_Final /

Priority/Frequency: Normal / Few users will encounter

Locale/System: English / Win All

Vote Count: 0

Listed in the version 2016.0.02.299200 Issues Fixed doc
Problem Description:

See Bug 3345011 -

This issue is still occuring in CF11, which is also stated in the bug comments itself.

Using Gmail as the imap server and a simple connection produces the error.

Steps to Reproduce:

See previous bug

Actual Result:

javax.mail.MessagingException: Unable to load BODYSTRUCTURE

Expected Result:

Gets mail

Any Workarounds:

I got the latest JavaMail from Oracle (v 1.5.5 i think) and replaced the mail.jar in the cf lib folder. It now works as intended correctly giving me the results.

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	4126653

External Customer Info:
External Company:  
External Customer Name: Toby Weston
External Customer Email:  
External Test Config: My Hardware and Environment details:

Win 2012 

CF 11 Update 7


  1. March 16, 2016 00:00:00: 1_cfmail_imap.txt


I have tried this on CF11 with the latest update and with out any updates. In both the scenarios cfimap works on gmail server. Anyways we are planning to upgrade the mail jar in the future updates for CF11.
Comment by HariKrishna K.
3593 | March 16, 2016 01:00:29 AM GMT
As per the previous bug this is an issue with attachments on the emails. Everything works fine but when you get those emails with noemail attachements on them this error occurs. What version are you updating the mail jar to in the future? Will this be the next update (8) to CF11?
Comment by External U.
3594 | March 16, 2016 01:43:43 AM GMT
I have tried fetching emails with and w/o attachments, and I was able to fetch them with out any error. It would be available in CF11 update9.
Comment by HariKrishna K.
3595 | March 16, 2016 04:13:43 AM GMT
I have attached the original source text of an email which is an example of this issue. emails and ips are redacted but you should get the message
Comment by External U.
3596 | March 16, 2016 05:33:18 AM GMT
Hi Hari, Were you able to repro this issue? If so, does it also affect CF2016? If so, could you please describe how to repro this (so that we can confirm the fix)? Thanks!, -Aaron
Comment by External U.
3597 | April 27, 2016 10:08:50 PM GMT
Hi Aaron, We have tried multiple ways of reproducing this scenario, but with no luck. We also tried sending the same mail that Toby has sent us, even that was also received successfully. So, we have upgraded the mail.jar to the latest. The fix will be available in CF 11 HF9 -Hari
Comment by HariKrishna K.
3598 | April 28, 2016 11:28:15 PM GMT
test note
Comment by CFwatson U.
3599 | June 07, 2016 04:18:05 AM GMT
The fix for this bug is available as part of the early-access build for ColdFusion 2016 Update 2.
Comment by CFwatson U.
3600 | June 07, 2016 04:24:45 AM GMT