tracker issue : CF-4149128

select a category, or use search below
(searches all categories and all time range)

query from cfoutput

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/Duplicate

Reporter/Name(from Bugbase): Robert Schwartz / Robert Schwartz (Robert Schwartz)

Created: 05/05/2016

Components: Database

Versions: 2016

Failure Type: Non Functioning

Found In Build/Fixed In Build: CF2016_Final /

Priority/Frequency: Critical / All users will encounter

Locale/System: English / Windows 7 32 bit

Vote Count: 0

Duplicate ID:	CF-4131212

Problem Description:get error that variable is not defined.  If you delete one of the outputs lines that are identical it works but should not have to do this.  the identical lines should not be in the code at all just for testing and it worked with coldfusion11.

Steps to Reproduce:

Actual Result:

Expected Result:

Any Workarounds:

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	4149128

External Customer Info:
External Company:  
External Customer Name: Robert Schwartz
External Customer Email:  
External Test Config: My Hardware and Environment details:


  1. May 05, 2016 00:00:00: 1_rps3.cfm


Robert, Please provide the information mentioned below: 1. Give a repro case without any dependency 2. Share exception stacktrace
Comment by Nimit S.
2935 | May 06, 2016 01:34:06 AM GMT
You should be able to create 2 tables with 1 record each with the fields I am using: Table: tblusers Fields: id: 95 FirstName: robert LastName: schwartz Table: hazusersys Fields: id: 95 Sys: Test1 And then use my code: <cfquery name="getHazUserInfo" datasource="#Application.DSN#"> SELECT * FROM tblusers WHERE ID = 95 </cfquery> <cfdump var="#getHazUserInfo#" expand="no"> <cfoutput>getHazUserInfo1: #getHazUserInfo.ID#</cfoutput><br/> <cfoutput query="getHazUserInfo"> <cfoutput>getHazUserInfo2: #getHazUserInfo.ID#</cfoutput><br/> <cfoutput>getHazUserInfo3: #getHazUserInfo.ID#</cfoutput><br/> <cfoutput>getHazUserInfo4: #getHazUserInfo.ID#</cfoutput><br/> <cfquery name="getHazUserSys" datasource="#Application.DSN#"> select * from hazusersys WHERE HazUserSys.ID = <cfqueryparam value="#getHazUserInfo.ID#" cfsqltype="CF_SQL_INTEGER"> </cfquery> <cfdump var="#getHazUserSys#" expand="no"> <cfoutput>recordcount: #getHazUserSys.RecordCount#</cfoutput> </cfoutput> The error I am getting is: Invalid date ' ' for CFSQLTYPE CF_SQL_INTEGER. The spcific sequence of files ... This is because the second query can't find the ="#getHazUserInfo.ID#" from the first query. I have determined it is because of nested <cfoutput>. I can fix the problem by removing the <cfoutput> </cfoutput> on the lines: <cfoutput>getHazUserInfo2: #getHazUserInfo.ID#</cfoutput><br/> <cfoutput>getHazUserInfo3: #getHazUserInfo.ID#</cfoutput><br/> <cfoutput>getHazUserInfo4: #getHazUserInfo.ID#</cfoutput><br/> I know you should not have nested <cfoutput> but this worked in v11 so I expect it to work in v2016 without have to rewrite over 5000 lines of code.
Comment by External U.
2936 | May 06, 2016 08:25:41 AM GMT
This issue is fixed and the fix will be available as part of ColdFusion 2016 Update 2. We are closing this bug as it is duplicate of bug #CF-4131212
Comment by Nimit S.
2937 | May 17, 2016 11:34:35 PM GMT