tracker issue : CF-4170889

select a category, or use search below
(searches all categories and all time range)

Unable to open Sanitized PDF using acrobat reader

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Shirak Avakian / Shirak Avakian (Shirak Avakian)

Created: 07/06/2016

Components: Document Management

Versions: 2016

Failure Type: Non Functioning

Found In Build/Fixed In Build: CF2016_Update1 /

Priority/Frequency: Major / All users will encounter

Locale/System: English / Windows 8.1 Update 2 x(64)

Vote Count: 0

Listed in the version 2016.0.03.300466 Issues Fixed doc
Problem Description: After Sanitizing PDF file, I'm unable to reopen the file to view whether with adobe reader or cfdocument

Steps to Reproduce: Please use attached zip file

Actual Result:reader / page hangs

Expected Result: show the PDF

Any Workarounds: none

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	4170889

External Customer Info:
External Company:  
External Customer Name: Shirak Avakian
External Customer Email:  
External Test Config: My Hardware and Environment details:

windows 8.1 

ColdFusion 2016 update 2

IIS 8.5.9600


  1. July 06, 2016 00:00:00:
  2. July 08, 2016 00:00:00: 2_foxnews.pdf
  3. July 08, 2016 00:00:00: 3_foxnews.xmp.txt
  4. July 08, 2016 00:00:00: 4_PDF.rar


Please make this high priority since I'm using this feature in my Adobe ColdFusion Summit 2016
Comment by External U.
2228 | July 06, 2016 10:25:40 AM GMT
Hi, This is a known issue which has been raised with the acrobat team and they are looking into it. We do have a patch for it. But the quality of the PDF image will degrade once sanitization is performed using it. For the patch, please send a mail to
Comment by Kailash B.
2229 | July 07, 2016 02:38:16 AM GMT
I just want to mention that the issue is not with acrobat reader only! any other readers unable to read the PDF including ColdFusion built in cfdocument and cfcontent.
Comment by External U.
2230 | July 07, 2016 11:06:47 AM GMT
Hi, Can you please share the xmp file you used to set the custom properties? In our case, we are able to set custom properties. So looking at your xmp will help us figure out the issue. Or are you setting the metadata post sanitization?
Comment by Kailash B.
2231 | July 07, 2016 11:59:17 PM GMT
I have uploaded another PDF foxnews.pdf which has custom properties created by acrobat. Delete all pdf files from my uploaded zip file and replace foxnews.pdf with this new attachment. Run the index.cfm file. Check foxnews_imported.pdf no custom properties were imported. I could not upload the xmp file because this bug base attach functionality is not allowing xmp file. Therefor I'm renaming it to foxnews.xmp.txt.
Comment by External U.
2232 | July 08, 2016 12:40:26 AM GMT
I removed all the old PDF's and tried importing the shared xmp. I could do it and i can see the custom properties. PFA the xmp i used to import metadata, and the PDF to which i imported the custom properties as a rar. As you will see in custom properties, there is a new field named 'Abc'. We are not able to repro your issue.
Comment by Kailash B.
2233 | July 08, 2016 01:36:35 AM GMT
Hi, Yes the file you included in your rar file, has custom properties, I'm still not seeing on my version. What CF version you are running on? I notice the quality of foxnews_imported.pdf is much better than mine. I did install the patch you sent me earlier. My CF version is 2016.0.02.299200 Update Level C:/ColdFusion2016/cfusion/lib/updates/chf20160002.jar
Comment by External U.
2234 | July 08, 2016 11:42:30 AM GMT
Hi Shirak, As discussed over the call, we are currently in the process of fixing the bugs you filed. We will be providing you with a patch as soon as we have one. Thanks, Kailash
Comment by Kailash B.
2235 | July 21, 2016 11:45:51 PM GMT