tracker issue : CF-4198300

select a category, or use search below
(searches all categories and all time range)
Title:

CFCHART - "Marker" tag attribute throws error

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/CannotReproduce

Reporter/Name(from Bugbase): spencer schultz / spencer schultz ()

Created: 02/01/2017

Components: Tags

Versions: 2016

Failure Type: Crash

Found In Build/Fixed In Build: 2016.0.03.300466 /

Priority/Frequency: Normal / All users will encounter

Locale/System: ALL / Win 2012 Server x64

Vote Count: 0

Problem Description:  While using CFCHART the "Marker" tag attribute throws an error stating it's not a valid attribute.  This is a valid attribute listed in the ColdFusion documents https://helpx.adobe.com/coldfusion/cfml-reference/coldfusion-tags/tags-c/cfchart.html and it is also a valid attribute of ZingChart (the third party component used to make the CFCHART tag).

Here is the error I receive when using the "Marker" attribute:

Diagnostics: Attribute validation error for the chart tag. The tag does not have an attribute called marker. The valid attribute(s) are id, type, renderer, query, itemColumn, style, name, format, chartHeight, height, chartWidth, width, aspect3d, alpha, plot, refresh, plotarea, preview, xaxis, yaxis, xaxis2, yaxis2, scales, zoom, tooltip, labels, scaleFrom, scaleTo, showXGridlines, showYGridlines, gridlines, seriesPlacement, legend, foregroundColor, dataBackgroundColor, backgroundColor, background, fill, border, bevel, crosshair, arrows, xaxisvalues, yaxisvalues, showBorder, font, fontSize, fontBold, fontItalic, xAxisTitle, yAxisTitle, title, show3D, xOffset, yOffset, rotated, showLegend, labelFormat, labelMask, tipStyle, tipBGColor, showMarkers, markerSize, pieSliceStyle, url, sortXAxis, xAxisType, yAxisType, returnAsInputStream. 

Steps to Reproduce:

Actual Result:

Expected Result:

Any Workarounds:

Attachments:

Comments:

@spencer could you please share the code in which you are facing this issue.
Comment by Dattanand M.
1263 | February 03, 2017 05:44:43 AM GMT
@spencer If you are still facing this issue, please share with the repro code so that we can investigate from our side.
Comment by Dattanand M.
1264 | September 17, 2017 08:09:02 AM GMT
We are unable to repro this issue. If you still face this issue please share with us the repro code so that we can reopen this bug.
Comment by Dattanand M.
1265 | October 09, 2017 04:50:21 AM GMT