tracker issue : CF-4198589

select a category, or use search below
(searches all categories and all time range)

Method invocation through ajaxproxy fails even if the required arguments are passed .

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/Fixed

Reporter/Name(from Bugbase): / ()

Created: 05/04/2017

Components: AJAX, Plumbing

Versions: 2016

Failure Type: Incorrectly functioning

Found In Build/Fixed In Build: 302561 / Verified in the patch provided.

Priority/Frequency: Major / Some users will encounter

Locale/System: /

Vote Count: 2

Listed in the version 2016.0.05.303689 Issues Fixed doc
Problem: Method invocation through ajaxproxy fails even if the required arguments are 
                passed .

Method: copy and paste the below code in a cfm file 

<script type="text/javascript">
function foobar(fname, lname){
	    //alert(fname + ", " + lname);
		t1 = new temp();
		t1.testAjax(fname, lname);

<cfset fname="S">
<cfset lname="K">	

<cfform format="html">
<cfinput type="textbox" name="firstName" value="#fname#"/> 
<cfinput type="textbox" name="lastName" value="#lname#"/> 
<cfinput type="button" name="test" onClick="foobar('#fname#','#lname#');"/> 
<cfajaxproxy cfc="test" jsclassname="temp"/>

Copy and paste the below code in a cfc and name it as test.cfc

<cfcomponent >
	<cffunction name="testAjax" access="remote">
		<cfargument type="string" name="arg1" required="true">
		<cfargument type="string" name="arg2" required="true">
		<cfdump var="#arguments#" format='text' output="c:\testAjax.txt">
		<cfreturn "hello!">

Even if the required arguments are passed it throws argument error

Result:coldfusion.runtime.MissingArgumentException: The ARG1 parameter to the testAjax function is required but was not passed in.

Expected: method should be invoked without any errors.




  1. May 23, 2017 00:00:00: hf201600-0000000.jar


Fix for this bug is enclosed as a jar file in the bug attachments. Download and paste the jar file in the <Coldfusion Home>\cfusion\lib\updates an then restart the CF. If you still face this issue, please let us know.
Comment by Dattanand M.
811 | May 23, 2017 10:33:24 AM GMT
That does appear to fix the issue. Thank you.
Comment by Matthew G.
812 | May 23, 2017 01:31:50 PM GMT
I can also confirm that this attached jar has resolved a similar U2 to U4 upgrade issue. Once we placed the jar file in the classpath it allowed the cfajaxproxy calls to function.
Comment by Mike C.
813 | June 07, 2017 06:38:46 PM GMT
Yes, fixed issue for us also. Hope this is included in next official update.
Comment by John S.
814 | June 07, 2017 07:07:11 PM GMT
John, Yes this would be part of next update.
Comment by HariKrishna K.
815 | June 08, 2017 04:38:12 AM GMT
When will Update 5 be released assuming this will be part of it? Thanks!
Comment by Tim B.
816 | August 15, 2017 06:01:05 PM GMT
We cannot commit to a timeline at this point but this bug fix will be part of the update.
Comment by Vamseekrishna N.
817 | August 16, 2017 03:28:45 AM GMT
I am not able to install the hotfix: C:\temp>c:\coldfusion2016\jre\bin\java -jar hf201600-0000000.jar Error: Invalid or corrupt jarfile hf201600-0000000.jar
Comment by Jürgen W.
818 | August 31, 2017 07:16:22 AM GMT
This was fixed with CF2016.5
Vote by Bernhard D.
819 | September 29, 2017 03:29:49 PM GMT
Like others I have been experiencing this problem with cfajaxproxy in CF 2016 ("Use cfajaximport tag to specify SCRIPTSRC or make sure all ajax controls are inside a single cfform tag that has SCRIPTSRC.") I found the link to this tracker item through the posting on I tried copying the supplied jar file into C:\ColdFusion2016\cfusion\lib\updates, and restarted the PC. (Perhaps I am not doing what is required?) In any event, there has been no change. I still get the error.
Comment by John P.
31086 | July 31, 2019 02:06:00 PM GMT