tracker issue : CF-4201058

select a category, or use search below
(searches all categories and all time range)
Title:

CFLDAP Timeout Value Less Than 158 Causes Error.

| View in Tracker

Status/Resolution/Reason: To Track//PRNeedInfo

Reporter/Name(from Bugbase): Mikeal Parfrey / Mikeal Parfrey ()

Created: 02/06/2018

Components: Net Protocols, LDAP

Versions: 2016,13.0

Failure Type: Incorrectly functioning

Found In Build/Fixed In Build: 2016.0.05.303689 /

Priority/Frequency: Minor / Unknown

Locale/System: ALL / Win 2016

Vote Count: 0

Problem Description:

Setting a timeout value of less than 158 in the CFLDAP timeout paramater causes an error.

Steps to Reproduce:

Add timeout="157" to a valid CFLDAP query tag.

Actual Result:

Error is reported: 
Error Message - An error has occurred while trying to execute query :192.168.1.210:389.
Error Detail - "One or more of the required attributes may be missing or incorrect or you do not have permissions to execute this operation on the server."

Expected Result:
A successful LDAP query is performed.

Any Workarounds:
Increase the timeout value to 158 or greater.

Attachments:

Comments:

Hi Mikeal Parfrey, This issue would be happening because your particular testcase might be taking more than 158s to complete. So, we would be fixing the exception that is currently being thrown to be an appropriate timeout exception. Thanks!
Comment by S P.
118 | February 08, 2018 04:47:21 AM GMT
Hi, If it is an actual timeout then I would suggest throwing a timeout exception instead of the error reported, as it is misleading. Thanks. Mikeal
Comment by Mikeal P.
119 | March 13, 2018 05:22:23 PM GMT
Hi Mikeal, In order to confirm if this is just exception issue, could try the following: Can you tell me the behavior when:  1.you specify a smaller value (say 10,50) 2.you specify a larger value 3.No timeout value Thanks!
Comment by S P.
29648 | August 30, 2018 06:51:16 AM GMT
Hi Mikeal, Tried with a simple test below: <cfldap server = "#sHost#" port=389 action = "query" name = "res" start = "dc=example,dc=com" filter = "uid=*" username="uid=admin,ou=system" password="administrator" attributes="*" timeout=1> <cfdump var="#res#"> It works on both CF 2016 and CF 2018.  Let me know if i'm missing something here? Please share your snippet to repro the issue.
Comment by HariKrishna K.
30042 | December 12, 2018 05:59:32 AM GMT