tracker issue : CF-4201309

select a category, or use search below
(searches all categories and all time range)
Title:

cfpdfform - "java.lang.NoClassDefFoundError: Could not initialize class com.adobe.xfa.AppModel"

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/CannotReproduce

Reporter/Name(from Bugbase): Cody W / Cody W ()

Created: 02/22/2018

Components: Document Management, PDF Form

Versions: 2016

Failure Type: Non Functioning

Found In Build/Fixed In Build: 2016.0.05.303689 /

Priority/Frequency: Normal / Unknown

Locale/System: / Win 2012 Server x64

Vote Count: 0

Problem Description:
Intermittently, it seems that cfpdfform quits working completely. What causes the server to reach this state is unknown. Seemingly randomly, ColdFusion will begin to throw an exception when you try to populate a PDF form. I'm reporting this as a bug because it doesn't seem that CF should ever be unable to find a class definition for the class in question.

Steps to Reproduce:
I've attached a test case, but I don't know if you'll be able to reproduce the issue. Hopefully the attached exception message is informative. 

Actual Result:
"java.lang.NoClassDefFoundError: Could not initialize class com.adobe.xfa.AppModel". I've attached a text file with the full exception stacktrace for your reference. 

Expected Result:
A PDF form to be generated and sent to the browser.

Any Workarounds:
A ColdFusion Restart seems to get the tag working again as expected.

Attachments:

  1. February 22, 2018 00:00:00: cfpdfform_error (1).txt
  2. February 22, 2018 00:00:00: pdfformtag.zip

Comments:

I would like to also point out that this issue was introduced with a recent ColdFusion update. Either update 4 or update 5. Previously this server was running update 3, and the issue began after applying this patch. Additionally, I've now been able to confirm the same issue with another recently updated ColdFusion 2016 server.
Comment by Cody W
98 | February 23, 2018 12:58:09 AM GMT
Thanks Cody for reporting this issue. We will get it checked and let you know in case we need additional information.
99 | February 23, 2018 03:31:27 AM GMT
Hi Cody, Can you please provide us with a few answers? 1. Can you please tell us the update level on which ColdFusion server is running? 2. Also, is your ColdFusion server configured with a cluster, and if yes, are all the nodes of the cluster in the same update level? 3. When you see the issue next time, can you please tell us the size of cf-acrobat jar at that moment? Its present in [ColdFusion Home]\[Instance Name]\lib folder Thanks, Kailash
Comment by Kailash Bihani
100 | March 09, 2018 11:05:37 AM GMT
Hi Cody,   Can you please reply with the information asked in a previous comment?   Thanks, Kailash
Comment by Kailash Bihani
29558 | August 21, 2018 05:52:03 AM GMT
Closing it for now as I was unable to reproduce the issue. If Cody comes back with the answers, will reopen it.
Comment by Kailash Bihani
29694 | September 12, 2018 06:35:00 AM GMT