tracker issue : CF-4201447

select a category, or use search below
(searches all categories and all time range)

neo-websocket.xml is installed as a blank file

| View in Tracker

Status/Resolution/Reason: Closed/Withdrawn/Duplicate

Reporter/Name(from Bugbase): Chad Adamson / Chad Adamson ()

Created: 03/06/2018

Components: Installation/Config, Installer

Versions: 2016

Failure Type: Others

Found In Build/Fixed In Build: ColdFusion 2016 Standard Trial /

Priority/Frequency: Normal /

Locale/System: / Win 2012 Server x64

Vote Count: 0

Unable to initialise WebSocket service: coldfusion.server.ServiceException: [C:\ColdFusion2016\cfusion\lib\neo-websocket.xml]coldfusion.wddx.WddxDeserializationException: WDDX packet parse error at line -1, column -1. Premature end of file..

neo-websocket.xml is installed as a blank file.

This causes WebSocket under Server Settings in the Administrator to throw an error.

I tried the installation on 2 different servers running Windows Server 2012 R2 Standard and got the same results.
Installer log reports the installation of neo-websocket.xml as a success.

I had to find a copy of the file on the internet to replace the blank one.



Hi, Can you let me know which installer are you trying it on (the build number)? It can be found by logging in to ColdFusion Administrator and clicking on the i icon on top right icon. We do run our QE side tests on fresh installations and have never seen this issue. In fact i just tried installing the update 3 installers for ColdFusion 2016 and checked the lib folder, and the neo-websocket.xml file was present. If you still see this issue, can you share the ColdFusion installation logs with us? If even that doesn't resolve the issue, we can go in a call to verify the issue Thanks, Kailash
Comment by Kailash B.
27524 | April 13, 2018 12:05:40 PM GMT