tracker issue : CF-4202005

select a category, or use search below
(searches all categories and all time range)

Installer Errored

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/Fixed

Reporter/Name(from Bugbase): Peter Freitag / ()

Created: 04/17/2018

Components: Installation/Config, Lockdown Installer

Versions: 2018

Failure Type: Incorrectly functioning

Found In Build/Fixed In Build: Public Beta / 309353

Priority/Frequency: Major / Unknown

Locale/System: ALL / Win 2016

Vote Count: 0

Problem Description: I got an error running the lockdown installer - see attached log file.

Steps to Reproduce:

Started with a fresh Windows 2016 server on EC2. Installed IIS. Deleted the Default Web Site, created two new websites and and created a folder under c:\sites\ for both sites.

Ran the ColdFusion installer in Secure Profile Mode, Connected CF to ALL IIS Sites. Created a test.cfm and confirmed that CF was working through IIS.

Next I ran the Lockdown installer (as Administrator), went through the wizard (I think you should have all the details as to what I selected from the log file).

Actual Result: Errors (see attached log)

It seamed like much of it worked but when it got to configuring the connector it was starting to get errors. 

Now what is interesting is that the log file says Connector is not configured (even though I did that for ALL IIS sites during CF installation). It then created two new connector instances (connector 1 was from my initial CF installation, then the lockdown installer created 2 and 3 for each site). It seams that the lockdown installer wants to create connectors for each site.

Configuring the connector for ColdFusion
Checking if connector already configured!
Connector is not configured!
Configuring the connector for: IIS for the website:
Connector was configured successfully!
Checking if connector already configured!
Connector is not configured!
Configuring the connector for: IIS for the website:
Connector was configured successfully!
Successfully configured the connector for ColdFusion
Setting up file system permissions for ColdFusion
Now trying to change folder permissions for ColdFusion folder!
Website name is:
Website name is:
Website name is: ERROR ( hresult:80070002, message:Command execution failed.  

The system cannot find the file specified.

Getting backup of old folder permissions

Some of the errors (see attached log file for all):

Change Permissions of ColdFusion file system: Error Logs
C:\ColdFusion2018\cfusion\..\config\wsconfig\1\isapi_redirect.log: Access is denied.

Permissions changed for the user: ColdFusion2018 for the path: C:\ColdFusion2018\cfusion\..\ java.lang.NullPointerException

Expected Result: No Errors

Any Workarounds: Not sure.



Hi, Can you please attach the log file created at: [ColdFusion Home]\lockdown\lockdown_logs.txt? It will help us in debugging the issue. Thanks, Kailash
Comment by Kailash B.
27457 | April 18, 2018 04:25:58 AM GMT
Hi Kailash - I have attached the log file -- I thought I did when I posted the bug, but it apparently didn't post -- let me know if you have any questions.
Comment by Peter F.
27458 | April 18, 2018 06:18:13 PM GMT
Hi Pete, Got the issue. Its happening for connector configured for "All" We will be fixing this and dropping a new build in a week or 2. Thanks, Kailash
Comment by Kailash B.
27459 | April 19, 2018 05:31:11 AM GMT
Hi Kailash - looks like the new build has not been posted yet, would be great to get that up on the public beta download site.
Comment by Peter F.
27739 | May 10, 2018 08:07:36 PM GMT